• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Can't Mount Database in RSG

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> General >> Can't Mount Database in RSG Page: [1]
Login
Message << Older Topic   Newer Topic >>
Can't Mount Database in RSG - 15.Feb.2008 3:38:37 PM   
altima98

 

Posts: 3
Joined: 15.Feb.2008
Status: offline
Hi,

Looking for help, I am trying perform a mailbox restore using the RSG, how ever when I attempt to mount the database for RSG I recieve this error.

Error encountered while trying to mount the database (Mailbox Database) in the recovery storage group (Exchange Server - Recovery Storage Group -2-15-08). Error message is: Exchange is unable to mount the database that you specified. Specified database: ExchangeServer\ExchangeServer - Recovery Storage Group -2-15-08\Mailbox Database; Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-550) ..

I have tried different back ups, I have restored to alternate folder then moved it into the RSG. I have tried using the powershell to mount it, no luck.

Any suggestions would be appreciated

Thanks in advance.
Post #: 1
RE: Can't Mount Database in RSG - 15.Feb.2008 3:46:50 PM   
John Weber

 

Posts: 1236
Joined: 20.Apr.2005
From: Portland, Oregon
Status: offline
Interesting.
Is the recovery database you restored in a consistent state?
How was the db backup taken?
Have you tried eseutil/isinteg against the restored db?

(in reply to altima98)
Post #: 2
RE: Can't Mount Database in RSG - 15.Feb.2008 4:10:26 PM   
altima98

 

Posts: 3
Joined: 15.Feb.2008
Status: offline
It was taken with Backup Exec 11D
As Far as I can tell it is in a consistent state
-forgot to add I can view the store and whats in it via PowerControls 5.0 trial
I have been debating about running the esenutil, but have held of to see if anyone else experienced anything similar.

(in reply to John Weber)
Post #: 3
RE: Can't Mount Database in RSG - 17.Feb.2008 3:14:49 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi mate,

If your database is clean shutdown...
Go to RSG Folder and remove all other files except the .edb (mailbox database.edb)

Clear up the application log
and then try to mount the RSG database.
Make a note of your eventid and description.

If it is failed then clear up the application log and then go for disaster recovery tool under toolbox run the database tool (to know why database is not mounted) and make a note of your eventid and exbpa analyzer information.

(in reply to altima98)
Post #: 4
RE: Can't Mount Database in RSG - 3.Mar.2008 3:49:49 PM   
altima98

 

Posts: 3
Joined: 15.Feb.2008
Status: offline
Solution was to run a ESEUTIL /P then /D and ISINTEG as suggested 

Database mounts and was able to merge a mailbox which works well.

Thanks

(in reply to ismail.mohammed)
Post #: 5
RE: Can't Mount Database in RSG - 1.May2008 5:08:59 AM   
atedja

 

Posts: 64
Joined: 14.Apr.2008
Status: offline
i tried in CMD Prompt "ESEUTIL /P" it gives me an error message ?

which database name should I put ?

_____________________________

/* I Appreciate all kinds of response */

(in reply to altima98)
Post #: 6
RE: Can't Mount Database in RSG - 2.May2008 1:06:59 PM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi mate,

you need to run the command for priv1.edb or RSG.edb database.
can you past the error

(in reply to atedja)
Post #: 7
RE: Can't Mount Database in RSG - 3.May2008 10:04:26 AM   
atedja

 

Posts: 64
Joined: 14.Apr.2008
Status: offline
C:\Documents and Settings\ADMINISTRATOR.ITREEW>eseutil /P
Extensible Storage Engine Utilities for Microsoft(R) Exchange Server Version 08.01
Copyright (C) Microsoft Corporation. All Rights Reserved.
 
Usage Error: Missing source database specification.
Operation terminated with error -1003 (JET_errInvalidParameter, Invalid API parameter) after 0.0 seconds.

thanks for replying my message.


_____________________________

/* I Appreciate all kinds of response */

(in reply to ismail.mohammed)
Post #: 8
RE: Can't Mount Database in RSG - 4.May2008 10:15:12 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi mate,

can you copy the database on non-exchange server and perform hard repair
http://support.microsoft.com/kb/244525/en-us

(in reply to atedja)
Post #: 9
RE: Can't Mount Database in RSG - 7.May2008 1:29:43 AM   
atedja

 

Posts: 64
Joined: 14.Apr.2008
Status: offline
Hi All,

thanks for responding my thread.

it is now partly fixed, the Public folder can now be access again by using eseutil /p "path to database\database.edb".

however,

i still got this error message:

15:28:26 Synchronizer Version 12.0.6300
15:28:26 Synchronizing Mailbox 'Albert Widjaja Tedjadiputra'
15:28:26 Synchronizing Hierarchy
15:28:26 Done
15:28:26 Microsoft Exchange offline address book
15:28:26                                 Not downloading Offline address book files.  A server (URL) could not be located.
15:28:26                0X8004010F

any idea of how this might be fixed ?

_____________________________

/* I Appreciate all kinds of response */

(in reply to ismail.mohammed)
Post #: 10
RE: Can't Mount Database in RSG - 7.May2008 7:27:44 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi mate,

Confirm that your mailbox store is associated with OAB.
you can do a test of creating new one and associating it

(in reply to atedja)
Post #: 11
RE: Can't Mount Database in RSG - 7.May2008 7:38:16 AM   
atedja

 

Posts: 64
Joined: 14.Apr.2008
Status: offline
Hi Ismail,

do you mean I should create new Mailbox and then check it whether is it listed in the Address book or not ?

_____________________________

/* I Appreciate all kinds of response */

(in reply to ismail.mohammed)
Post #: 12
RE: Can't Mount Database in RSG - 7.May2008 8:06:34 AM   
ismail.mohammed

 

Posts: 3018
Joined: 9.May2007
From: India
Status: offline
hi mate,

Go to maibox store properties => General Tab => you will see Default OAB associated with your mailbox store.

Go to Offline Address Book => Createa New OAB callled as Test OAB, schedule it for just for testing purpose (preferred would be during off peak hours) then associate this test oab to your mailbox store & restart your exchange services
wait for a while and then check that out.

(in reply to atedja)
Post #: 13

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> General >> Can't Mount Database in RSG Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter