• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Connection issue: Please correct your exchange server password

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Connection issue: Please correct your exchange server password Page: [1]
Login
Message << Older Topic   Newer Topic >>
Connection issue: Please correct your exchange server p... - 30.Apr.2008 8:42:20 PM   
hotdog

 

Posts: 5
Joined: 30.Apr.2008
Status: offline
Howdy folks.

First off, I recently was volunteered to help a friend fix up Exchange at his office; joy! My first task was a simple one: Fix the SSL Certificate issue, namely, the certificate they were using was expired, giving all sorts of exciting errors when people logged in; security warnings and such.

Having replaced the SSL Certificate with no hassle (purchased one through RapidSSL, FWIW), that problem was down.

My next task is this: They don't have many mobile users. Primarily, they have... oh, let's see, 10? If that? Right now, they're just syncing up their phones at their desktops. But, since Exchange 2007 is so awesomely easy to add mobile phones, I figured we could do that for them.

SSL wise, I got the certificate loaded in my Windows Mobile 6 phone, a PPC-6700 if it matters. It logs on to OWA with no issues, no SSL errors, and is secure; good times. Port wise, port 443 is open, hence the fact https://mail.domainname.com/owa works. I don't believe it's a firewall issue.

The issue, however, is with syncing it up wirelessly. It comes back with this error, each and every time:
"Please correct your Exchange server password"

Now, from my search online, most of it points to an SSL issue, with a combonation of using forms to log in on OWA, and mobile devices. The problem is, I don't know how it SHOULD be set up to work w/ mobile devices.

As it stands now, the "Default Website" is using the SSL Certificate we purchased, so EVERY Virtual Directory is also using this Certificate. I feel my issue stems from this; is there a directory that SHOULDN'T (and changing it to not using it wouldn't be an issue) have SSL Enabled?

As mentioned before, I believe I read that it had something to do with using the forms authentcation instead of the "lol annoying pop up". We'd rather use the "neato friendly looking forms authentication" if at all possible, so I'm sure there's some work around.

Please, let me know your ideas. I'm more than happy to post screenshots, provides answers, anything. He's starting to bug me about this :D

Oh, and FWIW: The password/username I'm using is correct, and I've tried it every which-way: domain\username, username, etc, etc, to try to eliminate that as an issue.
Post #: 1
RE: Connection issue: Please correct your exchange serv... - 30.May2008 4:50:44 PM   
romrunning

 

Posts: 50
Joined: 13.May2008
Status: offline
Did you use the EMS to get/enable your new SSL cert? 

Also, domain name can be a problem; make sure it's a FQDN.

(in reply to hotdog)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Connection issue: Please correct your exchange server password Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter