• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

2007 wont install as deceased 2003 server wasnt sp2

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Installation >> 2007 wont install as deceased 2003 server wasnt sp2 Page: [1]
Login
Message << Older Topic   Newer Topic >>
2007 wont install as deceased 2003 server wasnt sp2 - 2.May2008 8:24:29 AM   
gurner7878

 

Posts: 9
Joined: 25.Jan.2005
From: England
Status: offline
I have a site at the moment, that had 2 DCs, one with all the roles, the other with Exch2003.

Exch2k3 wasnt being used, but they bought a full install of 2007.  while i was away the 2003 box died and is no more.

i came in, settled down AD etc as they just threw away the server.

i have installed a new 2003 server, added it to the domain, i have one step on the 2007 install that fails, it says the Exchange 2003 server is not in not in native mode and was not running SP2

this server it is referring to is no more, so im guessing it is coming from AD.

Does anyone know of a way to fool the 2007 install or something?  i need this server on, but it is being stopped by obsolete information.

i have already done a Metadata Cleanup and removed AD references to the old server, but this obviously didnt include the Exchange stuff.

Cheers

Gurner
Post #: 1
RE: 2007 wont install as deceased 2003 server wasnt sp2 - 2.May2008 8:28:54 AM   
mark@mvps.org

 

Posts: 6811
Joined: 9.Jun.2004
From: Philadelphia PA
Status: offline
Use: http://www.msexchange.org/tutorials/Remove-Exchange-server-entire-Exchange-organization.html (only the bits you need!!!!) to rip the 2003 box out of the mix. You'll be ok to go forward then.

Better? Install Exchange 2003 with the /disasterrecovery switch. Do it in a virtual machine so you're not wasting hardware. Then make sure the Exchange is in native mode and install the 2007 environment. Uninstall the Exchange 2003 box in the normal way afterwards.

_____________________________

Mark Arnold (Exchange MVP)
List Moderator

(in reply to gurner7878)
Post #: 2
RE: 2007 wont install as deceased 2003 server wasnt sp2 - 2.May2008 9:00:52 AM   
gurner7878

 

Posts: 9
Joined: 25.Jan.2005
From: England
Status: offline
cool, cheers.  i'm just going to pour over that first one and give it a go, but that 2nd one sounds alright.

Thanks

Regards

(in reply to mark@mvps.org)
Post #: 3
RE: 2007 wont install as deceased 2003 server wasnt sp2 - 2.May2008 9:24:06 AM   
gurner7878

 

Posts: 9
Joined: 25.Jan.2005
From: England
Status: offline
as exchange doesnt physically exist anywhere at a file or registry level, just pointers in the AD Configuration and Domain (in ADSIedit.msc) there are no services or what not, so part of a solution im going to try is running the 2k3 setup.exe /removeorg switch then try 2007, problem is (ha!) is that im at a geographically different location to the 1st DC, and the one im using to install 2007 is x64 in a Datacentre, and the setup kit for 2003 wont run on it, so im transferring the 2k3 CD over a VPN to the x86 2003 DC with the obsolete Exchange records in AD

typical, lol

(in reply to gurner7878)
Post #: 4
RE: 2007 wont install as deceased 2003 server wasnt sp2 - 2.May2008 9:31:08 AM   
gurner7878

 

Posts: 9
Joined: 25.Jan.2005
From: England
Status: offline
i looked thorugh adsiedit and thought surely there are loads that need removing or amending, but if this is it it will be cool
------------------
1. Click Start, point to Programs, point to Windows 2000 Support Tools, point to Tools, and then click ADSI Edit. 2.Expand each of the following items: Configuration Container
CN=Configuration, DC=Domain_Name,DC=com
CN=Services
CN=Microsoft Exchange
CN=Your_Organization_Name
CN=Administrative Groups
CN=Your_Administrative_Group_Name_Or_Exchange5.5_Site_Name
CN=Servers
Note In this procedure, Domain_Name is a placeholder for the name of your domain, Your_Organization_Name is a placeholder for the name of your organization, and Your_Administrative_Group_Name_Or_Exchange5.5_Site_Name is a placeholder for the name of your administrative group or Exchange 5.5 site.3.Right-click the Exchange 2003 server object, and then click Delete. 4.Click Yes in every adsiedit dialog box that prompts you to confirm the deletion.----------------------

no doubt the same steps for 2003 as 2000

(in reply to gurner7878)
Post #: 5
RE: 2007 wont install as deceased 2003 server wasnt sp2 - 2.May2008 9:34:30 AM   
gurner7878

 

Posts: 9
Joined: 25.Jan.2005
From: England
Status: offline
it worked to get rid of the prompt about no SP2 on the non-existent exchange server, but hasn't stopped the prompt about the Exchange Org not being in native mode, doh

(in reply to gurner7878)
Post #: 6
RE: 2007 wont install as deceased 2003 server wasnt sp2 - 2.May2008 9:42:44 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Were there ever any users created in the Exchange environment? So currently you do NOT have any server objects listed in ADSIEdit under the exchange organization, correct?

If not, then I would recommend deleting the organization and starting with a fresh install of Exchange 2007. There are just too many possible issues that are coming to my mind right now with your configuration.

Another option would be to actually install a new exchange 2003 server preferably in on a virtual machine, upgrade it to SP2 and change the exchange organization mode to native. That should allow you to install exchange 2007.

< Message edited by de.blackman -- 2.May2008 9:46:45 AM >


_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to gurner7878)
Post #: 7
RE: 2007 wont install as deceased 2003 server wasnt sp2 - 2.May2008 9:55:26 AM   
gurner7878

 

Posts: 9
Joined: 25.Jan.2005
From: England
Status: offline
there were users setup, with only '@domainname.internal' addresses, but they werent used as everyone had delivery in Outlook set to a local Personal Folder, so there are a load of references to objects in AdsiEdit.

if just deleting the Exchange Organisation from ADSIedit is ok, i'll give that a go

Though, i have a copy of QEMU firing up to try putting another win2003 server on and put Exch2003 and try raising that way, rather than remove it.

i guess this will be the best option, but if deletion is ok, that could be a backup

you reckon just CN=Configuration>CN=Services>CN=Microsoft Exchange>CN='organisation name' will be ok?

Cheers

(in reply to de.blackman)
Post #: 8
RE: 2007 wont install as deceased 2003 server wasnt sp2 - 2.May2008 11:00:50 AM   
gurner7878

 

Posts: 9
Joined: 25.Jan.2005
From: England
Status: offline
bit the bullet and deleted the organisation name, and it has at last got past the Readiness Checks to start an install.

it popped up 'organisation removed' when i tried the /removeorg switch, but bombed out and reversed it all when it couldn't find any physical exchange files on the disk partition.

(in reply to gurner7878)
Post #: 9

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Installation >> 2007 wont install as deceased 2003 server wasnt sp2 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter