• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Outbound SMTP not working

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Outbound SMTP not working Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
Outbound SMTP not working - 12.May2008 11:50:50 AM   
bhavin78

 

Posts: 138
Joined: 28.Jul.2005
From: USA
Status: offline
I have published exchange 2003 via ISA server 2006.
My outbound mail is not working, how do I troubleshoot this? I am trying this on Lab environment. I am using dnydns.org as I have dynamic IP address.
When I try to send email to my gmail account, in the ISA log I can see it's trying to contact Gmail SMTP server.

Heres my network diagram:

DSL
Linksys Router

VMWARE Server:
ISA [3 NIC] (ISA server is not a domain member)
Exchange,DC on INT network
Web Server and FTP Server on DMZ


Post #: 1
RE: Outbound SMTP not working - 13.May2008 9:11:04 AM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Manually create/send a message from your ISA server to an outside server (like Gmail).  You may get useful information from the responses.

Using Telnet to simulate server communication

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to bhavin78)
Post #: 2
RE: Outbound SMTP not working - 13.May2008 10:08:15 AM   
bhavin78

 

Posts: 138
Joined: 28.Jul.2005
From: USA
Status: offline
This what I tried from exchange server as exchage server is my smtp server. It's not working for me, I guess I am doing something wrong.

bhavin.us is my domain name.
telnet bhavin.us 25
220 W2K3-EXCH1.zhc.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959 read
y at  Tue, 13 May 2008 10:18:59 -0400
ehlo bpatel.dyndns.org
250-W2K3-EXCH1.zhc.com Hello [192.168.1.1]
250-TURN
250-SIZE
250-ETRN
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-8bitmime
250-BINARYMIME
250-CHUNKING
250-VRFY
250-X-EXPS GSSAPI NTLM LOGIN
250-X-EXPS=LOGIN
250-AUTH GSSAPI NTLM LOGIN
250-AUTH=LOGIN
250-X-LINK2STATE
250-XEXCH50
250 OK
mail from:bhavin78@bhavin.us
500 5.5.1 Unrecognized command
mail from:bhavin78@bhavin.us
500 5.5.1 Unrecognized command
Mail From:bhavin78@bhavin.us
250 2.1.0 bhavin78@bhavin.us....Sender OK
rcpt to:bhavin78@gmail.com
500 5.5.1 Unrecognized command
RCPT to:bhavin78@gmail.com
501 5.5.4 Invalid Address
rcpt to:bhavin78@gmail.com
550 5.7.1 Unable to relay for bhavin78@gmail.com

 
This is what I will try next
rcpt to bhavin78@gmail.com
data
subject:test via telnet
Please reply if received
.
quit

< Message edited by bhavin78 -- 13.May2008 10:21:34 AM >

(in reply to uemurad)
Post #: 3
RE: Outbound SMTP not working - 13.May2008 10:27:25 AM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
"mail from" should not return a "unrecognized command" response.  Telnet doesn't have a backspace capability - please retry the sequence.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to bhavin78)
Post #: 4
RE: Outbound SMTP not working - 13.May2008 2:45:53 PM   
bhavin78

 

Posts: 138
Joined: 28.Jul.2005
From: USA
Status: offline
Mail From:bhavin78@bhavin.us
250 2.1.0 bhavin78@bhavin.us....Sender OK

rcpt to:bhavin78@gmail.com
550 5.7.1 Unable to relay for
bhavin78@gmail.com

unable to realy is the error

< Message edited by bhavin78 -- 13.May2008 3:24:40 PM >

(in reply to uemurad)
Post #: 5
RE: Outbound SMTP not working - 13.May2008 5:34:55 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
It looks like you are telnetting to your own domain name and not to the Gmail server.  You can't send a message to Gmail from your ISA server through your Exchange server.

First you use NSLookup to discover where SMTP mail to Gmail should go (gmail.com).
Then you use that FQDN to telnet. 
This test is how a message would travel from your ISA server to the outside world.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to bhavin78)
Post #: 6
RE: Outbound SMTP not working - 13.May2008 7:48:13 PM   
bhavin78

 

Posts: 138
Joined: 28.Jul.2005
From: USA
Status: offline
telnet gsmtp147.google.com 25
Connecting To gsmtp147.google.com...
Could not open connection to the host, on port 25: Connect failed
Logs on Firewall says SMTP connection on port 25 initiated.

(in reply to bhavin78)
Post #: 7
RE: Outbound SMTP not working - 13.May2008 11:55:20 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Having port 25 closed or restricted would definitely cause outbound mail to fail.  You need to investigate it at both the ISA server and any firewalls/routers touching the outbound messages.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to bhavin78)
Post #: 8
RE: Outbound SMTP not working - 15.May2008 10:25:02 AM   
bhavin78

 

Posts: 138
Joined: 28.Jul.2005
From: USA
Status: offline
I manually tried to send email to yahoo account and this is what I get. What authentication is it looking for?
I did scan my exchange and ISA server an port 25 is opened on both server

telnet smtp.att.yahoo.com 25
elho yahoo.com
220 smtp119.sbc.mail.re3.yahoo.com ESMTP
ehlo yahoo.com
250-smtp119.sbc.mail.re3.yahoo.com
250-AUTH LOGIN PLAIN XYMCOOKIE
250-PIPELINING
250 8BITMIME
mail from:bhavin78@bhavin.us
530 authentication required - for help go to http://help.yahoo.com/help/us/sbc/d
sl/mail/pop/pop-11.html

(in reply to uemurad)
Post #: 9
RE: Outbound SMTP not working - 15.May2008 10:53:24 AM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
It looks like you've hit a POP3 access point.  If you are attempting to send a message to a yahoo mailbox from the outside, the MX records indicate:

a.mx.mail.yahoo.com
b.mx.mail.yahoo.com (through "g")

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to bhavin78)
Post #: 10
RE: Outbound SMTP not working - 15.May2008 2:38:47 PM   
bhavin78

 

Posts: 138
Joined: 28.Jul.2005
From: USA
Status: offline
I tried to telnet a.mx.mail.yahoo.com 25 and here is the error
Could not open connection to the host, on port 25: Connect failed
Logs on Firewall says SMTP connection on port 25 initiated.
and
Port 25 is opened on both FW and Exchange Server.

Note: I use AT&T DSL Service. I have dynamic IP, is it possilbe that they might be blocking it?

Do I have other option ? What I am doing it just for test lab.


(in reply to uemurad)
Post #: 11
RE: Outbound SMTP not working - 15.May2008 3:49:35 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Try it with a different recipient domain.  gmail.com or hotmail.com.  It sounds like port 25 isn't open to you.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to bhavin78)
Post #: 12
RE: Outbound SMTP not working - 15.May2008 4:11:27 PM   
bhavin78

 

Posts: 138
Joined: 28.Jul.2005
From: USA
Status: offline
cannot connect to hotmail or google.

what are my other options?
check this out, http://helpme.att.net/article.php?item=287
do I have to configure port 465 with authetication?

< Message edited by bhavin78 -- 15.May2008 4:33:11 PM >

(in reply to uemurad)
Post #: 13
RE: Outbound SMTP not working - 15.May2008 4:41:31 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Port 25 is not open for an outbound connection from your server to the Internet.  It is likely that AT&T DSL doesn't allow it - especially if you are using a home connection.  Check with them.

It is also possible that they require you to send outbound mail to a smarthost on a different port.  In any case, you need to talk to your ISP.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to bhavin78)
Post #: 14
RE: Outbound SMTP not working - 15.May2008 11:20:22 PM   
bhavin78

 

Posts: 138
Joined: 28.Jul.2005
From: USA
Status: offline
I configured outlook express with incoming and outgoing mail server. I used Port 587 with userID/Pswd. With this settings I was able to send and receive email to my gmail account. But the same setting did not work with SMTP server.

is the Smart Host going to be different than the above setting? I am going to call AT&T and find out.

(in reply to uemurad)
Post #: 15
RE: Outbound SMTP not working - 16.May2008 10:53:45 AM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
Configuring a client is different than configuring a mail server.  Outlook Express will pull the messages from a host server (typically using POP3).  Exchange communicates with other SMTP servers.  It is possible that your ISP requires forwarding through one of their systems in one or both directions.  This is usually to cut down on the amount of unauthorized traffic (spam) that goes through it.

Post the results of what you find out from AT&T.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to bhavin78)
Post #: 16
RE: Outbound SMTP not working - 16.May2008 1:49:28 PM   
bhavin78

 

Posts: 138
Joined: 28.Jul.2005
From: USA
Status: offline
I called AT&T and they told me that I use my SMTP server to send email and there is nothing they can do to help me. They told me that port 25 was blocked and they opened it for me.
I now try to telnet different server (gmail, hotmail, yahoo) , it still not working.
Google:
220 mx.google.com ESMTP c5si25533949nfi.6
ehlo bhavin.us
250-mx.google.com at your service, [68.248.73.237]
250-SIZE 28311552
250-8BITMIME
250 ENHANCEDSTATUSCODES
mail from:bhavin78@bhavin.us
555 5.5.2 Syntax error. d24si23687308nfh.2

HOTMAIL:
to Microsoft's computer network is prohibited. Other restrictions are found at h
ttp://privacy.msn.com/Anti-spam/. Violations will result in use of equipment loc
ated in California and other states. Fri, 16 May 2008 10:47:22 -0700
ehlo bhavin.us
250-bay0-mc3-f14.bay0.hotmail.com (3.5.0.22) Hello [68.248.73.237]
250-SIZE 29696000
250-PIPELINING
250-8bitmime
250-BINARYMIME
250-CHUNKING
250-AUTH LOGIN
250-AUTH=LOGIN
250 OK
mail from:bhavin78@bhavin.us
550 DY-001 Mail rejected by Windows Live Hotmail for policy reasons. We generall
y do not accept email from dynamic IP's as they are not typically used to delive
r unauthenticated SMTP e-mail to an Internet mail server. http://www.spamhaus.or
g maintains lists of dynamic and residential IP addresses. If you are not an ema
il/network admin please contact your E-mail/Internet Service Provider for help.
Email/network admins, please visit http://postmaster.live.com for email delivery
information and support

< Message edited by bhavin78 -- 16.May2008 3:34:24 PM >

(in reply to bhavin78)
Post #: 17
RE: Outbound SMTP not working - 16.May2008 3:53:29 PM   
bhavin78

 

Posts: 138
Joined: 28.Jul.2005
From: USA
Status: offline
I tried other SMTP Server and here is the result. I was able to connect to SMTP server and send email but it's still sitting in queue

220 SMTP Proxy Server Ready
ehlo bhavin.us
250-ESMTP Server Ready
250-SIZE 0
250-DSN
250-STARTTLS
250 TLS
mail from:bhavin78@bhavin.us
250 +OK Sender OK
rcpt to:bpatel@botsford.org
250 +OK Recipient OK
data
354 Start mail input, end with "<CR><LF>.<CR><LF>"
subject:Test EWmail
Test email to Bhavin.
.
250 +OK message queued for delivery.



(in reply to bhavin78)
Post #: 18
RE: Outbound SMTP not working - 16.May2008 4:31:26 PM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
If you were following the telnet instructions from my blogsite, I apologize - it needs to be updated.

In the strictest sense, the RFC for SMTP requires that addresses follow the format:

mail from:<user@domain.com>

Where the < and > characters cannot be left out.  Many systems (including Exchange) don't require them.  That is the likely reason for your connections to Gmail and Hotmail to balk.

What is the name of the queue in which your successful message is sitting?  Is it sitting in the outbound system, or in the inbound system?  According to your telnet session it should have been delivered.


_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to bhavin78)
Post #: 19
RE: Outbound SMTP not working - 16.May2008 10:37:35 PM   
bhavin78

 

Posts: 138
Joined: 28.Jul.2005
From: USA
Status: offline
quote:


What is the name of the queue in which your successful message is sitting?  Is it sitting in the outbound system, or in the inbound system?  According to your telnet session it should have been delivered.

I am not sure what you mean by what queue, I just check the queue in ESM and my mails are still sitting there.

I was able to send email to gmail with telnet session with below code, but in my gmail it says sender unkown and data what missing. I was only able to see the subject.
220 mx.google.com ESMTP 2si1164602nfv.5
ehlo bhavin.us
250-mx.google.com at your service, [68.248.73.237]
250-SIZE 28311552
250-8BITMIME
250 ENHANCEDSTATUSCODES
mail from:<bhavin78@bhavin.us>
250 2.1.0 OK
rcpt to:<bhavin78@gmail.com>
250 2.1.5 OK
data
354 Go ahead
subject:Test Email
Please reply back
.
250 2.0.0 OK 1210991374 2si1164602nfv.5

(in reply to uemurad)
Post #: 20

Page:   [1] 2   next >   >> << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Outbound SMTP not working Page: [1] 2   next >   >>
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter