• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Pulling my hair out with Autodiscover and OA

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Pulling my hair out with Autodiscover and OA Page: [1]
Login
Message << Older Topic   Newer Topic >>
Pulling my hair out with Autodiscover and OA - 21.Jul.2008 8:44:14 PM   
jez85

 

Posts: 4
Joined: 21.Jul.2008
Status: offline
Hey Guys,
Great website and community here; I've been visiting the site for the last few months and have really only just started in my 'exchange' journey.

Anyhow I'll cut to the chase

I have set up three virtual machines (server 2003); One VM acting as a DC/DNS and root ca and the other VM with exchange 2k7sp1 (cas/mailbox/hub). The DC is in charge of the domain known as DOMAIN.lab to which the exchange server belongs. The final VM is windows XP which also belongs to the DOMAIN.lab domain with outlook 2007 installed.

Ports 80 and 443 are both forwarded to my cas/mailbox/hub server and mail flow works perfectly. Receive connector has been set up as Authoritive for my external domain. I have set up SAN certificate using EMS and my root ca. This certificate is working fine internaly and on external machines using OWA once the certificate from my CA is trusted on that pc.

Now I've explained what I've got running my my problem is with Outlook Anywhere, and I think more specificly the autodiscover service because when I'm away from my home and use outlook 2007 to connect to my exchange server it fails yet on the same machine OWA will work perfectly. When using the exchange setup wizard the following occurs

1. I input details (name, email address, password)
2. Authentication window appears (I type in DOMAIN\MYUSERNAME) and pass
3. After a few moments a dialogue box pops up with the following

testmx1.DOMAIN.lab
=SMTP:myemailaddress@domain.com

I have gone into the GUI exchange management console and enabled outlook anywhere and set the external domain, I have also used the GUI to set the external address for the other CAS functions as well. I also tried using this ps script I found on exchangeninjas http://www.exchangeninjas.com/set-allvdirs

Does anyone else have any ideas

Thanks in advance,

Jeremy

< Message edited by jez85 -- 22.Jul.2008 11:24:58 PM >
Post #: 1
RE: Pulling my hair out with Autodiscover and OA - 22.Jul.2008 12:56:35 PM   
Sembee

 

Posts: 4093
Joined: 17.Jan.2008
From: Somewhere near London, UK
Status: offline
The certificate would be the first place I would be looking.
I never recommend the use of a home grown certificate for anything that is external facing. Looks poor and is a security risk.

That certificate issue will probably also mean that the autodiscover test utility at http://testexchangeconnectivity.com/ will fail as well. That would give a clue as to the source of the problem. Try it first though and see if it flags anything.

I presume you have run the best practises tool from the Toolbox.

Simon.

_____________________________

Simon Butler,
Exchange MVP
Blog: http://blog.sembee.co.uk/
Web: http://www.amset.info/
In the UK? Hire me: http://www.sembee.co.uk/
Exchange Resources: http://exbpa.com/

(in reply to jez85)
Post #: 2
RE: Pulling my hair out with Autodiscover and OA - 22.Jul.2008 11:35:13 PM   
jez85

 

Posts: 4
Joined: 21.Jul.2008
Status: offline
Yes, Best practise analyser has been ran and most things followed... obviously it alerted me to things like running x86 and being in a VM... but it's a test environment so not really worried. Again, being a test environment I didn't really want to go out and buy a certificate which is why i've gone with using an internal certificate from my CA.
 
The certificate was the only thing I didn't look at that could be causing the issue, thanks for making me think of it because I've just gone home in my lunch break and it's now working.... When setting up the server originaly I applied the certificate and then set the external URL's... I just went home and decided to reapply the certificate using the following EMS command and all is now tested and working.....
 
Enable-ExchangeCertificate –Thumbprint <thumbprint> -Services "IIS, POP, IMAP”
 
Does anyone know why it would matter what order the certificate gets applied or is this just one of those Microsoft Anomalies?

< Message edited by jez85 -- 22.Jul.2008 11:37:50 PM >

(in reply to Sembee)
Post #: 3
RE: Pulling my hair out with Autodiscover and OA - 23.Jul.2008 2:52:46 PM   
Sembee

 

Posts: 4093
Joined: 17.Jan.2008
From: Somewhere near London, UK
Status: offline
If it is a test environment and has just been built then you didn't need to do anything with certificates - the installer would have created one. Although even my test environments have valid certificates in them - it isn't a valid test system otherwise. I just move the certificates around.

As far as I am aware there is no order the certificates have to be activated in. I tend to do them one at time though using PowerGui http://www.powergui.org/

Simon.

_____________________________

Simon Butler,
Exchange MVP
Blog: http://blog.sembee.co.uk/
Web: http://www.amset.info/
In the UK? Hire me: http://www.sembee.co.uk/
Exchange Resources: http://exbpa.com/

(in reply to jez85)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Pulling my hair out with Autodiscover and OA Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter