Exchange 2007 with POPCon (Full Version)

All Forums >> [Microsoft Exchange 2007] >> Message Routing



Message


paulmh_5 -> Exchange 2007 with POPCon (2.Aug.2008 4:17:36 PM)

Hey
I have just installed Exchange 2007 on my Server 2008.
I have previously used popcon to collect my pop3 emails with exchange and server 2003.
When I am trying to use it as a pop connector with my new setup ive come across a problem.
Everytime popcon trys to send the messages to exchange i get "Mail transfer to Exchange failed, reason: Could not reach Exchange SMTP server - check IP port 25 is not blocked by a firewall or antivirus product!"
Both popcon and exchange are on the same box which currently has no A/V or software firewall enabled.
I have emailed popcon support with no response.  Has anyone come across this or have any ideas?

Thanks




mark@mvps.org -> RE: Exchange 2007 with POPCon (2.Aug.2008 6:39:38 PM)

There's nothing wrong with POPCON. All that's happened is that you have failed to configure Exchange 2007 to accept "anonymous" mails on the receive connector.
I use POPCON and Exchange 2007. You need to NOTHING to POPCON to deliver to Exchange 2007.




paulmh_5 -> RE: Exchange 2007 with POPCon (2.Aug.2008 7:01:39 PM)

Well looking at it i cant see where Im going wrong.
Ive got the recieve connector set up to allow anonymous connections on port 25.  Other than that i cant see much else that i can change?




mark@mvps.org -> RE: Exchange 2007 with POPCon (2.Aug.2008 7:20:39 PM)

The only two things you need on the connector are:
Anonymous.
The IP address (or range) that is (or includes) the IP of the server with POPCON on it, even if that's the local host.

Oh, making sure you did this on the Default, not the Client receive connector.




paulmh_5 -> RE: Exchange 2007 with POPCon (3.Aug.2008 3:35:17 AM)

Yeah thats what ive got set up.
Ive just knowticed that the MS Exchange transport service keeps stopping of its own accord even if its manualy started.  Is that likely to be a reason why popcon cant find exchange?  If i create a virtual SMTP service in IIS6 it can find that but cant deliver the messsage as theres nothing behind it.
I think ive read about other people having issues with randomly stopping services, the recovery is set tp restart it but its not working.  Any suggestions?




mark@mvps.org -> RE: Exchange 2007 with POPCon (3.Aug.2008 8:17:12 AM)

Good, nothing to do with POPCON per-se then. Event log time. Increase logging perhaps so that you get somethin in the log to check.




paulmh_5 -> RE: Exchange 2007 with POPCon (3.Aug.2008 12:55:14 PM)

I get 2 errors in the event log when i try to start the transport service.

1:
Log Name:      Application
Source:        MSExchange Extensibility
Date:          03/08/2008 17:51:15
Event ID:      1052
Task Category: MExRuntime
Level:         Error
Keywords:      Classic
User:          N/A
Description:
The creation of an agent factory for the agent 'FSE Routing Agent' failed with error 'Failed to create type 'Antigen.AntigenRoutingAgentFactory' from assembly 'C:\Program Files\Microsoft\Exchange Server\TransportRoles\agents\FSEAgent\Bin\FSEAgent_8.0.685.dll' due to error 'Invalid agent assembly path.'.'. Verify that the corresponding transport agent assembly and dependencies with the correct version are installed.

2:
Log Name:      Application
Source:        MSExchangeTransport
Date:          03/08/2008 17:51:15
Event ID:      16023
Task Category: Configuration
Level:         Error
Keywords:      Classic
User:          N/A
Description:
Microsoft Exchange couldn't start transport agents. The Microsoft Exchange Transport service will be stopped. Exception details: Failed to create type 'Antigen.AntigenRoutingAgentFactory' from assembly 'C:\Program Files\Microsoft\Exchange Server\TransportRoles\agents\FSEAgent\Bin\FSEAgent_8.0.685.dll' due to error 'Invalid agent assembly path.'. : Microsoft.Exchange.Data.ExchangeConfigurationException: Failed to create type 'Antigen.AntigenRoutingAgentFactory' from assembly 'C:\Program Files\Microsoft\Exchange Server\TransportRoles\agents\FSEAgent\Bin\FSEAgent_8.0.685.dll' due to error 'Invalid agent assembly path.'. ---> System.ArgumentException: Invalid agent assembly path.
  --- End of inner exception stack trace ---
  at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable.CreateAgentFactory(AgentInfo agentInfo)
  at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable..ctor(IEnumerable agents)
  at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.RuntimeSettings..ctor(MExConfiguration config, String agentGroup)
  at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.MExRuntime.Initialize(String configFile, String agentGroup)
  at Microsoft.Exchange.Transport.Categorizer.MExEvents.Initialize(String configFilePath)
  at Microsoft.Exchange.Transport.Components.CategorizerMExRuntimeLoader.Load()

Sorry if posting all of that is a bit over the top but like i say im new to exchange 2007.




Page: [1]