• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

ACTIVESYNC Cant get it WORKING!!

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> ACTIVESYNC Cant get it WORKING!! Page: [1]
Login
Message << Older Topic   Newer Topic >>
ACTIVESYNC Cant get it WORKING!! - 2.Sep.2008 10:12:51 AM   
Gman0941

 

Posts: 136
Joined: 13.Oct.2004
From: Virginia
Status: offline
I just installed Exchange 2007 I got the OWA working but I can not get the Active Sync working??? Is there a way to get rid of SSL? I just need it working for now I can deal with securuity later. I removed the SSL but no luck. ANY HELP?? Thanks
Post #: 1
RE: ACTIVESYNC Cant get it WORKING!! - 2.Sep.2008 11:13:23 AM   
Sembee

 

Posts: 4093
Joined: 17.Jan.2008
From: Somewhere near London, UK
Status: offline
I wouldn't advise trying to do anything with Exchange 2007 without SSL. It is core to the product.
Have you changed the home grown certificate for a commercial certificate? If not then I would suggest that you do that to begin with. You need a SAN/UC certificate.

I have outlined what is required on my blog:
http://www.sembee.co.uk/archive/2008/05/30/78.aspx

Otherwise you need to provide more information. "Not working" doesn't really help. There are tools available from Microsoft such as the Windows Mobile emulator which can assist with troubleshoot, as well as the testexchangeconnectivity.com prototype site. However the second one will require a trusted SSL certificate.

Simon.

_____________________________

Simon Butler,
Exchange MVP
Blog: http://blog.sembee.co.uk/
Web: http://www.amset.info/
In the UK? Hire me: http://www.sembee.co.uk/
Exchange Resources: http://exbpa.com/

(in reply to Gman0941)
Post #: 2
RE: ACTIVESYNC Cant get it WORKING!! - 2.Sep.2008 12:53:01 PM   
Gman0941

 

Posts: 136
Joined: 13.Oct.2004
From: Virginia
Status: offline
Thanks Ya not working does not really do it. Does the server have to have a cert from an authority such as Verisign? I have a test one in now but can not put the root in the phones. I have removed and recreated the virtual directory and the error I am getting  on the phone is 0x80072F17

(in reply to Sembee)
Post #: 3
RE: ACTIVESYNC Cant get it WORKING!! - 2.Sep.2008 12:59:10 PM   
Sembee

 

Posts: 4093
Joined: 17.Jan.2008
From: Somewhere near London, UK
Status: offline
You don't have to purchase one of Verisign's over priced certificates. GoDaddy do SAN/UC certificates that are trusted by most Windows Mobile devices for US$60/year. http://DomainsForExchange.net/

Microsoft don't actually support the use of self generated certificates for Exchange ActiveSync (or Outlook Anywhere) on Exchange 2007.

If Exchange is deployed correctly using commercial SSL certificates then it works fine.

Simon.

_____________________________

Simon Butler,
Exchange MVP
Blog: http://blog.sembee.co.uk/
Web: http://www.amset.info/
In the UK? Hire me: http://www.sembee.co.uk/
Exchange Resources: http://exbpa.com/

(in reply to Gman0941)
Post #: 4
RE: ACTIVESYNC Cant get it WORKING!! - 2.Sep.2008 4:01:24 PM   
Gman0941

 

Posts: 136
Joined: 13.Oct.2004
From: Virginia
Status: offline
Thanks, I followed your directions and got a cert from certs for exchange for 30.00 but I did the import and went to enable it and it says the cert does not have a private key? I think I took it out and need to delete the cert and put it back in but can not seem to fine how to do just that??

(in reply to Sembee)
Post #: 5
RE: ACTIVESYNC Cant get it WORKING!! - 2.Sep.2008 4:08:49 PM   
Sembee

 

Posts: 4093
Joined: 17.Jan.2008
From: Somewhere near London, UK
Status: offline
What exactly did you buy? It sounds like you purchase a single name SSL certificate, when it should have been a SAN/UC certificate.
Did you go through the instructions supplied with the certificate to install the root certificates in to IIS?
Did you then follow the instructions in my blog to import the certificate result?

Simon.

_____________________________

Simon Butler,
Exchange MVP
Blog: http://blog.sembee.co.uk/
Web: http://www.amset.info/
In the UK? Hire me: http://www.sembee.co.uk/
Exchange Resources: http://exbpa.com/

(in reply to Gman0941)
Post #: 6
RE: ACTIVESYNC Cant get it WORKING!! - 2.Sep.2008 4:31:44 PM   
Gman0941

 

Posts: 136
Joined: 13.Oct.2004
From: Virginia
Status: offline
I did get a single SSL that is all i needed. I had removed the private key so I rekeyed the cert and reinstalled everything as you said and bingo! Finally! I should have done this yesterday as it was Monday! Thanks for your help and all of your procedures if you dont mind I am going to make copies for our records. We have not had a lot of need for SSL certs but now with 2007 I see we will need them.

Thanks again
George

(in reply to Sembee)
Post #: 7

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> ACTIVESYNC Cant get it WORKING!! Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter