• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

RE: Please help with AutoDiscover

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> RE: Please help with AutoDiscover Page: <<   < prev  1 [2] 3   next >   >>
Login
Message << Older Topic   Newer Topic >>
RE: Please help with AutoDiscover - 21.Oct.2008 5:56:07 PM   
stevenjwilliams83

 

Posts: 102
Joined: 18.Mar.2008
Status: offline
Well then, So the plot thickens....If a users mailbox is held on Exchange server 2003 and they have outlook 2007.....They are always prompted for autodiscover...It says do you want to allow autodiscover.Mydomain.com to configure your settings.  Any reason for this?

(in reply to stevenjwilliams83)
Post #: 21
RE: Please help with AutoDiscover - 22.Oct.2008 12:14:49 PM   
Elan Shudnow

 

Posts: 897
Joined: 4.Jan.2007
From: Chicago, IL
Status: offline
My assumption on that is that it's because the Autodiscover does more than just provide services.  It does things such as making sure you are utilizing the best CAS.  For example, if Exchange 2003 was in another site and there is also a CAS in that site providing Outlook Anywhere, Autodiscover would refer your Outlook client to another CAS which is in the same site as your mailbox/backend.  It would make sense you're still getting prompted as Outlook will contact the Autodiscover and it's going through a CAS for Outlook Anywhere so you still utilize Autodiscover.

_____________________________

Elan Shudnow
Exchange MVP
http://www.shudnow.net

(in reply to stevenjwilliams83)
Post #: 22
RE: Please help with AutoDiscover - 22.Oct.2008 1:31:26 PM   
stevenjwilliams83

 

Posts: 102
Joined: 18.Mar.2008
Status: offline
So back to the Autodiscover outside the corporate network.  The PC I am using is non-domain PC outside the corporate firewall.  I can get the user configured if they set the exchange proxy settings for HTTPS over RPC, but cant get autodiscover to work if they just enter email and password.  It errors out.  But when I go to the exchangeconnectivitytesting web page and test just autodiscover with that username and their credentials, it passes with flying colors, so in this case it shouod work correct?  Anything else I should be looking for?  And BTW I am pretty close to chicago so a beer might not be far fetched, or a job when they fire me for messing with this exchange server too much.  But if they want the bleeding edge functions thats what they will get!

(in reply to Elan Shudnow)
Post #: 23
RE: Please help with AutoDiscover - 29.Oct.2008 7:37:23 AM   
Ahmad Ramadan

 

Posts: 457
Joined: 6.Jul.2008
From: Egypt
Status: offline
so my friend i think this caseis exactly my casei have a split DNS meaning my internal DNS is Domain.local and my externall dns is Domain.com
plus i have 2 servers holding hub and cas roles and they r in NLB mode
so the virtual NLB name is Mail.domain.local
anyway from my understanding this is what i am gonna do and correct me if i am wrong :

Set-ClientAccessServer -Identity hubcas1 -AutoDiscoverServiceInternalUrl https://mail.domain.local/Autodiscover/Autodiscover.xml
Set-ClientAccessServer -Identity hubcas2 -AutoDiscoverServiceInternalUrl
https://mail.domain.local/Autodiscover/Autodiscover.xml 
Set-ClientAccessServer -Identity hubcas1-AutoDiscoverServiceexternalurl
https://mail.domain.local/Autodiscover/Autodiscover.xml 
Set-ClientAccessServer -Identity hubcas2AutoDiscoverServiceexternalurl
https://mail.domain.local/Autodiscover/Autodiscover.xml 

Set-WebServicesVirtualDirectory -Identity “hubcas1\EWS (Default Web Site)” -InternalURL https://mail.domain.locali/EWS/Exchange.asmx -ExternalURL https://mail.domain.comi/EWS/Exchange.asmx -BasicAuthentication:$true
Set-WebServicesVirtualDirectory -Identity “hubcas2\EWS (Default Web Site)” -InternalURL https://mail.domain.locali/EWS/Exchange.asmx -ExternalURL https://mail.domain.comi/EWS/Exchange.asmx -BasicAuthentication:$true 

Set-OABVirtualDirectory -Identity “hubcas1\OAB (Default Web Site)” -InternalURL https://mail.domain.local/OAB -ExternalURLhttps://mail.domain.com/OAB
Set-OABVirtualDirectory -Identity “hubcas2\OAB (Default Web Site)” -InternalURL https://mail.domain.local/OAB -ExternalURLhttps://mail.domain.com/OAB

Enable-OutlookAnywhere -Server hubcas1 -ExternalHostname “mail.domain.com” -ClientAuthenticationMethod “Basic”-SSLOffloading:$False
Enable-OutlookAnywhere -Server hubcas2 -ExternalHostname “mail.domain.com” -ClientAuthenticationMethod “Basic”-SSLOffloading:$False

Set-ActiveSyncVirtualDirectory -Identity “hubcas1\Microsoft-Server-ActiveSync (Default Web Site)” -ExternalURL https://mail.domain.com/Microsoft-Server-Activesync
Set-ActiveSyncVirtualDirectory -Identity “hubcas2\Microsoft-Server-ActiveSync (Default Web Site)” -ExternalURL https://mail.domain.com/Microsoft-Server-Activesync

Set-UMVirtualDirectory -Identity “hubcas1\UnifiedMessaging (Default Web Site)” -InternalURL https://mail.domain.local/UnifiedMessaging/Service.asmx -ExternalURL https://mail.domain.com/UnifiedMessaging/Service.asmx -BasicAuthentication:$true
Set-UMVirtualDirectory -Identity “hubcas2\UnifiedMessaging (Default Web Site)” -InternalURL https://mail.domain.local/UnifiedMessaging/Service.asmx -ExternalURL https://mail.domain.com/UnifiedMessaging/Service.asmx -BasicAuthentication:$true

Set-WebServicesVirtualDirectory –Identity "EWS*" -ExternalUrl "https://mail.domain.com/EWS/Exchange.asmx -internalurl
"https://mail.domain.local/EWS/Exchange.asmx
 
so my friend tell me r these commands going to open all the autodiscover and availability services on exchange 2007 for my clients or i need more commands?
and if i did these commands r there anything wrong will happen or i will be in safe side?
if u have any recommendations or ideas plz feel free to tell me it all
and is my outlook anywhere clients going to work perfectly or i need to consider something else???
 
thank you and waiting your reply ASAP














_____________________________

Ahmad Ramadan AbaYazeed
Senior Systems Projects Engineer

(in reply to stevenjwilliams83)
Post #: 24
RE: Please help with AutoDiscover - 29.Oct.2008 11:18:21 AM   
Elan Shudnow

 

Posts: 897
Joined: 4.Jan.2007
From: Chicago, IL
Status: offline
Looks good.

_____________________________

Elan Shudnow
Exchange MVP
http://www.shudnow.net

(in reply to Ahmad Ramadan)
Post #: 25
RE: Please help with AutoDiscover - 29.Oct.2008 11:38:11 AM   
Ahmad Ramadan

 

Posts: 457
Joined: 6.Jul.2008
From: Egypt
Status: offline
thank you my man from the quick reply but sorry for asking again another question :)
i will add to these configuration that i mentioned above and internal host A recorde names Autodiscover.mydomain.local in my dns and this recorde will point to the NLB virtual name of my 2 hub-cas server
and another host A on the ISP dns called Autodiscover.mydomain.com which will point to mail.mydomain.com which is my external internet name
and this will point to my FW and the FW will direct the requests to mail.mydomain.local which is my hubcas NLB Virtual name
do u agree on that?

1- also r u sure that i dont need any more shell command to enable any other services available on the exchange 2007?
2- this configuration will have no problems for outlook anywhere including the AS and autodiscover service clients i mean they will work good, or....?

waiting ur reply
thanx again

_____________________________

Ahmad Ramadan AbaYazeed
Senior Systems Projects Engineer

(in reply to Elan Shudnow)
Post #: 26
RE: Please help with AutoDiscover - 29.Oct.2008 11:41:38 AM   
Elan Shudnow

 

Posts: 897
Joined: 4.Jan.2007
From: Chicago, IL
Status: offline
It should work.  But we always know how that goes with technology.  If things always worked perfectly, we wouldn't have jobs.

Here's the services that utilize the whole InternalURL and ExternalURL functionality:
http://technet.microsoft.com/en-us/library/bb201695(EXCHG.80).aspx

There's also the Autodiscover Whitepaper if you're interested:
http://technet.microsoft.com/en-us/library/bb332063(EXCHG.80).aspx

_____________________________

Elan Shudnow
Exchange MVP
http://www.shudnow.net

(in reply to Ahmad Ramadan)
Post #: 27
RE: Please help with AutoDiscover - 29.Oct.2008 11:52:37 AM   
Ahmad Ramadan

 

Posts: 457
Joined: 6.Jul.2008
From: Egypt
Status: offline
yeah man i agree on that :D

1- another thing i think after running the command i should go to the IIS on each server and enable the basic authetication on each directory
2- on the exchange i have to specify the internal url or external url for OAB, outlook anywhere, UM,  and the others
right??
do i need to do or consider anything else?
waiting ur reply

_____________________________

Ahmad Ramadan AbaYazeed
Senior Systems Projects Engineer

(in reply to Elan Shudnow)
Post #: 28
RE: Please help with AutoDiscover - 29.Oct.2008 12:11:51 PM   
Elan Shudnow

 

Posts: 897
Joined: 4.Jan.2007
From: Chicago, IL
Status: offline
You don't really have to.  I wrote some articles on my blog and say to add basic authentication on the IIS directory, but I created those articles well over a year and a half ago.   You can leave the IIS authentication settings alone.  Just run the commands and you should be fine.

Yes, you will want to specify InternalURL and ExternalURL.  As stated, your commands look good.

_____________________________

Elan Shudnow
Exchange MVP
http://www.shudnow.net

(in reply to Ahmad Ramadan)
Post #: 29
RE: Please help with AutoDiscover - 29.Oct.2008 12:17:17 PM   
Ahmad Ramadan

 

Posts: 457
Joined: 6.Jul.2008
From: Egypt
Status: offline
Thank you alot my friend i will run the commands 2morro and iw ill feed you back with the status
thank you again
if it works i'll owe u a beer :P:p

_____________________________

Ahmad Ramadan AbaYazeed
Senior Systems Projects Engineer

(in reply to Elan Shudnow)
Post #: 30
RE: Please help with AutoDiscover - 29.Oct.2008 12:18:11 PM   
Elan Shudnow

 

Posts: 897
Joined: 4.Jan.2007
From: Chicago, IL
Status: offline
quote:

ORIGINAL: Ahmad Ramadan
if it works i'll owe u a beer :P:p


Beer always makes me

_____________________________

Elan Shudnow
Exchange MVP
http://www.shudnow.net

(in reply to Ahmad Ramadan)
Post #: 31
RE: Please help with AutoDiscover - 29.Oct.2008 12:21:40 PM   
Ahmad Ramadan

 

Posts: 457
Joined: 6.Jul.2008
From: Egypt
Status: offline
quote:

ORIGINAL: Elan Shudnow

quote:

ORIGINAL: Ahmad Ramadan
if it works i'll owe u a beer :P:p


Beer always makes me


same here my friend :D

_____________________________

Ahmad Ramadan AbaYazeed
Senior Systems Projects Engineer

(in reply to Elan Shudnow)
Post #: 32
RE: Please help with AutoDiscover - 10.Nov.2008 5:10:29 AM   
Ahmad Ramadan

 

Posts: 457
Joined: 6.Jul.2008
From: Egypt
Status: offline
dear Elan
1st thank you for your help regarding this autodiscovery issue i just wanted to tell u that all the command worked perfectly except the following one
Set-ClientAccessServer -Identity hubcas1 -AutoDiscoverServiceexternalUri https://mail.domain.com/Autodiscover/Autodiscover.xml
Set-ClientAccessServer -Identity hubcas2 -AutoDiscoverServiceexternalUri https://mail.domain.com/Autodiscover/Autodiscover.xml

i saw in ur 1st post that u only run the same command internally only, so do i have to run it externally and if i do why its not working with me and giving me a wrong parameters??

2- i found out that there is a command call set-autodiscovervirtualdirectory
do i have to run this one also? and if i do can u provide me with the exact command syntax??

waiting ur reply ASAP!!!  


_____________________________

Ahmad Ramadan AbaYazeed
Senior Systems Projects Engineer

(in reply to Ahmad Ramadan)
Post #: 33
RE: Please help with AutoDiscover - 10.Nov.2008 6:41:30 AM   
Exchange_Geek

 

Posts: 1287
Joined: 31.Dec.2006
Status: offline
Ref: http://technet.microsoft.com/en-us/library/bb125157.aspx
I do not find any such switch as -AutoDiscoverServiceexternalUri

Are you trying to configure your A.Service to be configured for external users using this command ??

(in reply to Ahmad Ramadan)
Post #: 34
RE: Please help with AutoDiscover - 10.Nov.2008 7:52:27 AM   
Elan Shudnow

 

Posts: 897
Joined: 4.Jan.2007
From: Chicago, IL
Status: offline
You only do a Set-ClientAccessServer -AutodiscoverInternalURI

That configures the SCP in AD so when clients locate the SCP, they hit the Autodiscover Server internally.  You don't have to configure anything externally as clients will automatically try to contact autodiscover.smtpdomain.com.   The only thing you have to worry about from an external perspective is setting up all your services to have an -ExternalURL.  And from what you said, all the other comamnds ran fine so you should be good to go.  After testing of course. :)

_____________________________

Elan Shudnow
Exchange MVP
http://www.shudnow.net

(in reply to Exchange_Geek)
Post #: 35
RE: Please help with AutoDiscover - 10.Nov.2008 9:34:52 AM   
Ahmad Ramadan

 

Posts: 457
Joined: 6.Jul.2008
From: Egypt
Status: offline
i got your idea so there is no need for Set-ClientAccessServer
-AutodiscoverInternalURI
actually when i tried to do it, it didnt work.

my second question is regarding the other command that i found it out and when i ran it and it worked

Set-AutodiscoverVirtualDirectory –Identity ‘HubCas1\autoDiscover (Deafult Web Site)’ –ExternalUrl https://Autodiscover.domain.com/autodiscover/autodiscover.xml -internalurl https://autodiscover.domain.local/autodiscover/autodiscover.xml
 
Set-AutodiscoverVirtualDirectory –Identity ‘HubCas2\autoDiscover (Deafult Web Site)’ –ExternalUrl https://Autodiscover.domain.com/autodiscover/autodiscover.xml -internalurl https://autodiscover.domain.local/autodiscover/autodiscover.xml
is this command syntax is right?
coz when i run get-autodiscovervirtualdirectory | Fl the result was okay as i mentioned it in my externall and internall URL's

if i am okay and good to go right now my final step is to retype the url internal and external on each of the services as mentioned on each command in EMC right??
waiting ur replies 

_____________________________

Ahmad Ramadan AbaYazeed
Senior Systems Projects Engineer

(in reply to Elan Shudnow)
Post #: 36
RE: Please help with AutoDiscover - 10.Nov.2008 9:47:17 AM   
Elan Shudnow

 

Posts: 897
Joined: 4.Jan.2007
From: Chicago, IL
Status: offline
I've never set the InternalURL or ExternalURL for that.  I've never even read anywhere that you should set those and anytime I've ever set up Autodiscover, I've never modified the InternalURL and ExternalURL for that.

_____________________________

Elan Shudnow
Exchange MVP
http://www.shudnow.net

(in reply to Ahmad Ramadan)
Post #: 37
RE: Please help with AutoDiscover - 10.Nov.2008 9:54:55 AM   
Ahmad Ramadan

 

Posts: 457
Joined: 6.Jul.2008
From: Egypt
Status: offline
so gentleman, what does it do, if this command is RUN??? and what is the rollback if the command is not required ? do reply me back pls





_____________________________

Ahmad Ramadan AbaYazeed
Senior Systems Projects Engineer

(in reply to Elan Shudnow)
Post #: 38
RE: Please help with AutoDiscover - 10.Nov.2008 10:00:30 AM   
Elan Shudnow

 

Posts: 897
Joined: 4.Jan.2007
From: Chicago, IL
Status: offline
I would leave them at default.  I've never seen anybody have to configure those and I've read a ton of Autodiscover documentation.  You don't have to set those as far as I know.

What I do know, is that the two settings are empty by default, so to revert it back, you'd just set the options to $null.  -InternalURL $null -ExternalURL $null

_____________________________

Elan Shudnow
Exchange MVP
http://www.shudnow.net

(in reply to Ahmad Ramadan)
Post #: 39
RE: Please help with AutoDiscover - 10.Nov.2008 10:09:26 AM   
Ahmad Ramadan

 

Posts: 457
Joined: 6.Jul.2008
From: Egypt
Status: offline
thank you Elan for ur replies
but what do u think if i ran the command is it gonna prevent anything from working??
waiting ur reply

_____________________________

Ahmad Ramadan AbaYazeed
Senior Systems Projects Engineer

(in reply to Elan Shudnow)
Post #: 40

Page:   <<   < prev  1 [2] 3   next >   >> << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> RE: Please help with AutoDiscover Page: <<   < prev  1 [2] 3   next >   >>
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter