Problem with shared mailbox reply-to address (Full Version)

All Forums >> [Microsoft Exchange 2003] >> General



Message


albracco -> Problem with shared mailbox reply-to address (1.Dec.2008 9:50:40 AM)

Had an existing W2003 DC, and a separate member server Exchange server. One forest, one domain, one internet domain name. Needed to add a new, secondary internet domain name that certain users will need email addresses for. Created a new OU, new users, new recipient policy for that OU, setup "send-on-behalf" and setup outlook to display the second mailbox for users that have emails at both domains. For example, USERA1 at domain1.com has a corresponding USERA2 at domain2.com. (in the separate OU). Setup mailbox sharing, so that when USERA1 logs in and opens outlook, it shows his main mailbox, as well as his USERA2 mailbox as a shared mailbox. Incoming messages go to the correct mailbox. No problem so far.

The issue is trying to send a new email from the USER2A address. When he creates a new message and selects USERA2 to be the "from" address, when the recipient gets the message, the reply-to is still the USERA1 address. When he replies to a message that was sent to the USERA2 address, the recipient sees the correct reply-to.

Have I gone about this the wrong way or have I missed something?




Sembee -> RE: Problem with shared mailbox reply-to address (1.Dec.2008 2:23:27 PM)

Send on Behalf of is different to Send As.

Send on Behalf of can have mixed results with external recipients.

If you have two domains then you should be using Send As permissions, not Send on Behalf of. Those are set on the Security tab of the user account. If you don't see the security tab, close the properties and choose View, Advanced Features.
Remove the Send on Behalf of and chosoe Send As.

Do not expect it to be live immediately, due to the way that Exchange caches permissions. It can take two hours or more for the change to take effect.

Simon.




albracco -> RE: Problem with shared mailbox reply-to address (1.Dec.2008 4:04:14 PM)

Thank You. Sounds logical. I was looking in mailbox rights and seeing a "send as', which is why i was trying the "send on behalf of" (which I felt was not right). The "advanced" option to get the security tab was the key. I made the changes and it isn't working yet. I will wait a few hrs and see.

Al




albracco -> RE: Problem with shared mailbox reply-to address (1.Dec.2008 4:36:04 PM)

meant to say "not" seeing send as...




albracco -> RE: Problem with shared mailbox reply-to address (2.Dec.2008 11:56:25 AM)

After removing "send on behalf" and adding "send as", now there is no "from" option that can be added when composing the message. Now I'm going in circles.

Is there a how-to somewhere that will give me more details on how to set this up?

Thanks,

Al




Sembee -> RE: Problem with shared mailbox reply-to address (2.Dec.2008 12:49:49 PM)

The From field has nothing to do with the permissions on the account. Exchange doesn't control whether it can be seen or not. The from field is exclusively client side.

Therefore you simply need to enable it again. Open a new message, view From field.

Simon.




albracco -> RE: Problem with shared mailbox reply-to address (2.Dec.2008 1:19:21 PM)

I thought the "from: field becomes available when Outlook is accessing an Exchange server, but in any case, when I try to compose a NEW message, there is no longer a "from" option when I click on "view". If I REPLY to a message that has been sent to USERA2, then the "from" field is available.




Sembee -> RE: Problem with shared mailbox reply-to address (2.Dec.2008 1:30:12 PM)

That is a client issue - possibly a suspect Outlook profile.
The from field is only available to select when connected to Exchange, but again that is still a client side control. Exchange does not control it.

Therefore I would suggest that you test it on another machine.

Simon.




albracco -> RE: Problem with shared mailbox reply-to address (8.Dec.2008 10:01:33 AM)

I checked another PC and same issue - no "from" field available. I ahve set the shared hosting up as per this article:

http://www.msexchange.org/tutorials/Shared_Hosting_Exchange_2003_Part1.html

And have set the "send as" permissions, so I think I'm ready to go, but now there is no "from field". Haven't been able to find anything online yet with regards to this issue.




uemurad -> RE: Problem with shared mailbox reply-to address (8.Dec.2008 10:34:14 AM)

Displaying the "From" field is a configuration option in Outlook.  Start a New Email message.  Under the View menu, select "From field" so there is a check next to it.  You'll also see an option for BCC.




albracco -> RE: Problem with shared mailbox reply-to address (8.Dec.2008 10:39:12 AM)

I know all of that - but the From option wasn't there! I have since figured out that the user had switched to Word as his email editor and in Word, you find the "from:" option by clicking on the down arrow next to "options". So I've gotten past that silliness - now to see if I have resolved my original issue...

Al




albracco -> RE: Problem with shared mailbox reply-to address (8.Dec.2008 8:36:18 PM)

Current Status: I've been able to share open the mailboxB and open it from the primary mailboxA. I have set the "send as" permissions, so userA can send as userB. Incoming mail to userB appears in the mailboxB's inbox. If I send a message "from" the second address, the message gets bounced back with an undeliverable. This occurs if I send to either an internal or external recipient. The message says:

Your message did not reach some or all of the intended recipients.
     Subject: new test2
     Sent: 12/8/2008 8:26 PM
The following recipient(s) could not be reached:
     user@emaildomain.com on 12/8/2008 8:26 PM
           You do not have permission to send to this recipient.  For assistance, contact your system administrator.
           MSEXCH:MSExchangeIS:/DC=com/DC=domain/DC=domain




uemurad -> RE: Problem with shared mailbox reply-to address (8.Dec.2008 10:08:00 PM)

That's the NDR you get when the Send As permissions are not set.  Doublecheck the setting.  Log userA out and log back in before attempting to send again.




albracco -> RE: Problem with shared mailbox reply-to address (9.Dec.2008 9:45:42 AM)

Setting was correct - I just needed a little patience. This morning all is working fine. Thank you to all who have helped out here. This was a good learning experience.




Page: [1]