• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Failed to obtain AutoDiscover XML response

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Failed to obtain AutoDiscover XML response Page: [1]
Login
Message << Older Topic   Newer Topic >>
Failed to obtain AutoDiscover XML response - 3.Jan.2009 12:22:01 PM   
alan@thelevyhome.com

 

Posts: 1
Joined: 3.Jan.2009
Status: offline
Everyone I am not sure if I should worry about this error and wanted to know what everyone thought.  I have an SBS 2008 Server.  All of the internal BPA (Exchange and SBS), have not reported any issues.  I have remote clients connecting to the SBS server and wanted to check to make sure that everything was correct configured so I went to the https://www.testexchangeconnectivity.com/ web site and when I went to the Microsoft Office Outlook 2007 AutoDiscover Connectivity Test it failed with the following log.  I have removed my actual domain names and the like.  I would appreciate it if anyone could chime in before I start making settings changes within Exchange.
 
Thanks,
Alan
 
Log follows:
 
Attempting each method of contacting the AutoDiscover Service
 Failed to contact the AutoDiscover service successfully by any method
Test Steps
 Attempting to test potential AutoDiscover URL https://(External Domain name)/AutoDiscover/AutoDiscover.xml
 Failed testing this potential AutoDiscover URL
Test Steps
 Attempting to Resolve the host name (External Domain name) in DNS.
 Host successfully Resolved
Additional Details
 IP(s) returned: (Server IP)
 
Testing TCP Port 443 on host (External Domain name) to ensure it is listening/open.
 The port was opened successfully.
 
Testing SSLCertificate for validity.
 The SSLCertificate failed one or more certificate validation checks.
 Tell me more about this issue and how to resolve it
 
Additional Details
 The name on the certificate does not match the name (External Domain name)
 
 
 
Attempting to test potential AutoDiscover URL https://autodiscover.(External Domain name)/AutoDiscover/AutoDiscover.xml
 Failed testing this potential AutoDiscover URL
Test Steps
 Attempting to Resolve the host name autodiscover.(External Domain name) in DNS.
 Host successfully Resolved
Additional Details
 IP(s) returned: (Server IP)
 
Testing TCP Port 443 on host autodiscover.(External Domain name) to ensure it is listening/open.
 The port was opened successfully.
 
Testing SSLCertificate for validity.
 The SSLCertificate failed one or more certificate validation checks.
 Tell me more about this issue and how to resolve it
 
Additional Details
 The name on the certificate does not match the name autodiscover.(Domain name)
 
 
 
Attempting to contact the AutoDiscover service using the HTTP redirect method.
 Failed to contact AutoDiscover using the HTTP Redirect method
 Tell me more about this step
 
Test Steps
 Attempting to Resolve the host name autodiscover.(Domain name) in DNS.
 Host successfully Resolved
Additional Details
 IP(s) returned: (Server IP)
 
Testing TCP Port 80 on host autodiscover.(Domain name) to ensure it is listening/open.
 The port was opened successfully.
 
Checking Host autodiscover.(Domain name) for an HTTP redirect to AutoDiscover
 Failed to get an HTTP redirect response for AutoDiscover
Additional Details
 A Web Exception occured because an HTTP 404 - NotFound response was received from IIS7
 
 
 
Attempting to contact the AutoDiscover service using the DNS SRV redirect method.
 Failed to contact AutoDiscover using the DNS SRV redirect method.
Test Steps
 Attempting to locate SRV record _autodiscover._tcp.(Domain name) in DNS.
 Successfully retrieved AutoDiscover SRV record from DNS.
Additional Details
 Srv Record returned host: (External FQDN of Server)
 
Attempting to test potential AutoDiscover URL https://(External FQDN of server)/Autodiscover/Autodiscover.xml
 Failed testing this potential AutoDiscover URL
Test Steps
 Attempting to Resolve the host name (External FQDN of server) in DNS.
 Host successfully Resolved
Additional Details
 IP(s) returned: (Server IP)
 
Testing TCP Port 443 on host (External FQDN of Server) to ensure it is listening/open.
 The port was opened successfully.
 
Testing SSLCertificate for validity.
 The certificate passed all validation requirements.
Additional Details
 Subject: OU=Domain Control Validated, CN=(External FQDN of Server), O=(External FQDN of Server), Issuer SERIALNUMBER=07969287, CN=Go Daddy Secure Certification Authority, OU=http://certificates.godaddy.com/repository, O="GoDaddy.com, Inc.", L=Scottsdale, S=Arizona, C=US
 
Attempting to Retrieve XML AutoDiscover Response from url https:// (External FQDN of Server)/Autodiscover/Autodiscover.xml for user testuser@(Domain name)
 Failed to obtain AutoDiscover XML response.
Additional Details
 A Web Exception occured because an HTTP 401 - Unauthorized response was received from Unknown
Post #: 1
RE: Failed to obtain AutoDiscover XML response - 3.Jan.2009 4:05:20 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

One of the failures has to do with the certificates. Standard Exchange is installed with self-signed certificates. If you access OWA it will warn you about this. Besides this the certificates installed on your system do not match the url you are trying to access.

If you want to use autodiscovery, OWA and all the other stuff from external you will need to buy a SAN certificate which can contain all the required names, domains etc.

For a description on how to configure this check the following tutorial:

http://www.msexchange.org/articles_tutorials/exchange-server-2007/mobility-client-access/securing-exchange-2007-client-access-server-3rd-party-san-certificate.html

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to alan@thelevyhome.com)
Post #: 2
RE: Failed to obtain AutoDiscover XML response - 5.Feb.2009 6:12:15 PM   
17g33k

 

Posts: 2
Joined: 14.Jan.2009
Status: offline
I am having the same issue with my autodiscover service. 

I just recently setup this exchange 2007 server and when I use https://www.testexchangeconnectivity.com/ to analyze my remote connectivity it states "A Web Exception occured because an HTTP 503 - ServiceUnavailable response was received from Unknown" as the reason to why it cannot obtain the AutoDiscover XML response.

The full details of the test are below:

Attempting to test potential AutoDiscover URL https://autodiscover.domain.com/AutoDiscover/AutoDiscover.xml
Failed testing this potential AutoDiscover URL

   Test Steps
   
   Attempting to Resolve the host name autodiscover.domain.com in DNS.
   Host successfully Resolved

   Testing TCP Port 443 on host autodiscover.domain.com to ensure it is     listening/open.
   The port was opened successfully.

   Testing SSLCertificate for validity.
   The certificate passed all validation requirements.
  
   Attempting to Retrieve XML AutoDiscover Response from url     https://autodiscover.domain.com/AutoDiscover/AutoDiscover.xml for user fake@domain.com
   Failed to obtain AutoDiscover XML response.
   Additional Details
   A Web Exception occured because an HTTP 503 - ServiceUnavailable response was received from Unknown

Any idea what would cause the http 503 error?  I've read several forums on this issue, but none of them seem to address this particular issue.  Any help is appreciated.

(in reply to jveldh)
Post #: 3
RE: Failed to obtain AutoDiscover XML response - 19.Jun.2009 2:21:05 AM   
GoldenDog

 

Posts: 26
Joined: 26.Jan.2007
From: Las Vegas, NV
Status: offline
Here's how I resolved the autodiscover issue with my SBS 2008 clients.

For this example, I will use the fake domain name domain.com

I created a new domain alias called autodiscover.domain.com
I created a new A host record for autodiscover pointed to the IP of remote.domain.com
I created a new folder under the website domain.com called autodiscover
I created a new file in that folder called autodiscover.xml
I used IIS (on the web hosting site, not SBS/Exchange server) to redirect and requests for the autodiscover.xml file to redirect to https://remote.domain.com/autodiscover/autodiscover.xml
 
I then tested it with https://www.testexchangeconnectivity.com/Default.aspx and the results passed!

Basiclly, here is what happens: Autodiscover trys a few different methods to resolve. I use the HTTP method as it seems to work best for these types of situations and doesn't require special SSL certificates.

It sends a HTTP request to http://domain.com/autodiscover/autodiscover.xml
I have the file autodiscover.xml set on the webhosting site to do a redirect to https://remote.domain.com/autodiscover/autodiscover.xml
It then connects to this correct file, and then authenticates and pulls down the information it needs.

Hope this helps!

Lyle AKA GoldenDog

(in reply to 17g33k)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> Failed to obtain AutoDiscover XML response Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter