• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

HELP with Disaster recovery

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> General >> HELP with Disaster recovery Page: [1]
Login
Message << Older Topic   Newer Topic >>
HELP with Disaster recovery - 20.Mar.2009 12:36:33 PM   
zaidyy123

 

Posts: 7
Joined: 20.Mar.2009
Status: offline
Hi; 2 days ago our exchange server RAID controller blew up!!
I prepared a new box as follows:
1. box name and IP same as original, partitions also.
2. reset old box account in AD, join new box to domain
3. install exchange 2003 and SP2 using /disasterrecovery switch , installed hotfixes.

once the server is restarted, exchange services up and running; but the following event is logged every 2 minutes

Event ID 9174
Source: MSExchangeSA

The MAPI call 'OpenMsgStore' failed with the following error:
The Microsoft Exchange Server computer is not available.  Either there are network problems or the Microsoft Exchange Server computer is down for maintenance.
The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0526-00000000

Additionally, when using NTBACKUP to restore last week's backup, i receive "the specified computer is not a microsoft exchange server or its microsot exhcange services are not started"

All related Exchange services are running [IS,MTA,SA,routing engine]

any help is appriciated, thx in advance
Post #: 1
RE: HELP with Disaster recovery - 20.Mar.2009 4:06:17 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Can you confirm that the error you are getting is 9174 and not 9175??

This error usually is generated when the information store service is not started or when the IS service is started by the databases are not mounted. Try to restart the information store service and see if any errors/warnings are generated.

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to zaidyy123)
Post #: 2
RE: HELP with Disaster recovery - 21.Mar.2009 12:13:54 AM   
zaidyy123

 

Posts: 7
Joined: 20.Mar.2009
Status: offline
Oops! guess too many hours got to me at last! it is 9175!!

DB is not mounted because I am trying to restore it from a backup, actually i have NEVER MOUNTED IT since rebuilding, could this be the reason?

I have also noticed that when running NTBACKUP on this box, exchange IS is not visible for backup! it's like the server doesn't realize it's a mail box!

thanks for your time!

(in reply to de.blackman)
Post #: 3
RE: HELP with Disaster recovery - 21.Mar.2009 12:36:39 AM   
zaidyy123

 

Posts: 7
Joined: 20.Mar.2009
Status: offline
One more thing:  MDBDATA folder is empty after rebuild and  I have not mounted the original  DB becasue Exchange displays a message saying there is not DB and it would create a new one; the message also advises against this action if DB will be restored (which is what I'm planning to do).

I'm afraid creating a new one will damage whatever settings are there in AD and render my backupsets useless!

(in reply to zaidyy123)
Post #: 4
RE: HELP with Disaster recovery - 21.Mar.2009 5:22:18 AM   
zaidyy123

 

Posts: 7
Joined: 20.Mar.2009
Status: offline
Thanks for your reply de.blackman.
Empty DB folder was the reason!
I mounted the DB, got the warning [DO NOT MOUNT IF PLANNING TO RESTORE], ignored it, and the message dissapeared!

Dismounted, started restoring using NTBACKUP, and it works!!

Still got 120GB of data to restore, so it will take a while.




(in reply to zaidyy123)
Post #: 5
RE: HELP with Disaster recovery - 23.Mar.2009 4:51:49 AM   
zaidyy123

 

Posts: 7
Joined: 20.Mar.2009
Status: offline
Exchange is alive!

After restoring from backup, I ran eseutil /cc but replay was not successful, ended up doing the following:

1. eseutil /mh ------Status showing [Dirty Shutdown]
2. eseutil /p  ------ Took 6hrs
3. eseutil/mh-------Status no shoing [Clean Shutdown]
5. Mounted DB successfully.
6. Moved mailboxes to new store; 6 or 7 mailboxes returned errors.
7. Ran [isinteg -s servername -fix -test alltests] a couple of times until receving 0 errors.
8. Moved remaining mailboxes
9. Dismounting restored store, created new backup set.

(in reply to zaidyy123)
Post #: 6

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> General >> HELP with Disaster recovery Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter