• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Can't telnet into Exchange SMTP server port 25

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> General >> Can't telnet into Exchange SMTP server port 25 Page: [1]
Login
Message << Older Topic   Newer Topic >>
Can't telnet into Exchange SMTP server port 25 - 6.Apr.2009 1:15:06 AM   
urbanriot

 

Posts: 15
Joined: 6.Apr.2009
Status: offline
I've been working so long with 2007, I've lost all ability to diagnose 2003 problems. Basically, I can't telnet into an Exchange Server 2003's SMTP connector at all, locally or externally. No error, it just kicks out when I attempt to telnet.

If I run SMTPDIAG.EXE, I receive the following:
Error: Expected "220". Server is not accepting connections.
Failed to submit mail to mail.server

The default SMTP Virtual server is assigned to the appropriate IP, I've even allowed anonymous authentication, set the IP's in the subnet (and localhost) as being allowed to access the virtual server... no matter what I do. I can't get in. I even stopped the service, changed it to a random port, started it back up and I can't telnet into that either... No antivirus or 'firewall' is running on the server (Symantec Antivirus 10.1 was, but it's been removed).

Any suggestions? Thanks in advance!
Post #: 1
RE: Can't telnet into Exchange SMTP server port 25 - 6.Apr.2009 10:08:15 AM   
urbanriot

 

Posts: 15
Joined: 6.Apr.2009
Status: offline
Neko, thanks for the response. Yes, the server has been restarted many times. Outlook clients are able to obtain email via MAPI so other aspects of the server are working correctly.
Post #: 2
RE: Can't telnet into Exchange SMTP server port 25 - 6.Apr.2009 10:33:11 AM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
First, test whether you can establish an outbound SMTP connection from your Exchange server to some other server.  That will tell you if you have a problem with the SMTP service or IIS.

Second, if you are able to establish an outbound connection, check your Default SMTP Virtual Server settings to make sure you haven't locked down the server tighter than you intended.  Go to the Access tab and then to the Connection button.

Finally, check any potential port filters that lie between your Exchange server and the system from which you are trying to connect.  That includes any firewalls, desktop firewalls, routers, and layer-3 switches.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to urbanriot)
Post #: 3
RE: Can't telnet into Exchange SMTP server port 25 - 6.Apr.2009 1:37:20 PM   
urbanriot

 

Posts: 15
Joined: 6.Apr.2009
Status: offline
uemurad, I appreciate your attempt to help me.

The server is forwarding all outgoing, public email to an external smart host (the business' ISP mail server), so I assume SMTP outbound is working fine.

As far as access under the Default SMTP Virtual Server goes, I've opened everything right up allowing even anonymous access. Access is granted to all subnets including localhost, and I can't even access from the server itself.

From the server itself I can't even access, so there isn't anything in between and there is no software that is running on the server that might cause this. This server consists of Windows Small Business Server 2003, HP Data Protector Express, Microsoft System Server Essentials 2007, and Blackberry Enterprise Server Express.

(in reply to uemurad)
Post #: 4
RE: Can't telnet into Exchange SMTP server port 25 - 7.Apr.2009 9:31:15 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
So when you are logged on to the exchange server and you run a TELNET SERVERNAME 25, you do not receive the SMTP banner?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna
Post #: 5
RE: Can't telnet into Exchange SMTP server port 25 - 7.Apr.2009 10:12:48 AM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
De Blackman's suggestion is worth trying and will be telling.  If you don't get the MS-Exchange banner, it means that SMTP is not running.  Check the services on your Exchange server to make sure that Simple Mail Transport Protocol is started. 
Towards that end, your post ...
quote:

The server is forwarding all outgoing, public email to an external smart host (the business' ISP mail server), so I assume SMTP outbound is working fine.
doesn't necessarily mean that TCP 25 is open.  You can change the outbound port in the Virtual SMTP Server settings.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to de.blackman)
Post #: 6
RE: Can't telnet into Exchange SMTP server port 25 - 7.Apr.2009 11:46:33 AM   
urbanriot

 

Posts: 15
Joined: 6.Apr.2009
Status: offline
Thank you for your responses gentlemen:

quote:

Just to be sure... is the server running a firewall (even the Windows) one? Tried disabling that?

The Windows firewall service is disabled. In routing and remote access, one of the more public NICs have the RRAS firewall enabled but it's not on the local or internal ports.

quote:

If Symantec is removed, are you sure it's removed completely? Any possible references still lurking in the registry?

This is Symantec Corporate Antivirus, to which the links you provided are invalid (as they are for Norton Antivirus). I'm not aware that the corporate package requires or has any third party removal tools.

quote:

So when you are logged on to the exchange server and you run a TELNET SERVERNAME 25, you do not receive the SMTP banner?

Correct. Either one of two things happen... the command line console immediately clears the screen and I'm still at the command prompt or the screen clears with a flashing _ underscore in the top left hand corner and if I hit a key it immediately puts me at the command line (that might be a telnet behaviour though).

quote:

If you don't get the MS-Exchange banner, it means that SMTP is not running.  Check the services on your Exchange server to make sure that Simple Mail Transport Protocol is started. 


All right, under Server Properties in Exchange System Manager, in the Monitoring tab I have "Default Microsoft Exchange Services - Stopped." However in the properties of that I have:

Microsoft Exchange Information Store - Running
Microsoft MTA Stacks - Stopped
Microsoft Exchange Routing Engine - Running
Microsoft Exchange System Attendant - Running
Simple Mail Transfer Protocol (SMTP) - Runnning
World Wide Web Publishing Service - Running


If I recall correctly, the status will display as critically stopped if any one of those is stopped, and MTA stacks is for downward compatibility with something else... it's been a while, but I think everything there looks as it should.



Post #: 7
RE: Can't telnet into Exchange SMTP server port 25 - 7.Apr.2009 11:51:39 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
When you telnet locally on an exchange server, you should get the SMTP banner not just a flashing cursor. This tells me that something has a hold of the SMTP protocol on that server and it is not exchange OR the configuration of your SMTP virtual server in exchange is not correct. How many NICs do you have on the server? How many IP addresses does the server have?



_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to urbanriot)
Post #: 8
RE: Can't telnet into Exchange SMTP server port 25 - 7.Apr.2009 12:14:24 PM   
urbanriot

 

Posts: 15
Joined: 6.Apr.2009
Status: offline
The server has two NICs, one to respond to internet requests and the other to respond to network requests:

Ethernet adapter Network:
Connection-specific DNS Suffix  . : network.local
IPv4 Address. . . . . . . . . . . : 192.168.0.100
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : 192.168.0.100

Ethernet adapter Internet:
Connection-specific DNS Suffix  . :
IPv4 Address. . . . . . . . . . . : 10.10.10.10
Subnet Mask . . . . . . . . . . . : 255.255.255.192
Default Gateway . . . . . . . . . : 10.10.10.1
DNS Servers . . . . . . . . . . . : 10.10.10.1


C:\netstat -ano -p TCP
TCP    0.0.0.0:25    0.0.0.0:0     LISTENING     2388

PID 2388 is inetinfo.exe, which is expected behaviour.

Hrmmm...

< Message edited by urbanriot -- 7.Apr.2009 2:27:00 PM >

(in reply to de.blackman)
Post #: 9
RE: Can't telnet into Exchange SMTP server port 25 - 7.Apr.2009 1:40:27 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
How many SMTP virtual servers are available on the server? Can you check and see if it using a specific IP address? If so, change it to All Unassigned and restart the SMTP service.

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to urbanriot)
Post #: 10
RE: Can't telnet into Exchange SMTP server port 25 - 7.Apr.2009 2:29:53 PM   
urbanriot

 

Posts: 15
Joined: 6.Apr.2009
Status: offline
First of all I previously posted the wrong server's addressing information and I've edited the above post with accurate information. I was rdp'ing into another server, which was rdp'd to the server in question, oops.

Secondly, I have just one SMTP Virtual Server assigned to IP address 192.168.0.100. I set it to All Unassigned, restarted it and attempted to telnet to all local addresses and I have the same results.

(in reply to de.blackman)
Post #: 11
RE: Can't telnet into Exchange SMTP server port 25 - 8.Apr.2009 10:23:18 AM   
Flip

 

Posts: 5
Joined: 9.Jan.2008
Status: offline
Since it is an SBS 2003 box, have you verified that ISA server is not causing any issues with Telnet, SMTP, port 25?

(in reply to urbanriot)
Post #: 12
RE: Can't telnet into Exchange SMTP server port 25 - 8.Apr.2009 10:52:47 AM   
urbanriot

 

Posts: 15
Joined: 6.Apr.2009
Status: offline
Flip, it's SBS standard, not premium. No ISA or SQL. Actually, the sole purpose of this server is just for Blackberry users since the Blackberry software is incompatible with their x64 servers.

Neko, I've manually removed every single key relating to this software (some existed, but the services were not running) AND I ran that third party removal tool. I still can't access but I won't have the ability to reboot until the evening...

I'm no BES expert, could that be causing me any trouble?

Thanks again guys!

(in reply to Flip)
Post #: 13
RE: Can't telnet into Exchange SMTP server port 25 - 12.Apr.2009 4:24:51 PM   
urbanriot

 

Posts: 15
Joined: 6.Apr.2009
Status: offline
All right, so I've gone so far as to remove BES, and anything else not Microsoft from the server. There's no antivirus or anti-spam software... and I still can't connect. I'm at wit's end here... anyone have any further ideas?

(in reply to urbanriot)
Post #: 14
RE: Can't telnet into Exchange SMTP server port 25 - 13.Apr.2009 9:46:55 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
There is a tool called TRANSWIZ.exe which allows you to look at the SMTP protocol on an exchange server and it shows you the various event sinks placed by different applications that tie into the SMTP protocol (such as an antivirus). I have seen situations whereby even after uninstalling an AV from a server, the even sinks remain active on the SMTP protocol.

I am looking for a site that you can download Transwiz and when I do will post it back here.

Using the tool is very straight forward. When you open it, you'll see the SMTP protocol information and under it, all event sinks will be shown. If anything resembles an Antivirus sink, DISABLE it and restart the SMTP protocol (do not delete anything!).

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to urbanriot)
Post #: 15
RE: Can't telnet into Exchange SMTP server port 25 - 13.Apr.2009 11:40:36 AM   
uemurad

 

Posts: 8232
Joined: 7.Jan.2004
From: California, USA
Status: offline
I haven't used it before, but here is the transwiz.exe that DeBlackman was talking about.

_____________________________

Regards,

Dean T. Uemura
Microsoft MVP - Exchange (2007-2011)
exchangeguy.blogspot.com
uemurad@yahoo.com

(in reply to de.blackman)
Post #: 16
RE: Can't telnet into Exchange SMTP server port 25 - 13.Apr.2009 7:39:14 PM   
urbanriot

 

Posts: 15
Joined: 6.Apr.2009
Status: offline
Thank you both for continuing to work with me on this problem!

I've used the software and I have the following listed, all with green lights:

POP3 Connector Event Sink
Exchange Transport XEXCH50 Submission sink
Exchange Transport AntiVirus API
ISM SMTP Transport
Small Business Server Attachment Remover

I believe the above API is inherent to Exchange itself and not third party, however I did disable it, restart SMTP and did not experience any difference.

(in reply to de.blackman)
Post #: 17

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> General >> Can't telnet into Exchange SMTP server port 25 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter