Public Folder Disaster (Full Version)

All Forums >> [Microsoft Exchange 2003] >> Public Folders



Message


amadrigal -> Public Folder Disaster (16.Apr.2009 12:12:45 PM)

Please help! I have already learned that I need to set up my Exchange to not delete items until a few days have passed, but that can't help me now. To begin, our setup is an Exchange 2000 (old one) server and an Exchange 2003 (new one) server. When we setup 2003, we began using it as our primary mail server, but left all of the public folders on 2000. There are only a handful of new folders that were created on 2003, and those have continued to work without a problem throughout this fiasco. Here is a rundown of what happened:

1. It is brought to my attention by someone that two of our most important public folders are empty. When I take a look at it, it looks like a new folder that is empty, and says there are no items to show, and to double click to add new contacts.

2. I go to the 2000 server and look at PF instances and I see that those two folders are still filled with data. I tell the server to move all replicas from 2000 to 2003 thinking that it will move the data to the new server and prevent any problems on the old one (we are going to be removing it soon as we barely use it). When this finishes, now nothing shows up except those few folders that were originally created on 2003. The message this time is different, giving me a gray screen and saying that Outlook cannot communicate with the server. This shows up for the original 2 folders that went missing as well as all the others that were on 2000. I realize I probably just made the problem much worse.

3. I look online for a solution and decide to restore the PF store from backup. Briefly, I set properties to allow an overwrite by a restore, used ntbackup to restore, told it to replace the old store, and set last restore set and mount db after restore, all according to the directions I found on a few different websites. I left it running, prayed for the best, and hoped it would be working when I got to the office this morning. It didn't.

4. It still says that it is unable to communicate with the server whenever I try to open a public folder. I restarted everything and nothing changed.

5. I tried adding replicas of 2000 server to the 2003 server. This may have also been a bad idea. Now, every folder shows up like the original 2 (they look like new folders that are empty, with message no items to show, double click to add new).

I fear that this may have not been a serious problem but I have made it progressively worse with every attempt to fix it. Below is a basic rundown of what the servers look like now in System Manager (with the exception of the few that were created on 2003 and have always worked throughout this mess). Hopefully this will be able to help someone help me.

2003 Server
Public Folder Instances shows a list of every folder with the size 0
Public Folders shows a list of every folder with the size 0

2000 Server
Public Folder Instances shows a list of every folder with the correct folder sizes
Public Folders shows only two folders, Default and ExchangeVI

The fact that the folder sizes are correct on PF Instances on 2000 server give me hope that this can be fixed. Even if I have to get the data out manually and move it over, I don't mind, but I am not sure how to get to that info.




rsmudliar123 -> RE: Public Folder Disaster (16.Apr.2009 5:49:32 PM)

Move all Replicas is very critical when not handled properly.

Now in your case simply get the data back from backup. Which is time saving with less administrative effort.




amadrigal -> RE: Public Folder Disaster (20.Apr.2009 9:20:49 AM)

Rsmudliar123, if you had actually read my post, you would have seen that I did try to restore from backup and that it did not restore my public folders.

Can someone please make some helpful suggestions? Everything I tried has been detailed in my post and I don't know what to do next. Thank you!




amadrigal -> RE: Public Folder Disaster (22.Apr.2009 2:16:26 PM)

Does anyone have any ideas? At this point I will recreate manually if necessary, but I NEED to do something and I have no idea what do to.




amadrigal -> RE: Public Folder Disaster (28.Apr.2009 10:58:04 AM)

Wow. Can't believe I haven't gotten any responses yet. In the past I have gotten tons of help solving problems usually within a few days. Been almost 2 weeks already. If anyone has any ideas I haven't tried yet PLEASE help. 




Natalie -> RE: Public Folder Disaster (15.May2009 8:55:00 AM)

Hi Amadrigan,

I can see you are struggling slightly. I'm not sure if you've resloved your issue, but this website may be of some use to you:

http://www.ontrackpowercontrols.co.uk/exchange-solutions/overview/

Hope this helps,

Natalie




Page: [1]