• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

NDR Delayed & Incorrect

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Message Routing >> NDR Delayed & Incorrect Page: [1]
Login
Message << Older Topic   Newer Topic >>
NDR Delayed & Incorrect - 7.May2009 4:58:00 PM   
dubbin

 

Posts: 25
Joined: 3.Jul.2008
Status: offline
I did some searching and didn't see much reference to this question, so if it's been posted before I apologize.

Currently if an internal or external user sends a mail to someone who does not have an address, the NDR is not delivered for up to two hours. Also, the NDR is 5.4.6 showing the following:

#554 5.4.6 Hop count exceeded - possible mail loop ##

In the header it shows the message bouncing between my 1 Edge Transport & 3 Hub Transport machines.

So not only is the NDR delayed for a very long time, it's returning the wrong NDR...

Any help would be great, I can provide anything needed just didn't want to add useless information here.

Thanks in advance!!
Post #: 1
RE: NDR Delayed & Incorrect - 7.May2009 5:30:49 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

Just to verify the problem occurs when:

- internal user sends mail to not existing internal user
- internal user sends mail to not existing external user
- external user sends mail to not existing internal user

Can you please confirm this?

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to dubbin)
Post #: 2
RE: NDR Delayed & Incorrect - 7.May2009 5:37:57 PM   
dubbin

 

Posts: 25
Joined: 3.Jul.2008
Status: offline
quote:

ORIGINAL: jveldh

Hi,

Just to verify the problem occurs when:

- internal user sends mail to not existing internal user
- internal user sends mail to not existing external user
- external user sends mail to not existing internal user

Can you please confirm this?


It does not happen when internal sends to external user, but yes to the other two...

(in reply to jveldh)
Post #: 3
RE: NDR Delayed & Incorrect - 8.May2009 2:22:35 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

Please check the DNS both internal and external. And please describe how the send connectors are defined, is this with smart-hosts ? and if so do they point to fqdn's or ip-addresses ?

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to dubbin)
Post #: 4
RE: NDR Delayed & Incorrect - 11.May2009 11:08:42 AM   
dubbin

 

Posts: 25
Joined: 3.Jul.2008
Status: offline
Could you please elaborate on checking DNS, are you talking about our actual DNS server entries or you talking about how DNS is configured on my Exchange devices?

/sorry

I'm using EdgeSync and the Outbound is using DNS, but my inbound is using a smarthost of '--'

There is also a receive connector on the Edge Transport server setup to accept mail using the range of the Hub Transport machines.

I'm also seeing a lot more spam than usual... We use Postini

< Message edited by dubbin -- 11.May2009 11:36:05 AM >

(in reply to jveldh)
Post #: 5
RE: NDR Delayed & Incorrect - 11.May2009 1:20:21 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

I indeed ment if it was looking in the external dns or in the internal dns.

Did you try to use the mail flow troubleshooter and the Exbpa to check for issues ?

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to dubbin)
Post #: 6
RE: NDR Delayed & Incorrect - 11.May2009 1:40:00 PM   
dubbin

 

Posts: 25
Joined: 3.Jul.2008
Status: offline
Outbound - Using MX Records using External DNS
Inbound - Smart Host not using External DNS

I'll try running EXBPA and see what turns up...

EXBPA didn't show anything out of the ordinary other than some Page File errors which we've seen before.

< Message edited by dubbin -- 11.May2009 1:47:41 PM >

(in reply to jveldh)
Post #: 7
RE: NDR Delayed & Incorrect - 11.May2009 4:31:35 PM   
dubbin

 

Posts: 25
Joined: 3.Jul.2008
Status: offline
I also have about 3500 messages in the Submission Queue on the Edge, and it seems that 99% are spam. This is a new symptom...

(in reply to dubbin)
Post #: 8
RE: NDR Delayed & Incorrect - 11.May2009 4:35:56 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

Do you use the anti-spam agents on your Edge ? These can prevent a lot of spam.

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to dubbin)
Post #: 9
RE: NDR Delayed & Incorrect - 11.May2009 4:41:16 PM   
dubbin

 

Posts: 25
Joined: 3.Jul.2008
Status: offline
I'm using some of the Anti-Spam functionality yes...

(in reply to jveldh)
Post #: 10
RE: NDR Delayed & Incorrect - 11.May2009 4:58:55 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

Can you post an overview of the spam mails in the queue ?

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to dubbin)
Post #: 11
RE: NDR Delayed & Incorrect - 11.May2009 5:09:23 PM   
dubbin

 

Posts: 25
Joined: 3.Jul.2008
Status: offline
http://img516.imageshack.us/my.php?image=queue.png

As you can see, the submission queue has gone down, but there are tons of queues going on with spam messages in them.

< Message edited by dubbin -- 11.May2009 5:10:41 PM >

(in reply to jveldh)
Post #: 12
RE: NDR Delayed & Incorrect - 18.May2009 10:22:16 AM   
dubbin

 

Posts: 25
Joined: 3.Jul.2008
Status: offline
/bump

(in reply to dubbin)
Post #: 13
RE: NDR Delayed & Incorrect - 18.May2009 8:05:39 PM   
yeowow

 

Posts: 22
Joined: 20.Jul.2008
Status: offline
Also look at your Accepted Domains under "Organization Configuration\Hub Transport" and ensure that the types are configured correctly.

You may need to set it to Authoritative or Internal Relay depending on your exact configuration and how you wish email to be handled.

(in reply to dubbin)
Post #: 14
RE: NDR Delayed & Incorrect - 19.May2009 12:58:48 PM   
dubbin

 

Posts: 25
Joined: 3.Jul.2008
Status: offline
Ok, I think that's the problem because we originally had to make it Internal Relay for our legacy email system. Guess we just never went back to change this. We have a few domains and they were all set to relay. I'll change this and let you know.

Thanks!

Update:

That fixed it so far, just keeping an eye on some of this spam that was accumulating in the queue on the Edge.

< Message edited by dubbin -- 19.May2009 1:48:23 PM >

(in reply to yeowow)
Post #: 15

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Message Routing >> NDR Delayed & Incorrect Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter