• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Strange "MapiExceptionNotAuthorized" error with INTERNAL mail

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Message Routing >> Strange "MapiExceptionNotAuthorized" error with INTERNAL mail Page: [1]
Login
Message << Older Topic   Newer Topic >>
Strange "MapiExceptionNotAuthorized" error wi... - 15.Jun.2009 4:10:15 AM   
ovset

 

Posts: 2
Joined: 15.Jun.2009
Status: offline
When internal (office outlook or OWA) user sends message to mail-enabled PF, the message returns with NDR: 

#550 5.2.0 STOREDRV.Deliver: The Microsoft Exchange Information Store service reported an error. The following information should help identify the cause of this error: "MapiExceptionNotAuthorized:16.18969:B90C0000, 17.27161:0000000066020000000000001F00000000000000, 255.23226:00000000, 255.27962:7A000000, 255.27962:0A000000, 255.27962:0E000000, [skipped]

Here is workaround:
1. The sending user has "Owner" permissions on the mail-enabled folder.
2. Anonymous has "Author" permissions
3. Default permissions is "Author" too.
4. The PF does not require sender authentication
5. Any message from any external (i.e. anonymous) sender successfully deliveries to the PF. And that is no difference in smtp connector (internal with auth or external anonymous)

I created new PF and tried to send mail to it. 
I tried to give the "Owner" permissions to anonymous on that newly created public folder.

Here is result of "Get-PublicFolderClientPermission -Identity \iamtest3 | FL" command:

Identity     : \imtest3
User         : Default
AccessRights : {ReadItems, CreateItems, EditOwnedItems, DeleteOwnedItems, EditA
               llItems, DeleteAllItems, CreateSubfolders, FolderOwner, FolderVi
               sible}

Identity     : \iamtest3
User         : domain.com/domain/admin1
AccessRights : {Owner}

Identity     : \iamtest3
User         : domain.com/domain/user1
AccessRights : {Owner}

Identity     : \iamtest3
User         : Anonymous
AccessRights : {ReadItems, CreateItems, EditOwnedItems, DeleteOwnedItems, EditA
               llItems, DeleteAllItems, CreateSubfolders, FolderOwner, FolderVi
               sible}


So...
1. MapiExceptionNotAuthorized when sending inside.
2. Message successfully deliveded when sending throught any smtp connector (with or without authentication).
3. If I check the option to require all senders be authenticated, I get #550 5.7.1 RESOLVER.RST.AuthRequired; authentication required when sending throught any smtp connector.
    
User1 was only an example. I tried to send mail from several domain users maiboxes. And from newly created users too.

I checked out permissions in AD on:

1. CN=Configuration -> CN=Services -> CN=Microsoft Exchange -> CN=My Exchange Organization -> CN=Folder Hierarchies -> CN=Public Folders
2. CN=Configuration -> CN=Services -> CN=Microsoft Exchange -> CN=My Exchange2003 Organization -> CN=Folder Hierarchies -> CN=Public Folders

All permissions are OK (and are propagated from parent). There are two Orgs because of migration from 2003 (it was long time ago).

I checked out that no update was installed on any server for as least three days before the problem appears.

Here is ExBPA report:

Post #: 1
WOW! I broke it... In a new issue :) - 16.Jun.2009 6:57:39 AM   
ovset

 

Posts: 2
Joined: 15.Jun.2009
Status: offline
After many and different experiments...
I got new situation: now it works in a new manner.

All tests were made with smtp client:
1. Every message that have @mydomain.com "From" address does not delivere. And I get NDR with MapiExceptionNotAuthorized error.
2. Every message that have @anyforeign.com "From" address deliveres to PF.
3. When I add @foreigndomain.com smtp address to my test exchange user and send message, that message does not delivere. With NDR delivered to user's primary smtp address.

(in reply to ovset)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Message Routing >> Strange "MapiExceptionNotAuthorized" error with INTERNAL mail Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter