ActiveSync Error 0x80072f0d - Exchange 2007 (Full Version)

All Forums >> [Microsoft Exchange 2007] >> Mobility



Message


scwconsulting -> ActiveSync Error 0x80072f0d - Exchange 2007 (22.Jun.2009 1:29:14 PM)

I'm beating my head up trying to figure this one out.

Exchange 2007 SP1 Server being used in a CoExist Network behind an Exchange 2000 Server. I can access OWA just fine and have issues a new certicate using Selfssl. Currently, they're not trying to use ActiveSync from outside the network, just internal so using an internal address ie server.domain.local. I have imported the certicate into the correct Certificate stores as well as on the phones (using Windows Mobile 5 and 6 for testing).

The error we get on the phone is as follows:

support code: 0x80072f0d
The security certificate on the server is invalid....

Any help with this would be really appreciated.




scwconsulting -> RE: ActiveSync Error 0x80072f0d - Exchange 2007 (22.Jun.2009 2:16:34 PM)

Okay well I reissued the Certificate using IIS7 instead of IE and it worked for two syncs for one user and then quit again and is giving th same error. No event log messages either. I'm lost :(




scwconsulting -> RE: ActiveSync Error 0x80072f0d - Exchange 2007 (22.Jun.2009 2:35:58 PM)

Sorry I was wrong. It only works if I remove the SSL option when syncing the PDA. Otherwise, if using SSL it fails with the same error above.




scwconsulting -> RE: ActiveSync Error 0x80072f0d - Exchange 2007 (22.Jun.2009 7:16:06 PM)

No responses yet but I guess only one question needs to be answered before I go any further....

Will SELF Signed Certificate's work with Exchange 2007 ActiveSync?




ratishnair -> RE: ActiveSync Error 0x80072f0d - Exchange 2007 (18.Jul.2009 3:32:05 PM)

Hi,

We can get self-signed certificates to work with Exchange.
My question is, have you installed the root certificate on the mobile device ?

Also, when you configured the mobile device, what did you put in the "SERVER ADDRESS" Field ?
Say for instance you typed in server.domain.local in the "SERVER ADDRESS" Field, then your certificate should be issued to server.domain.local

The point is, the certificate should be issued to the webmail url you are trying to access and the Root certificate should be installed on the mobile device.

For installing the root certificate, got to Default Website--> Properties--> Directory Security--> View Certificate--> Click on Certification Path--> Double click on the Root Certificate--> Click the Details Tab--> Click Copy to a file--> Copy the certificate on the Desktop in the *.cer Format.

Now. install this certificate on the mobile device and try to sync.





davtup -> RE: ActiveSync Error 0x80072f0d - Exchange 2007 (19.Jul.2009 1:33:56 PM)

Dear scwconsulting,
please do some thing below:
1. check ssl require on virtual directory Microsoft-Server-Activesync.
2. did you try type your CAS server name only, for example just type CAS-SERVER (same name with certificate name) on your mobile when configure Activesync.




Page: [1]