• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Receiving email

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Installation >> Receiving email Page: [1]
Login
Message << Older Topic   Newer Topic >>
Receiving email - 30.Aug.2009 8:59:08 PM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
Hi All

I have set up a new exchange 2007 standard server 64bit. Everything is using standard settings. I created a send connector that uses DNS for outbound email this works fine.

I have dynamic IP Address and therefore have dynamic dns (dyndns.org) setup. e.g. mail.dyndns.org

I can telnet on mail.dyndns.org on port 25 and I get a connection.

My actual email domain is mydomain.com. I have created an mx record that forwrds mydomain.com to mail.dyndns.org.

However whenever I send to that account I get....

Reporting-MTA: dns; xmail-1.exchange.datagate.net

Final-recipient: RFC822; me@mydomain.com
Action: failed
Status: 5.7.1
Remote-MTA: dns; SrvEXCH1.mail.local Note this is the name of my exchange server that is receiving the email, so this tells me the connection is being made
X-Supplementary-Info: <SrvEXCH1.mail.local #5.7.1 smtp;530 5.7.1 Client was
not authenticated>
X-Display-Name: Me

Can anyone explain why this happens? Why isn't the exchange server that I am sending from being authenticated? I am new to Exchange 2007. Do I need to to create an inbound connector as I did with sending email?

Thanks in advance
Post #: 1
RE: Receiving email - 30.Aug.2009 9:13:51 PM   
Elan Shudnow

 

Posts: 897
Joined: 4.Jan.2007
From: Chicago, IL
Status: offline
quote:

ORIGINAL: benny99

Do I need to to create an inbound connector as I did with sending email?



Yes, you need to enable Anonymous on an Internet Receive Connector to receive internet mail.

More information:
http://technet.microsoft.com/en-us/library/aa998212.aspx

_____________________________

Elan Shudnow
Exchange MVP
http://www.shudnow.net

(in reply to benny99)
Post #: 2
RE: Receiving email - 30.Aug.2009 9:30:33 PM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
Could you tell me where or how please?

many thanks

(in reply to Elan Shudnow)
Post #: 3
RE: Receiving email - 30.Aug.2009 9:31:18 PM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
sorry just seen the link. will have a read thanks

(in reply to benny99)
Post #: 4
RE: Receiving email - 31.Aug.2009 8:35:50 AM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
OK I have read the document and sorry to say that I dont quite follow it.

quote:

The Receive connector that is capable of receiving mail from the Internet and from Hub Transport servers is automatically created when the Edge Transport server role is installed. However, end-to-end mail flow is possible only after the Edge Transport server has been subscribed to the Active Directory directory service site by using the Edge Subscription process. Other scenarios, such as an Internet-facing Hub Transport server or an unsubscribed Edge Transport server, require manual connector configuration to establish end-to-end mail flow. For more information, see the following topics:


I have installed the default exchange standard with the hub transport role. Does the statement above mean I have to re run the set up and install the edge transport as well? Or would it be easier just to manually create the connector.

I did have a go at making a receive connector but not sure of the settings it is asking for. When I complete the set up it complains that it conflicts with the settings in the default receive connector.

I gave it the name of Internet Receive Connector. I select custom as the intended use of this connector.

Next Step: Use these local IP Addresses to receive email from. I am not sure what this is asking as external email will be coming from the firewall so do I put the internal firewall address or am I meant to select the IP of the exchange server.

Next Step: Provide the FQDN which this connector will provide in response to the HELO or EHLO: Again I am not sure what I should be providing here. Should this be mydomain.com

I leave all the default responses I get Error when Creating. The values you specfied for the bindings and remoteIPRanges parametres conflict withe the settings on receive connetor SRVExch1\Default.

Any further help you can provide would be great. Thanks

(in reply to benny99)
Post #: 5
RE: Receiving email - 31.Aug.2009 9:51:48 AM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Benny,

The remote ip must be set to 0.0.0.0 - 255.255.255.255
About the ehlo/helo this one must match the fqdn of your mailserver on the outside, for example: mail.domain.com

If you like you can also create it using the Exchange Management Shell:

new-receiveconnector -Name 'Receive from Internet'-Type FromInternet -Bindings 0.0.0.0:25 -RemoteIPRanges 0.0.0.0- 255.255.255.255

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to benny99)
Post #: 6
RE: Receiving email - 31.Aug.2009 10:19:45 AM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
How can I determine what the FQDN Should be.

I am using the one exchange server to respond to more than one domain name. So in reality my domains are

mydomain.com and yourdomain.com

being forwarded to domain.dyndns.org

Sorry to make things confusing, I think this is why I have got in a muddle.

(in reply to jveldh)
Post #: 7
RE: Receiving email - 31.Aug.2009 10:27:47 AM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
I tried the following with the wizard in the mgt console

Exchange Management Shell command attempted:
new-ReceiveConnector -Name 'Internet Receive Connector' -Usage 'Internet' -Bindings '0.0.0.0:25' -Fqdn 'domain.dyndns.org' -Server 'SRVEXCH1'


Note that the type internet does not allow you to specify the remote IP. Only custom type provides this setting option. However even under custom and using the default setting (the same that you specified) I get the conflict error with the default.

Exchange Management Shell command attempted:
new-ReceiveConnector -Name 'Internet Receive Connector' -Usage 'Custom' -Bindings '0.0.0.0:25' -Fqdn 'domain.dyndns.org' -RemoteIPRanges '0.0.0.0-255.255.255.255' -Server 'SRVEXCH1'

Error:
The values that you specified for the Bindings and RemoteIPRanges parameters conflict with the settings on Receive connector "SRVEXCH1\Default SRVEXCH1". A Receive connector must have a unique combination of a local IP address, port bindings, and remote IP address ranges. Change at least one of these values.

(in reply to benny99)
Post #: 8
RE: Receiving email - 31.Aug.2009 10:29:38 AM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
Could I not just allow anonymous connection on the default receive connector??

(in reply to benny99)
Post #: 9
RE: Receiving email - 31.Aug.2009 1:24:07 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

Yes that's also an option, but creating a seperate connector is what I do with implementations.

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to benny99)
Post #: 10
RE: Receiving email - 31.Aug.2009 3:23:06 PM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
Thank Johan, I agree with you but dont see what I am doing wrong with the new connector. The default connector settings are:

Network:
Local IP addresses
All available IPv6 addresses port 25
All available IPv4 addresses port 25

Remote servers from that have these IP Addresses
::-ffff.ffff.ffff.ffff.ffff.ffff.ffff.ffff
0.0.0.0-255.255.255.255.255

Authentication:
TLS (Ticked)
enable domain security (not ticked)
Basic Authentication (ticked)
Offer basic authentication only after starting TLS (ticked)
Exchange Server Authentication (ticked)
Integrated Windows Authentication (ticked)
Externally Secured (not ticked)

Permission Groups
Anonymous (ticked I enabled)
Exchnage Users (ticked)
Exchange servers (ticked)
Legacy Exchange severs (ticked)
PArtners (not ticked)


I can see that the IP are conflicting with the new connector. But how is your default connector different to mine to enable you to create an independeant connector??

(in reply to jveldh)
Post #: 11
RE: Receiving email - 31.Aug.2009 4:00:07 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

It's not diffent but I prefer to leave the default connectors as they are and create a special internet connector. But what type of connector did you tried internet and custom ?

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to benny99)
Post #: 12
RE: Receiving email - 1.Sep.2009 6:49:28 AM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
I tried both :(

(in reply to jveldh)
Post #: 13
RE: Receiving email - 1.Sep.2009 7:07:29 AM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
just to confirm this is the error I am getting...

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:00


Internet Receive Connector
Failed

Error:
The values that you specified for the Bindings and RemoteIPRanges parameters conflict with the settings on Receive connector "SRVEXCH1\Default SRVEXCH1". A Receive connector must have a unique combination of a local IP address, port bindings, and remote IP address ranges. Change at least one of these values.

Exchange Management Shell command attempted:
new-ReceiveConnector -Name 'Internet Receive Connector' -Usage 'Internet' -Bindings '0.0.0.0:25' -Fqdn 'domain.dyndns.org' -Server 'SRVEXCH1'

Elapsed Time: 00:00:00

< Message edited by benny99 -- 1.Sep.2009 7:08:51 AM >

(in reply to benny99)
Post #: 14
RE: Receiving email - 1.Sep.2009 7:21:22 AM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
OK it seems that it is the local address that it conflicts on. If I specify an address it successfully creates a new connector.

Do you usually specify a local address e.g. the address of the server itself?

(in reply to benny99)
Post #: 15
RE: Receiving email - 1.Sep.2009 2:13:50 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi

By specifying 0.0.0.0-255.255.255.255 you will match every remote ip-address so the whole internet. It's not necessary to specify your own server's ip-address unless it has multiple ip-addresses and you want it to listen on one ip-address for smtp traffic.

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to benny99)
Post #: 16
RE: Receiving email - 2.Sep.2009 2:25:29 PM   
benny99

 

Posts: 17
Joined: 20.Mar.2009
Status: offline
seems to all work now. Thanks for your help

(in reply to benny99)
Post #: 17

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Installation >> Receiving email Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter