• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

ActiveSync Proxying Issues

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Mobility >> ActiveSync Proxying Issues Page: [1]
Login
Message << Older Topic   Newer Topic >>
ActiveSync Proxying Issues - 7.Dec.2009 8:30:26 AM   
NunoMota

 

Posts: 14
Joined: 27.Oct.2008
Status: offline
Hi guys,
 
I'm hoping someone can explain me the issue below as I simply can't find an answer for it...
 
Basically, we had our Exchange 2007 environment (2 SCC clusters and 3 HT/CAS servers - more details at the end) all in the same Active Directory site. Last week we moved one cluster and one HT/CAS server to one site and the other cluster and 2 HT/CAS servers to the other site. We also built one virtual HT/CAS server in each site.
 
Site 1
- HTCAS_1
- HTCAS_2_VM (powered off from the start)
- SCC_Cluster_1

 
Site 2
- HTCAS_3
- HTCAS_4
- HTCAS_5_VM
- SCC_Cluster_2


 
Everyone, either internally/externally, who connects to OWA connects to HTCAS_1. So, we configured every HTCAS server according to the Understanding Proxying and Redirection document (http://technet.microsoft.com/en-us/library/bb310763.aspx).
 
The proxying is working perfectly for OWA, ActiveSync and WebServices! Everyone gets connected to HTCAS_1 and gets proxyed to a CAS server on the 2nd site if their mailbox is in that site.
 
I ran all the possible tests like:
- Test-ActiveSyncConnectivity
- Test-OutlookWebServices
- Test-OwaConnectivity
- Test-WebServicesConnectivity
- Test-Mailflow
- Exchange Remote Connectivity Analyzer (all tests)
 
And all of them came out successful.
 
 
My problem is when I turn off any of the CAS servers in Site 2... When I do that, I sometimes get the following error for OWA (in this case I turned off the vm):
 
Microsoft Exchange Client Access server "https://owa.xxxxxxx/owa" attempted to proxy Outlook Web Access traffic to Client Access server "https://htcas_5_vm.xxxxxx.local/owa".
This failed because "https:// htcas_5_vm.xxxxxx.local/owa" did not respond. Outlook Web Access will attempt to proxy this traffic to Client Access server "https://htcas3.xxxxxxx.local/owa" in the same Active Directory site.
 
Which is what one would expect, and it works.
 
However, when the same thing happens to ActiveSync, it just doesn't work... Because we have three CAS servers at site 2, when we shut down one of them, ActiveSync works 2 out of 3 times. When it fails, we get this error:
 
CAS server HTCAS_1 failed to proxy EWS to AD site CN=xxxx,CN=Sites,CN=Configuration,DC=xxxxx,DC=local because none of the CAS servers in this site are responding. Please check the configuration and status of the servers in site CN=xxxx,CN=Sites,CN=Configuration,DC=xxxx,DC=local
 
 
With one of the servers down:
- Test-OutlookWebServices works for all CAS servers except the one that is down or when Autodiscover tries to contact the server that is down
- Test-OwaConnectivity works for all CAS servers except the one that is down
- Test-WebServicesConnectivity works for all CAS servers except the one that is down
- Test-ActiveSyncConnectivity fails sometimes with the error:

CasServer  MailboxServer Scenario        Result  Latency(MS) Error
---------  ------------- --------        ------  ----------- -----
htcas_1                  Options         Success       31.21
htcas_1                  FolderSync      Success      202.89
htcas_1                  First Sync      Success       62.43
htcas_1                  GetItemEstimate Success       46.82
htcas_1                  Sync Data       Failure             [System.Net.WebException
                                                          ]: The remote server ret
                                                          urned an error: (500) In
                                                         ternal Server Error.

                                                          HTTP response headers:

                                                          Content-Length: 0
                                                          Cache-Control: private
                                                          Date: Thu, 03 Dec 2009 1
                                                          0:29:21 GMT
                                                          Server: Microsoft-IIS/6.
                                                          0
                                                          X-AspNet-Version: 2.0.50
                                                          727
                                                          X-Powered-By: ASP.NET
 
 
Why does HTCAS_1 tries to proxy the ActiveSync connection to a server that is powered off?! Why doesn't it work like OWA where it doesn't detects a response and so proxies to another server? Or am I missing something here?
 
This is a big problem for us as we need to shut down the virtual server, but every time we do that, ActiveSync works irregularly...
 
Thank you very much for your time and any help!
 
 
Exchange 2007 environment:
- Exchange 2007 SP1 with all the latest Rollups on all servers;
- 2 SCC clusters, one at each site;
- 5 HT/CAS servers (2 of which are virtual machines, on at each site), two in Site1 and 3 in Site2;
- Active Directory with Windows Server 2003 functional Level;
- Autodiscover is working internally and externally.
 
 
 
Best regards,
Nuno

< Message edited by NunoMota -- 7.Dec.2009 8:32:29 AM >


_____________________________

Nuno Mota
http://LetsExchange.blogspot.com
Post #: 1

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Mobility >> ActiveSync Proxying Issues Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter