• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Cant Receive Emails with Exchange 2010

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> Message Routing >> Cant Receive Emails with Exchange 2010 Page: [1]
Login
Message << Older Topic   Newer Topic >>
Cant Receive Emails with Exchange 2010 - 23.Dec.2009 7:27:02 PM   
brandoincan

 

Posts: 14
Joined: 23.Dec.2009
Status: offline
Hello All,

I have Exchange 2010 running on Windows 2008 R2 Ent server and cannot receive emails externally, however, I can send emails externally and internally.

The following is the configuration on the Server configuration Hub transport.

Hub transport connects directly to the Internet, so no external SMTP gateway is used.

Hub transport:

2 send connectors enabled, client and custome Internet with anti-spam enabled.

Internet Send Connector:

Specify the FQDN this connector will provide = serv01.domain.corp
Network Local = All IPv4 with port 25
Network receive mail from remote servers = ISP smarthost IP address
Authentication = TLS only, enable Domain security unchecked
Permission groups = All checked except partners

Internal DNS lookups uses the network card and External DNS lookups uses 2 external DNS IP addresses.

MX and A records are alread setup with my ISP and is working as previously i had Windows 2003 R2 and Echange 2003 running.

When I telnet from outside the network and inside the network and directly on the box, I get

421 4.3.2 service not available

Any help would be appreciated as I dont know where else to check.

Brando
Post #: 1
RE: Cant Receive Emails with Exchange 2010 - 24.Dec.2009 1:41:12 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

Which authentication types are configured on the connectors ? Please ensure that one of them has anonymous for authentication. My personal advice is to create a seperate receive connector which has this settings.

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to brandoincan)
Post #: 2
RE: Cant Receive Emails with Exchange 2010 - 24.Dec.2009 2:06:34 PM   
brandoincan

 

Posts: 14
Joined: 23.Dec.2009
Status: offline
Johan,

Under receive connectors, nothing is checked in the Authentication tab, for Permission groups, everything is checked off including anonymous.

But when i telnet to the server internally, i am getting

421 4.3.2 service not available

I did a netstat -a and i can see that port 25 is listening. So, i am stomped here.

Brando

(in reply to jveldh)
Post #: 3
RE: Cant Receive Emails with Exchange 2010 - 24.Dec.2009 2:24:41 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

And telnetting on the local machine to the local machine ?

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to brandoincan)
Post #: 4
RE: Cant Receive Emails with Exchange 2010 - 24.Dec.2009 2:31:09 PM   
brandoincan

 

Posts: 14
Joined: 23.Dec.2009
Status: offline
I telnetted from a client PC to the Exchange box, also directly local on the Exchnage box and from outside the network to the public IP which is properly configured for translation on the firewall.

Brando

(in reply to jveldh)
Post #: 5
RE: Cant Receive Emails with Exchange 2010 - 24.Dec.2009 2:46:43 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

And from all of them the same result ?

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to brandoincan)
Post #: 6
RE: Cant Receive Emails with Exchange 2010 - 24.Dec.2009 3:01:12 PM   
brandoincan

 

Posts: 14
Joined: 23.Dec.2009
Status: offline
Yes, same message

(in reply to jveldh)
Post #: 7
RE: Cant Receive Emails with Exchange 2010 - 24.Dec.2009 3:19:56 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi.

Also when performing telnet localhost 25 ? Besides this try to enable anonymous and check again.

Besides this run netstat -nbt to check which program uses port 25.

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to brandoincan)
Post #: 8
RE: Cant Receive Emails with Exchange 2010 - 24.Dec.2009 3:44:04 PM   
brandoincan

 

Posts: 14
Joined: 23.Dec.2009
Status: offline
yes, when i telnet localhost, same message, anonymous is enabled.

funny though, i thought TCP 25 was listening, but now, when i run netstat -nbt, i dont see it anywhere where its listening.

Also, why is IIS smtp service running, is that a normal behaviour as i think in previous versions of Exchange it was disabled as there would be a conflict?

(in reply to jveldh)
Post #: 9
RE: Cant Receive Emails with Exchange 2010 - 24.Dec.2009 4:05:09 PM   
brandoincan

 

Posts: 14
Joined: 23.Dec.2009
Status: offline
I downloaded MS PortQry v2 tool and ran this against my Exchange box and this is the result.

C:\PortQryV2>PortQry.exe -n 192.168.40.11 -p tcp -e 25

Querying target system called:

172.16.1.1

Attempting to resolve IP address to a name...


IP address resolved to reccedc01.lzed.corp

querying...

TCP port 25 (smtp service): LISTENING

Data returned from port:
421 4.3.2 Service not available


so, again not sure

(in reply to brandoincan)
Post #: 10
RE: Cant Receive Emails with Exchange 2010 - 24.Dec.2009 4:26:03 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

Please run get-receiveconnector |fl and post the output here.

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to brandoincan)
Post #: 11
RE: Cant Receive Emails with Exchange 2010 - 24.Dec.2009 4:55:35 PM   
brandoincan

 

Posts: 14
Joined: 23.Dec.2009
Status: offline
eId : 7bf41bf4-77de-4bd5-b655-5dddb2a84d3d
AuthMechanism : Tls, Integrated, BasicAuth, BasicAuthRequireTLS
Banner :
BinaryMimeEnabled : True
Bindings : {0.0.0.0:587}
ChunkingEnabled : True
DefaultDomain :
DeliveryStatusNotificationEnabled : True
EightBitMimeEnabled : True
DomainSecureEnabled : False
EnhancedStatusCodesEnabled : True
LongAddressesEnabled : False
OrarEnabled : False
SuppressXAnonymousTls : False
AdvertiseClientSettings : False
Fqdn : serv01.domain.corp
Comment :
Enabled : True
ConnectionTimeout : 00:10:00
ConnectionInactivityTimeout : 00:05:00
MessageRateLimit : 5
MessageRateSource : User
MaxInboundConnection : 5000
MaxInboundConnectionPerSource : 20
MaxInboundConnectionPercentagePerSource : 2
MaxHeaderSize : 64 KB (65,536 bytes)
MaxHopCount : 30
MaxLocalHopCount : 8
MaxLogonFailures : 3
MaxMessageSize : 10 MB (10,485,760 bytes)
MaxProtocolErrors : 5
MaxRecipientsPerMessage : 200
PermissionGroups : ExchangeUsers
PipeliningEnabled : True
ProtocolLoggingLevel : None
RemoteIPRanges : {::-ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff, 0.0.0.0-255.255.255.255}
RequireEHLODomain : False
RequireTLS : False
EnableAuthGSSAPI : True
LiveCredentialEnabled : False
Server : SERV01
SizeEnabled : Enabled
TarpitInterval : 00:00:05
MaxAcknowledgementDelay : 00:00:30
AdminDisplayName :
ExchangeVersion : 0.1 (8.0.535.0)
Name : Client SERV01
DistinguishedName : CN=Client SERV01,CN=SMTP Receive Connectors,CN=Protocols,CN=SERV01,CN=S
ervers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative G
roups,CN=Funky Mellow,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=l
zed,DC=corp
Identity : SERV011\Client SERV01
Guid : 349eb1cb-bb1a-4100-9eb9-ff88418bcdb4
ObjectCategory : domain.corp/Configuration/Schema/ms-Exch-Smtp-Receive-Connector
ObjectClass : {top, msExchSmtpReceiveConnector}
WhenChanged : 24/12/2009 11:35:47 AM
WhenCreated : 20/12/2009 2:24:58 AM
WhenChangedUTC : 24/12/2009 7:35:47 PM
WhenCreatedUTC : 20/12/2009 10:24:58 AM
OrganizationId :
OriginatingServer : serv01.domain.corp
IsValid : True

RunspaceId : 7bf41bf4-77de-4bd5-b655-5dddb2a84d3d
AuthMechanism : Tls
Banner :
BinaryMimeEnabled : True
Bindings : {172.16.1.1:25}
ChunkingEnabled : True
DefaultDomain :
DeliveryStatusNotificationEnabled : True
EightBitMimeEnabled : True
DomainSecureEnabled : False
EnhancedStatusCodesEnabled : True
LongAddressesEnabled : False
OrarEnabled : False
SuppressXAnonymousTls : False
AdvertiseClientSettings : False
Fqdn : serv01.domain.corp
Comment :
Enabled : True
ConnectionTimeout : 00:10:00
ConnectionInactivityTimeout : 00:05:00
MessageRateLimit : unlimited
MessageRateSource : IPAddress
MaxInboundConnection : 5000
MaxInboundConnectionPerSource : 20
MaxInboundConnectionPercentagePerSource : 2
MaxHeaderSize : 64 KB (65,536 bytes)
MaxHopCount : 30
MaxLocalHopCount : 8
MaxLogonFailures : 3
MaxMessageSize : 10 MB (10,485,760 bytes)
MaxProtocolErrors : 5
MaxRecipientsPerMessage : 200
PermissionGroups : AnonymousUsers, ExchangeUsers, ExchangeServers, ExchangeLegacyServers
PipeliningEnabled : True
ProtocolLoggingLevel : Verbose
RemoteIPRanges : {206.12.82.139}
RequireEHLODomain : False
RequireTLS : False
EnableAuthGSSAPI : False
LiveCredentialEnabled : False
Server : SERV01
SizeEnabled : Enabled
TarpitInterval : 00:00:05
MaxAcknowledgementDelay : 00:00:30
AdminDisplayName :
ExchangeVersion : 0.1 (8.0.535.0)
Name : Internet_Receive Connector
DistinguishedName : CN=Internet_Receive Connector,CN=SMTP Receive Connectors,CN=Protocols,CN=SERV01
,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administra
tive Groups,CN=Funky Mellow,CN=Microsoft Exchange,CN=Services,CN=Configuratio
n,DC=domain,DC=corp
Identity : SERV01\Internet_Receive Connector
Guid : 5127275e-4045-4f92-b334-2637d6e0041e
ObjectCategory : domain.corp/Configuration/Schema/ms-Exch-Smtp-Receive-Connector
ObjectClass : {top, msExchSmtpReceiveConnector}
WhenChanged : 24/12/2009 12:28:24 PM
WhenCreated : 22/12/2009 9:17:27 PM
WhenChangedUTC : 24/12/2009 8:28:24 PM
WhenCreatedUTC : 23/12/2009 5:17:27 AM
OrganizationId :
OriginatingServer : serv01.domain.corp
IsValid : True

(in reply to jveldh)
Post #: 12
RE: Cant Receive Emails with Exchange 2010 - 25.Dec.2009 10:38:07 AM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

On the connector which has the anonymous group assigned to it I see that you only accept connections from a specific IP:

RemoteIPRanges : {206.12.82.139}

This can cause the issue, please remove this and try again.

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to brandoincan)
Post #: 13
RE: Cant Receive Emails with Exchange 2010 - 25.Dec.2009 1:35:39 PM   
brandoincan

 

Posts: 14
Joined: 23.Dec.2009
Status: offline
Hello Johan,

Seasons greetings and thanks for the reply today.

I removed the IP aadress restrctions and now when someone sends me a message I am getting a NDR 5.7.1 UNABLE TO RELAY report.

I can telnet to the public IP address and I get the expected behaviour of 220..... when i try to send a email from this telnet session RCPT:admin@test.com, i also get the 5.7.1 unable to relay error.

I have been through the config and even formatted and started from scratch and I have no idea where else to look.

Brando

(in reply to jveldh)
Post #: 14
RE: Cant Receive Emails with Exchange 2010 - 25.Dec.2009 1:53:03 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

OK that's good to hear, it's a step ahead ;-)
Can you please explain how you tested and it not like below test it as below:

telnet fqdnofyourmailserver 25
helo yourdomain.com
mail from: externaluser@external.com
rcpt to:existinguser@yourdomain.com
data
this is a test.
.

And then check if it accepts your mail, one import thing is that the domain you are sending to is added as an accepted domain for your server.

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to brandoincan)
Post #: 15
RE: Cant Receive Emails with Exchange 2010 - 25.Dec.2009 2:43:08 PM   
brandoincan

 

Posts: 14
Joined: 23.Dec.2009
Status: offline
Johan,

i followed your format for testing and when i did the
rcpt to:username@mydomain.com, i get a 550 5.7.1 Unable to relay error

Question, the domain I am sending to as in mydomain.corp? mydomain.corp is my internal domain and it is a accepted domain and it is also the authoritative domain as well.

(in reply to jveldh)
Post #: 16
RE: Cant Receive Emails with Exchange 2010 - 26.Dec.2009 3:02:33 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

Please run get-receiveconnector |fl again and post the results it might have to do with incorrect remote ip-address ranges specified.

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to brandoincan)
Post #: 17
RE: Cant Receive Emails with Exchange 2010 - 26.Dec.2009 8:17:12 PM   
brandoincan

 

Posts: 14
Joined: 23.Dec.2009
Status: offline
Johan,

I was able with the assistance to find the problem and the issue was that i didnt have domain.com in the accepted domains tab, I only had domain.corp and thats what threw me off.

Emails work bidirectional now. Thanks for your help.

We can close this post.

Brando

(in reply to jveldh)
Post #: 18

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> Message Routing >> Cant Receive Emails with Exchange 2010 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter