fqdn helo (Full Version)

All Forums >> [Microsoft Exchange 2010] >> Installation



Message


yunker -> fqdn helo (20.Feb.2010 11:06:56 AM)

I hope someone else has experienced this:
setting the fqdn for the sendconnector
I have set it in the EMC
"Specify the FQDN this connector will provide in response to HELO or EHLO" to mail.domain.com
the cmd get-senderconnector | fl
returns fqdn = mail.domain.com
however when you telnet the server and put in helo it returns with the AD name.
When sending mail it correctly identifys itself as mail.domain.com but also as ADname.domain.com.
Could this come from IPv6?
The reason for this problem has to do with SSL Certificate, if we use the selfmade for OWA and ActiveSync the internal clients complain about the Certificate.

Appreciate any suggestions.

Jeff




jveldh -> RE: fqdn helo (20.Feb.2010 11:38:55 AM)

Hi,

This is logical since you only set the FQDN on the send connector. Please perform the same task on the receive connector:

get-receiveconnector|set-receiveconnector -fqdn mail.domain.com




yunker -> RE: fqdn helo (22.Feb.2010 6:58:20 AM)

Thanks for the reply Joahn,

Sorry forgot to mention I had already done that with set-receiveconnector. There are default 2 connectors one for 25 the other 587 I played around with different attempts but made no difference. Fact is Default (port 25) fqdn= mail.domain.com and client (port 587) = ADname.domain.com.
Telnet to port 25 helo is still ADname, problem is as I mentioned SSL certificate.

?




jveldh -> RE: fqdn helo (22.Feb.2010 3:26:34 PM)

Hi,

Have you tried to reboot the server or restart the Exchange Transport service ?

Pleae run get-receiveconnectors |fl and post the output here.




yunker -> RE: fqdn helo (23.Feb.2010 12:23:11 PM)

I haven't restarted the server will do but have several times restart-service msexchange transport
here is the results of the get cmdlet:


RunspaceId : 69da0d28-ad7a-456e-909c-c75f4aeaa296
AuthMechanism : Tls, Integrated, BasicAuth, BasicAuthRequireTLS, ExchangeServer
Banner :
BinaryMimeEnabled : True
Bindings : {:::25, 0.0.0.0:25}
ChunkingEnabled : True
DefaultDomain :
DeliveryStatusNotificationEnabled : True
EightBitMimeEnabled : True
DomainSecureEnabled : False
EnhancedStatusCodesEnabled : True
LongAddressesEnabled : False
OrarEnabled : False
SuppressXAnonymousTls : False
AdvertiseClientSettings : False
Fqdn : DC01.softwhere-it.com
Comment :
Enabled : True
ConnectionTimeout : 00:10:00
ConnectionInactivityTimeout : 00:05:00
MessageRateLimit : unlimited
MessageRateSource : IPAddress
MaxInboundConnection : 5000
MaxInboundConnectionPerSource : unlimited
MaxInboundConnectionPercentagePerSource : 100
MaxHeaderSize : 64 KB (65,536 bytes)
MaxHopCount : 30
MaxLocalHopCount : 8
MaxLogonFailures : 3
MaxMessageSize : 97.89 MB (102,645,760 bytes)
MaxProtocolErrors : 5
MaxRecipientsPerMessage : 5000
PermissionGroups : AnonymousUsers, ExchangeUsers, ExchangeServers, ExchangeLegacyServers
PipeliningEnabled : True
ProtocolLoggingLevel : Verbose
RemoteIPRanges : {::-ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff, 0.0.0.0-255.255.255.255}
RequireEHLODomain : False
RequireTLS : False
EnableAuthGSSAPI : False
LiveCredentialEnabled : False
Server : DC01
SizeEnabled : EnabledWithoutValue
TarpitInterval : 00:00:05
MaxAcknowledgementDelay : 00:00:30
AdminDisplayName :
ExchangeVersion : 0.1 (8.0.535.0)
Name : Default DC01
DistinguishedName : CN=Default DC01,CN=SMTP Receive Connectors,CN=Protocols,CN=DC01,CN=Servers,CN
=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=
Softwhere-IT,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=softwhere-
it,DC=com
Identity : DC01\Default DC01
Guid : 80cbf912-11d6-44b6-b4ed-120e1e4505fd
ObjectCategory : softwhere-it.com/Configuration/Schema/ms-Exch-Smtp-Receive-Connector
ObjectClass : {top, msExchSmtpReceiveConnector}
WhenChanged : 19.02.2010 23:35:46
WhenCreated : 18.02.2010 21:44:52
WhenChangedUTC : 19.02.2010 22:35:46
WhenCreatedUTC : 18.02.2010 20:44:52
OrganizationId :
OriginatingServer : soft01b.softwhere-it.com
IsValid : True

RunspaceId : 69da0d28-ad7a-456e-909c-c75f4aeaa296
AuthMechanism : Tls, Integrated, BasicAuth, BasicAuthRequireTLS
Banner :
BinaryMimeEnabled : True
Bindings : {:::587, 0.0.0.0:587}
ChunkingEnabled : True
DefaultDomain :
DeliveryStatusNotificationEnabled : True
EightBitMimeEnabled : True
DomainSecureEnabled : False
EnhancedStatusCodesEnabled : True
LongAddressesEnabled : False
OrarEnabled : False
SuppressXAnonymousTls : False
AdvertiseClientSettings : False
Fqdn : dc01.softwhere-it.com
Comment :
Enabled : True
ConnectionTimeout : 00:10:00
ConnectionInactivityTimeout : 00:05:00
MessageRateLimit : 5
MessageRateSource : User
MaxInboundConnection : 5000
MaxInboundConnectionPerSource : 20
MaxInboundConnectionPercentagePerSource : 2
MaxHeaderSize : 64 KB (65,536 bytes)
MaxHopCount : 30
MaxLocalHopCount : 8
MaxLogonFailures : 3
MaxMessageSize : 10 MB (10,485,760 bytes)
MaxProtocolErrors : 5
MaxRecipientsPerMessage : 200
PermissionGroups : ExchangeUsers
PipeliningEnabled : True
ProtocolLoggingLevel : None
RemoteIPRanges : {::-ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff, 0.0.0.0-255.255.255.255}
RequireEHLODomain : False
RequireTLS : False
EnableAuthGSSAPI : True
LiveCredentialEnabled : False
Server : DC01
SizeEnabled : Enabled
TarpitInterval : 00:00:05
MaxAcknowledgementDelay : 00:00:30
AdminDisplayName :
ExchangeVersion : 0.1 (8.0.535.0)
Name : Client DC01
DistinguishedName : CN=Client DC01,CN=SMTP Receive Connectors,CN=Protocols,CN=DC01,CN=Servers,CN=
Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=S
oftwhere-IT,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=softwhere-i
t,DC=com
Identity : DC01\Client DC01
Guid : 35348726-45e1-4071-bf0e-394d43358d79
ObjectCategory : softwhere-it.com/Configuration/Schema/ms-Exch-Smtp-Receive-Connector
ObjectClass : {top, msExchSmtpReceiveConnector}
WhenChanged : 22.02.2010 12:43:18
WhenCreated : 18.02.2010 21:44:53
WhenChangedUTC : 22.02.2010 11:43:18
WhenCreatedUTC : 18.02.2010 20:44:53
OrganizationId :
OriginatingServer : soft01b.softwhere-it.com
IsValid : True


Thanks




yunker -> RE: fqdn helo (23.Feb.2010 12:30:12 PM)

I realized that the fqdn on the default receive connector is the ADName however the set command does not let me change it the following error comes:
--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
The following error(s) occurred while saving changes:

Set-ReceiveConnector
Failed
Error:
If the AuthMechanism attribute on a receive connector contains the value ExchangeServer, you must set the FQDN parameter on the receive connector to one of the following values: the FQDN of the transport server "DC01.softwhere-it.com", the NetBIOS name of the transport server "DC01", or $null.




--------------------------------------------------------
OK
--------------------------------------------------------




yunker -> RE: fqdn helo (23.Feb.2010 1:00:00 PM)

I have finally solved it this way, not sure if any other problem evolves. I deleted the "default" receiverconnector and created 2 new ones one named "internal" with only internal IP addresses and 1 named "extern" for port 25 and set the fqdn to mail.domain.com, with telnet it works shows fqdn as server, however now when the internal clients try to connect they get a complaint about the SSL certificate.

Am I missing something?




Page: [1]