Outlook 2007 requests password, Exchange 2010 (Full Version)

All Forums >> [Microsoft Exchange 2010] >> Installation



Message


clum1 -> Outlook 2007 requests password, Exchange 2010 (15.Mar.2010 10:33:14 AM)

I have setup a new Server 2008 R2 AD with Exchange 2010 and am getting problems with some Outlook 2007 clients requesting passwords when connecting to the Exchange server.
The symptoms are:
  1. The client connects correctly using Autodiscover
  2. Test messages send correctly
  3. Some time after mailbox creation, upon startup, the client will request a  password to connect to the Exchange server.
  4. Inputting a valid password does not work, clicking OK returns the same dialogue box.
  5. The message displayed at bottom right will be either "Need Password" or "online With Microsoft Exchange"
  6. Emails can still be sent and received throughout this
  7. The prompt reappears at random intervals
  8. There are no corresponding events in the logs either on client or server.
  9. I lose the will to live
I've searched extensively online, and the info suggests it's not limited to Exchange 2010 but the suggested fixes have had no effect on my situation. Can anyone help me before I flatten my Exchange box please?
thanks
Calum




jveldh -> RE: Outlook 2007 requests password, Exchange 2010 (15.Mar.2010 5:07:34 PM)

Calum

Does this happen when downloading the address book or connecting to the autodiscover services ?




clum1 -> RE: Outlook 2007 requests password, Exchange 2010 (16.Mar.2010 11:01:37 AM)

It seems to happen at random times but I think it's related to autodiscover. If I CTRL click on the Outlook icon in the sys tray and do a "Test Email Configuration" it looks to https://mydomain.co.uk for info, this being my default policy for email addresses. For users unaffected, it looks to https://Exchangehost.domain.local for this info.

At the moment, this server is not in production so I'm wondering if it's just that the mydomain.co.uk address is unresolvable that's causing it; this doesn't explain to me why some clients randomly swap to this address though!

thanks

Calum




jveldh -> RE: Outlook 2007 requests password, Exchange 2010 (16.Mar.2010 5:03:01 PM)

Hi,

If the users are using a system that's member of the domain it should get the info by quering for the SCP record which points to the autodiscover site.

What's the difference between the users are they running on systems that are a memberof the domain or not ?




clum1 -> RE: Outlook 2007 requests password, Exchange 2010 (17.Mar.2010 4:21:33 AM)

Yes; all are members of the domain. It's now started on another account; I'm close to wiping the server!

thanks

Calum




jveldh -> RE: Outlook 2007 requests password, Exchange 2010 (17.Mar.2010 5:33:36 PM)

Hi,

Please run get-webservicesvirtualdirectory |fl and post the output here.




clum1 -> RE: Outlook 2007 requests password, Exchange 2010 (18.Mar.2010 10:06:37 AM)

Hi Jveldh,
I spoke to MS (finally used one of my free Technet support calls!) and they seem to have isolated the problem for me; we're behind a proxy server here and it looks like Outlook was sticking on it. 
Adding the NETBIOS name, FQDN and IP address of the Exchange server to the Tools / Options / Connections / LAN Settings / Proxy Server / Advanced / Exceptions field on each client seems to be working for now.

Will update if there's any changes.

Thanks for your help.

Calum




Page: [1]