• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

OVA 2010 Directory Name Lookup Delays

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> Unified Messaging >> OVA 2010 Directory Name Lookup Delays Page: [1]
Login
Message << Older Topic   Newer Topic >>
OVA 2010 Directory Name Lookup Delays - 20.Apr.2010 8:52:29 AM   
camgsmith

 

Posts: 1
Joined: 20.Apr.2010
Status: offline
Some basics about the underlying infrastructure:
AD Schema: 2008 R2
Exchange: 2010 with rollup 3

The problem: It took us a while to pinpoint the precise circumstances that cause this problem to manifest itself. To illustrate the course of actions, this all takes place inside the voicemail service:

1) User asks for "Directory" to look up an AD user
2) The service asks for the name of the person being looked for.
3) User speaks the name of the AD user.
4) Some time passes - sometimes 3 seconds, sometimes 10 seconds or longer.
5) The service reads back the AD user's recording of their name

Further testing has revealed that on 2010, the pause described in (4) above is specific to those users who have recorded their name via the greetings options and thus populated the msExchUMSpokenName attribute in AD. If there's no data in this attribute, the voice engine reads the AD Display Name attribute back to the user without any pause whatsoever.

When we were using Exchange 2007 UM up until a few months ago, we never encountered the long pause described in (4) above; it was (near) instant confirmation and onwards with the next user action. Now, it's as if there's a delay in Exchange 2010 UM reconstituting the data string from the AD attribute back into an audio stream for playback in a way its predecessor never had a problem with. We have no performance or specification concerns about the hosts involved either.

It's more of an annoyance than anything; it does work eventually, and if it was considered unworkable we could always wipe the users' recordings and revert to using the system's pronunciation attempts. All the same I'd be interested to know if anyone else has experienced this anomaly, has any idea why it's happening or better still, knows a way to fix it.

_____________________________

Cameron Smith
MCITP: EMA & EA | MCSE:M & S
Post #: 1

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> Unified Messaging >> OVA 2010 Directory Name Lookup Delays Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter