• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Error adding 2nd node to DAG

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> High Availability >> Error adding 2nd node to DAG Page: [1]
Login
Message << Older Topic   Newer Topic >>
Error adding 2nd node to DAG - 11.May2010 3:23:27 PM   
spencerpyne

 

Posts: 1
Joined: 20.Nov.2008
Status: offline
Environment:

Virtual Server 2005:
AD Windows 2003 Forest and Domain level
Exchange 2003 SP2; FE, 2- BE servers on W2k3 sp2; Exchange 2007 server

Hyper-v:
Exchange 2010; CA and Hub, 2-MB servers all on W2k8 Ent. SP2

All servers in the same domain.

++++++++++++++++++
Trying to add the second MB to DAG, getting following error;

add-databaseavailabiltygroupserver started on machine SPLABX10MB2.
[2010-05-11T16:43:07] add-dagserver started
[2010-05-11T16:43:07] commandline: $scriptCmd = {& $wrappedCmd @PSBoundParameters }
[2010-05-11T16:43:07] Option 'Identity' = 'NewDAG1'.
[2010-05-11T16:43:07] Option 'MailboxServer' = 'SPLABX10MB2.SPLAB.NET'.
[2010-05-11T16:43:07] Option 'DatabaseAvailabilityGroupIpAddresses' = ''.
[2010-05-11T16:43:07] Option 'WhatIf' = ''.
[2010-05-11T16:43:07] Process: w3wp w3wp.exe:3812.
[2010-05-11T16:43:07] User context = 'NT AUTHORITY\SYSTEM'.
[2010-05-11T16:43:07] Member of group 'Everyone'.
[2010-05-11T16:43:07] Member of group 'BUILTIN\Users'.
[2010-05-11T16:43:07] Member of group 'NT AUTHORITY\SERVICE'.
[2010-05-11T16:43:07] Member of group 'NT AUTHORITY\Authenticated Users'.
[2010-05-11T16:43:07] Member of group 'NT AUTHORITY\This Organization'.
[2010-05-11T16:43:07] Member of group 'BUILTIN\IIS_IUSRS'.
[2010-05-11T16:43:07] Member of group 'LOCAL'.
[2010-05-11T16:43:07] Member of group 'IIS APPPOOL\MSExchangePowerShellAppPool'.
[2010-05-11T16:43:07] Member of group 'BUILTIN\Administrators'.
[2010-05-11T16:43:07] Updated Progress 'Validating the parameters.' 2%.
[2010-05-11T16:43:07] Working
[2010-05-11T16:43:07] Mailbox server: value passed in = SPLABX10MB2.SPLAB.NET, mailboxServer.Name = SPLABX10MB2, mailboxServer.Fqdn = SPLABX10MB2.splab.net
[2010-05-11T16:43:07] LogClussvcState: clussvc is Stopped on SPLABX10MB2.splab.net. Exception (if any) = none
[2010-05-11T16:43:07] The IP addresses for the DAG are (blank means DHCP):
[2010-05-11T16:43:07] Looking up IP addresses for NewDAG1.
[2010-05-11T16:43:07] NewDAG1 = [ 205.134.37.1 ].
[2010-05-11T16:43:07] Looking up IP addresses for splabx10mb2.
[2010-05-11T16:43:07] splabx10mb2 = [ fe80::29df:5786:1c11:611b%15, fe80::ac34:76c6:14e1:21bc%19, 2002:cd86:2540::cd86:2540, 205.134.37.64, 10.0.0.2 ].
[2010-05-11T16:43:07] Looking up IP addresses for SPLABX10MB2.splab.net.
[2010-05-11T16:43:07] SPLABX10MB2.splab.net = [ fe80::29df:5786:1c11:611b%15, fe80::ac34:76c6:14e1:21bc%19, 2002:cd86:2540::cd86:2540, 205.134.37.64, 10.0.0.2 ].
[2010-05-11T16:43:07] DAG NewDAG1 has 1 servers:
[2010-05-11T16:43:07] DAG NewDAG1 contains server SPLABX10MB1.
[2010-05-11T16:43:07] Updated Progress 'Checking if Mailbox server 'SPLABX10MB2' is in a database availability group.' 4%.
[2010-05-11T16:43:07] Working
[2010-05-11T16:43:07] GetRemoteCluster() for the mailbox server failed with exception = An Active Manager operation failed. Error: An error occurred while attempting a cluster operation. Error: Cluster API '"OpenCluster(SPLABX10MB2.splab.net) failed with 0x6d9. Error: There are no more endpoints available from the endpoint mapper"' failed.. This is OK.
[2010-05-11T16:43:07] Ignoring previous error, as it is acceptable if the cluster does not exist yet.
[2010-05-11T16:43:07] DumpClusterTopology: Opening remote cluster NewDAG1.
[2010-05-11T16:43:07] Dumping the cluster by connecting to: NewDAG1.
[2010-05-11T16:43:07] The cluster's name is: NewDAG1.
[2010-05-11T16:43:07] Groups
[2010-05-11T16:43:07] group: Available Storage [not a CMS]
[2010-05-11T16:43:07] OwnerNode: SPLABX10MB1.splab.net
[2010-05-11T16:43:07] State: Offline
[2010-05-11T16:43:07] group: Cluster Group [Cluster Main Group]
[2010-05-11T16:43:07] OwnerNode: SPLABX10MB1.splab.net
[2010-05-11T16:43:07] State: Online
[2010-05-11T16:43:07] Resource: Cluster Name [Online, type = Network Name, PossibleOwners = SPLABX10MB1 ]
[2010-05-11T16:43:07] NetName = [NEWDAG1]
[2010-05-11T16:43:07] RequireKerberos = 1. Computer account created on DC ''.
[2010-05-11T16:43:07] Resource: Cluster IP Address [Online, type = IP Address, PossibleOwners = SPLABX10MB1 ]
[2010-05-11T16:43:07] Address = [205.134.37.1]
[2010-05-11T16:43:07] EnableDhcp = [1]
[2010-05-11T16:43:07] Network = [Cluster Network 1]
[2010-05-11T16:43:07] Nodes
[2010-05-11T16:43:07] node: SPLABX10MB1.splab.net [ state = Up ]
[2010-05-11T16:43:07] Subnets
[2010-05-11T16:43:07] Name(Cluster Network 1), Mask(205.134.37.0/24), Role(ClusterNetworkRoleInternalAndClient)
[2010-05-11T16:43:07] NIC 205.134.37.63 on Node SPLABX10MB1 in State=Up
[2010-05-11T16:43:07] Name(Cluster Network 2), Mask(10.0.0.0/8), Role(ClusterNetworkRoleInternalUse)
[2010-05-11T16:43:07] NIC 10.0.0.1 on Node SPLABX10MB1 in State=Up
[2010-05-11T16:43:07] Opening the cluster on nodes [splabx10mb1].
[2010-05-11T16:43:07] Other mailbox servers in the DAG are already members of cluster 'NewDAG1'
[2010-05-11T16:43:07] The server SPLABX10MB2 does not belong to a cluster, and the other servers belong to NewDAG1.
[2010-05-11T16:43:07] Successfully resolved servers based on the AD configuration.
[2010-05-11T16:43:07] The following servers are in the StartedServers list:
[2010-05-11T16:43:07] The following servers are in the StoppedServers list:
[2010-05-11T16:43:07] Verifiying that the members of database availability group 'NewDAG1' are also members of the cluster.
[2010-05-11T16:43:07] Verifying that the members of cluster 'NewDAG1' are also members of the database availability group.
[2010-05-11T16:43:07] According to GetNodeClusterState(), the server SPLABX10MB2 is NotConfigured.
[2010-05-11T16:43:07] The CNO is currently Online.
[2010-05-11T16:43:07] InternalValidate() done.
[2010-05-11T16:43:07] Updated Progress 'Adding server 'SPLABX10MB2' to database availability group 'NewDAG1'.' 6%.
[2010-05-11T16:43:07] Working
[2010-05-11T16:43:07] Updated Progress 'Adding server 'SPLABX10MB2' to the cluster.' 8%.
[2010-05-11T16:43:07] Working
[2010-05-11T16:53:07] The operation wasn't successful because an error was encountered. You may find more details in log file "C:\ExchangeSetupLogs\DagTasks\dagtask_2010-05-11_16-43-07.112_add-databaseavailabiltygroupserver.log".
[2010-05-11T16:53:07] WriteError! Exception = Microsoft.Exchange.Cluster.Replay.DagTaskOperationFailedException: A server-side database availability group administrative operation failed. Error: The operation failed with message: Error 0x71a (The remote procedure call was cancelled) from cli_RpccAddNodeToCluster ---> Microsoft.Exchange.Rpc.RpcException: Error 0x71a (The remote procedure call was cancelled) from cli_RpccAddNodeToCluster
at ThrowRpcException(Int32 rpcStatus, String message)
at Microsoft.Exchange.Rpc.RpcClientBase.ThrowRpcException(Int32 rpcStatus, String routineName)
at Microsoft.Exchange.Rpc.Cluster.ReplayRpcClient.RpccAddNodeToCluster(String newNode, String& verboseLog)
at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.<>c__DisplayClass26.<RunAddNodeToCluster>b__24()
at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.<>c__DisplayClass32.<RunRpcOperationDbName>b__30()
at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.ClientRetryableOperation(String serverName, RpcClientOperation rpcOperation)
--- End of inner exception stack trace ---
at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.ClientHandleRpcException(RpcException ex, String serverName)
at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.ClientRetryableOperation(String serverName, RpcClientOperation rpcOperation)
at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.RunRpcOperationDbName(String serverName, String databaseName, Int32 timeoutMs, ReplayRpcClient& rpcClient, IHaRpcExceptionWrapper rpcExceptionWrapperInstance, InternalRpcOperation rpcOperation)
at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.RunRpcOperation(String serverName, Nullable`1 dbGuid, Int32 timeoutMs, ReplayRpcClient& rpcClient, IHaRpcExceptionWrapper rpcExceptionWrapperInstance, InternalRpcOperation rpcOperation)
at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.RunAddNodeToCluster(AmServerName serverName, AmServerName newNode, String& verboseLog)
at Microsoft.Exchange.Management.SystemConfigurationTasks.AddDatabaseAvailabilityGroupServer.JoinNodeToCluster()
[2010-05-11T16:53:07] Updated Progress 'Done!' 100%.
[2010-05-11T16:53:07] COMPLETED
add-databaseavailabiltygroupserver explicitly called CloseTempLogFile().

Any suggestions will be greatly appreciated.
Post #: 1
RE: Error adding 2nd node to DAG - 19.May2010 3:51:23 AM   
mkalugotla

 

Posts: 1
Joined: 19.May2010
Status: offline
Hi,
Iam also facing the same problem. Any help is very much appreciated.
 
thanks

(in reply to spencerpyne)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> High Availability >> Error adding 2nd node to DAG Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter