• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Problem Synchronizing Mobile Devices after installing an extension on CAS (IIS)

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> Mobility >> Problem Synchronizing Mobile Devices after installing an extension on CAS (IIS) Page: [1]
Login
Message << Older Topic   Newer Topic >>
Problem Synchronizing Mobile Devices after installing a... - 26.May2010 11:24:39 PM   
VipulPathak

 

Posts: 4
Joined: 26.May2010
Status: offline
Hi Everyone,

I am writing an ISAPI Extension that will be installed on the /Microsoft-Server-ActiveSync virtual directory as a wildcard script map.

What I am trying to do:
The purpose of this Extension is to record, who all users has sync'ed their exchange account using device and whats the last connect time. I am using the System time to record the time of connection and the QueryString parameter to obtain the UserId, which is what you get in the HttpExtensionProc() function of the ISAPI Extension. In a way this is similar to the Intercepting All Incoming Requests example on MSDN for ISAPI. I am not touching to any other thing and passing the control to the actual handler AirSync.dll.

Problem:
When I add my wildcard handler, It works fine and record the UserId and Current system time, but then The devices stop sync'ing with CAS. On the device, when I click on the Sync button in ActiveSync application, it fails and show me the Support code: 0x85010017.

Help:
Any idea of whats happening inside, I passed the request very gracefully withour touching any header or data to the next handler (AirSync). The user id was picked from the QueryString which was made available in the EXTENSION_CONTROL_BLOCK structure in side the HttpExtensionProc function of ISAPI Extension. Finally, the control was passed using the ServerSupportFunction HSE_REQ_EXEC_URL.

Any Idea ?


Thanks,

Any help of this is really appreciated. I am dealing with from past 3 days now ...

_____________________________

Vipul Pathak
----------------------
India.
Post #: 1
RE: Problem Synchronizing Mobile Devices after installi... - 2.Sep.2010 5:10:16 AM   
rishishah

 

Posts: 784
Joined: 14.Nov.2006
From: Surrey, UK
Status: offline
Hi,

I believe it keeping things very simple...but is there no reason why you cannot just switch on logging in IIS and simply query the IIS logs for that information.



_____________________________

Rishi Shah, MCP

Remember to backup before applying the advice. www.saiconsult.co.uk. Happy to provide Professional Exchange Server Consultancy to anywhere in the world.

(in reply to VipulPathak)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> Mobility >> Problem Synchronizing Mobile Devices after installing an extension on CAS (IIS) Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter