Legacy mailbox move (Full Version)

All Forums >> [Microsoft Exchange 2010] >> General



Message


swstew -> Legacy mailbox move (24.Jun.2010 3:10:28 PM)

Can anyone tell me how to move a legacy mailbox into exchange.

When I try to do a move I get this error:

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:00

Sarah E
Failed
Error:
Value cannot be null.
Parameter name: objectId
Warning:
An unexpected error has occurred and a Watson dump is being generated: Value cannot be null.
Parameter name: objectId

Exchange Management Shell command attempted:
'domain.com/Users/Sarah E' | New-MoveRequest -TargetDatabase 'Mailbox Database 2099318038' -BadItemLimit '100'
Elapsed Time: 00:00:00

This user have not had an exchange mailbox at this location.  This is a new exchange install.

anyone?




de.blackman -> RE: Legacy mailbox move (24.Jun.2010 3:16:51 PM)

I do not understand!

If this is a new mailbox, where are you trying to move it from and to? How many exchange servers are there? What roles are running on them? What version is the "legacy" server running?

More details will help in getting more responses and a faster solution to your issue! Please provide as much detail as possible!!




swstew -> RE: Legacy mailbox move (24.Jun.2010 3:29:57 PM)

There has not been an exchange server at this location.  There is no legacy server.

I found the user in question while clicking on recipient configuration listing the entire forest.  The user in question shows a legacy mailbox.  I tried doing a new local move request and that is where the error came from.

This organization was popping to godaddy for their email.  we are moving them off pop to exchange.  Outlook send and receive work fine.

Any other questions please let me now.

Thanks




de.blackman -> RE: Legacy mailbox move (24.Jun.2010 3:40:12 PM)

Ok now things are a little bit more clear! using the Move Local Request will allow you to move a mailbox from one database to another on the same server or to another server!

What you have to do is change the properties of the mailbox so it shows as a user mailbox. Run the following command to do so:

set-mailbox -identity ProblematicMailboxName -PpplyMandatoryProperties




swstew -> RE: Legacy mailbox move (24.Jun.2010 3:52:37 PM)

That command game me errors.  I tells me that a positional parameter cannot be found for -PpplyMandatoryProperties, I also tried -Papp....




de.blackman -> RE: Legacy mailbox move (25.Jun.2010 8:06:27 AM)

My mistake!! A little type there

set-mailbox -identity ProblematicMailboxName -ApplyMandatoryProperties




swstew -> RE: Legacy mailbox move (25.Jun.2010 9:32:53 AM)

I understand, I get fat fingers also.

I ran the command and I get the message:

Can"t apply mandatory properties....it is hosted on a legacy exchange server

There is no legacy server.




de.blackman -> RE: Legacy mailbox move (25.Jun.2010 10:08:55 AM)

That is not making any sense! If this is the ONLY exchange server in the entire organization, then how can it say that it is hosted on a legacy server. Did you run the install of the exchange server? In the Exchange management Shell, run the following command:

Get-Mailbox -Identity NameOfMailboxWithProblem | FL

Confirm that the server name is correct (if possible please post the information here!)




swstew -> RE: Legacy mailbox move (25.Jun.2010 10:37:43 AM)

Lagacy is refering to an ad server which has been decommissioned, it did have a trial copy of exchange 2003 installed on it but was never used as far as I know of, it was before my time.  This user was popping to godaddy.




de.blackman -> RE: Legacy mailbox move (25.Jun.2010 10:42:22 AM)

This was what I expected!! It seems it was never decommissioned properly! It may have been turned off and removed from the network but references to it still reside in active directory! I assume this mailbox was never logged into since the server was removed? Problem is that you cannot move this mailbox since the source no longer exists. Can you confirm when the last time someone used this mailbox was? Have you tried disabling the mailbox from the exchaneg management console?




swstew -> RE: Legacy mailbox move (25.Jun.2010 2:53:03 PM)

If I disable this mailbox, will it remove the user from AD?




de.blackman -> RE: Legacy mailbox move (25.Jun.2010 3:01:33 PM)

No! Disabling a mailbox will remove any connections it may have to a user account and it then removes any exchange information from the user account. REMOVE, however, will delete the mailbox AND the user account!! Be careful which one to use!




swstew -> RE: Legacy mailbox move (25.Jun.2010 3:17:58 PM)

Thankyou Sir -- We have a winner!!!!!




de.blackman -> RE: Legacy mailbox move (25.Jun.2010 3:30:45 PM)

[:D]Another one bites the dust![:D]

Glad to hear that!! Good luck with your new server.




swstew -> RE: Legacy mailbox move (25.Jun.2010 3:33:04 PM)

All I need to do is get phones syncing to this server.  I have autodiscover working but not the phones.




de.blackman -> RE: Legacy mailbox move (25.Jun.2010 3:46:33 PM)

Open a new thread under Mobility section just so as to not mix up the different issues!




swstew -> RE: Legacy mailbox move (25.Jun.2010 3:50:21 PM)

Will do.  Thanks for all of your help.




mhouk -> RE: Legacy mailbox move (17.Jul.2013 2:29:22 PM)

HELO [:D] - I have a similar issue. We have Exchange 2003 & 2010 still running. I have a user that was moved from an exchange 2003 to a 2010 server, when opening Exchange Management Console I find this user listed as recipient type details "Legacy Mailbox" after looking at the settings I see the user is still in the Exchange 2003 database and I donít see the mailbox move feature anymore. This user must have been moved but the wrong database was selected? Any idea how to move this user to the exchange 2010 database after this?




de.blackman -> RE: Legacy mailbox move (18.Jul.2013 11:40:11 AM)

Try moving the mailbox using the exchange powershell. Tyr using the following command:

New-MoveRequest -Identity 'user@domain.com' -TargetDatabase DB01




Page: [1]