• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

OWA doesn't sign out correctly.

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> Outlook Web Access >> OWA doesn't sign out correctly. Page: [1]
Login
Message << Older Topic   Newer Topic >>
OWA doesn't sign out correctly. - 30.Aug.2010 6:05:28 AM   
clum1

 

Posts: 61
Joined: 25.Jul.2002
From: UK
Status: offline
I want to use OWA to log in as a couple of users for testing on my machine but can't seem to sign out correctly. When I click the Sign Out button (FireFox or IE), I get sent to a window telling me "You have successfully signed out of Outlook Web App..." but from there I can click Back etc to get back to my session; I also can't get a Login screen as it automatically returns me to my previous session, even after restarting the browser.
How do I get this to behave; it's a security risk to be honest - not so much in the office but if any of my users are logging in remotely from insecure machines...
Post #: 1
RE: OWA doesn't sign out correctly. - 30.Aug.2010 9:07:48 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Is this happening on all computers or just certain machines in the network?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to clum1)
Post #: 2
RE: OWA doesn't sign out correctly. - 30.Aug.2010 10:21:51 AM   
clum1

 

Posts: 61
Joined: 25.Jul.2002
From: UK
Status: offline
Looks like FireFox is behaving slightly better; if I log out and close the browser window it requires credentials on restarting it, however, if I don't restart it does not. E.g. click Sign Out, hit F5 at "Logged Off" screen then click Back and F5, I can reaccess my email. I know it warns you to close the window, but how many users in the field can be trusted to do this..?
For IE, the issue is worse; for the user's first login it requires credentials, but not subsequently - browser restart or not. I'd be happier if on sign-out the user was prompted with a sign-in screen but that's not the case. At the moment I'm testing with domain access so perhaps IE is cacheing to the user account? This isn't much use for me as I wish to use OWA to log on as various different users but am unable to do so with IE.
Confused? I am..!

(in reply to de.blackman)
Post #: 3
RE: OWA doesn't sign out correctly. - 30.Aug.2010 10:26:41 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
It is confusing but again, is this an issue on multiple computers or just the one you have been testing with?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to clum1)
Post #: 4
RE: OWA doesn't sign out correctly. - 30.Aug.2010 11:10:54 AM   
clum1

 

Posts: 61
Joined: 25.Jul.2002
From: UK
Status: offline
Yes, multiple computers on the network.

(in reply to de.blackman)
Post #: 5
RE: OWA doesn't sign out correctly. - 30.Aug.2010 11:21:24 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
SO this tells us the issue is from the client access server. How many CAS servers do you have?

Log into each server and open the IIS manager console. Check the authentication of OWA, Exchange, EXCHWEB and all exchange-related virtual directories under the default website and post them back here. I am interested to see if any of them may have integrated authentication enabled.

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to clum1)
Post #: 6
RE: OWA doesn't sign out correctly. - 30.Aug.2010 11:51:34 AM   
clum1

 

Posts: 61
Joined: 25.Jul.2002
From: UK
Status: offline
  1. Exchange: Anonymous Authentication enabled, all others disabled
  2. Exchweb: Basic and Windows Authentication Enabled, all others disabled
  3. MS-Server-ActiveSync: Basic Authentication Enabled, all others disabled
  4. OAB: Basic and Windows Authentication Enabled, all others disabled
  5. OWA: Windows Authentication Enabled, all others disabled
  6. Default Web Site: Anonymous and Windows Authentication Enabled, all others disabled
This is the only Exchange server in my organisation; it handles all tasks.

Thanks for your help; I hope this is of some use.

clum1

(in reply to de.blackman)
Post #: 7
RE: OWA doesn't sign out correctly. - 30.Aug.2010 12:14:37 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Actually yes this proves to be very useful. I assume you are NOT using form-based authentication?
Because the OWA directory is configured to use Windows (integrated) authentication, the account you have logged into your machine is always passed through for authentication! If order to change this, I recommend for you to use forms-based authentication whereby you will be presented with the OWA logon page for authentication. To do this, follow the details at http://technet.microsoft.com/en-us/library/aa998867.aspx

< Message edited by de.blackman -- 30.Aug.2010 12:24:19 PM >


_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to clum1)
Post #: 8
RE: OWA doesn't sign out correctly. - 31.Aug.2010 3:58:08 AM   
clum1

 

Posts: 61
Joined: 25.Jul.2002
From: UK
Status: offline
That all made sense and the fix has worked perfectly; many thanks for your help.  IIRC, I had some problems when I set it up and ended up settling on what worked, rather than what was best - it's always worth getting these things sorted out properly though!

Thanks again,

clum1

(in reply to de.blackman)
Post #: 9
RE: OWA doesn't sign out correctly. - 31.Aug.2010 10:26:16 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Another one bites the dust!

Glad to have helped!



_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to clum1)
Post #: 10

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> Outlook Web Access >> OWA doesn't sign out correctly. Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter