• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

setting SendAs permissions from shell not working ?

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Management >> setting SendAs permissions from shell not working ? Page: [1]
Login
Message << Older Topic   Newer Topic >>
setting SendAs permissions from shell not working ? - 14.Sep.2010 8:25:27 AM   
lbm_

 

Posts: 63
Joined: 2.Apr.2009
Status: offline
I am trying to add some send as permissions through powershell, w. added 2007 mngtmnt shell. But it does not seem to work at all.(or maybe it is working, but the GUI is not showing it) ???!

I use the following command.
add-mailboxpermission -Identity "User1" -accessrights sendas -user "User2"

If I then go to view the Send As permissions in the GUI on User1's mailbox, I cannot see that User2 have access to send as ? How can this be?

If I try to use the same command again, it get an message that the object already have this permissions set? (HUH?)..

The following works fine and I can see this in the GUI.
add-mailboxpermission -Identity "User1" -accessrights fullaccess -user "User2"
Post #: 1
RE: setting SendAs permissions from shell not working ? - 14.Sep.2010 8:57:06 AM   
raghuram

 

Posts: 281
Joined: 10.Jun.2009
From: Chennai, India
Status: offline
Hi

Your command is verym much correct. This must work. if not

please try this command as the sendas is a AD attribute

Add-ADPermission -Identity "user1" -User "user2 -ExtendedRights Send-As

Please check in PS and update.

(in reply to lbm_)
Post #: 2
RE: setting SendAs permissions from shell not working ? - 14.Sep.2010 9:05:09 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
In order to assign the send-as permission from the EMS, you need to use the Add-ADPermission command, not the Add-MailboxPermission cmdlet.

Add-ADPermission "John Simpson" -User "Domain\User" -Extendedrights "Send As"

Manage Send As Permissions for a Mailboxhttp://technet.microsoft.com/en-us/library/bb676368.aspx#UseShell

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to raghuram)
Post #: 3
RE: setting SendAs permissions from shell not working ? - 14.Sep.2010 9:15:29 AM   
lbm_

 

Posts: 63
Joined: 2.Apr.2009
Status: offline
I see, is it possible to add FullAccess and sendas in one command, or does it have to be split up in two?

(in reply to de.blackman)
Post #: 4
RE: setting SendAs permissions from shell not working ? - 14.Sep.2010 10:21:37 AM   
raghuram

 

Posts: 281
Joined: 10.Jun.2009
From: Chennai, India
Status: offline
I think...Yes , you can do by using pipeline in between the commands.

i have not yet tried.

please check and upadte.

(in reply to lbm_)
Post #: 5
RE: setting SendAs permissions from shell not working ? - 23.Sep.2010 4:10:40 AM   
mohamed.abdulfattah

 

Posts: 2
Joined: 23.Sep.2010
From: Egypt
Status: offline
very much correct answer

quote:

ORIGINAL: de.blackman

In order to assign the send-as permission from the EMS, you need to use the Add-ADPermission command, not the Add-MailboxPermission cmdlet.

Add-ADPermission "John Simpson" -User "Domain\User" -Extendedrights "Send As"

Manage Send As Permissions for a Mailboxhttp://technet.microsoft.com/en-us/library/bb676368.aspx#UseShell

(in reply to de.blackman)
Post #: 6

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Management >> setting SendAs permissions from shell not working ? Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter