• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

OWA replaceCurrent blocks public access

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Installation >> OWA replaceCurrent blocks public access Page: [1]
Login
Message << Older Topic   Newer Topic >>
OWA replaceCurrent blocks public access - 17.Sep.2010 8:09:14 AM   
kadoun

 

Posts: 1
Joined: 17.Sep.2010
Status: offline
Hi all,

I configured our domain with recomended company.local name a long time ago.
4 years ago I installed Exchange 2003 and last year I replaced it with Exchange 2007.
We are still using .local domain name inside the local network. Last year we used certificate from pucblic CA to secure Outlook Web Access and  Outlook Anywhere.
We used VPN client software to access internal network and everything worked fine but only with VPN connection established.
Now when we renewed the certificate wih alternative subject names we are trying to configure OWA to run without VPN client software.
The new certificate includes mailserver's internal and external names.
We also have public DNS record for our mailserver. It is also possible to access IIS default page running on the mailserver using https://mail.company.com without /owa.
BUT
when acessing OWA using it's external url

https://mail.company.com/owa

the address is changed to internal url.

https://mail.company.local/owa/auth/logon.aspx?replaceCurrent=1&url=https%3a%2f%2fmail.company.local%2fowa%2f

OWA is still working when using VPN client software but it is not working on public internet because the company.local is not accessible from internet.
I'm tried to setup external url using set-owavirtualdirectory, I removed and recreated owavirtualdirectory with correct external url parameters but nothing changed.

I will be very thankful for any idea how to solve the replaceCurrent issue.

Tomas Kadoun
Post #: 1

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Installation >> OWA replaceCurrent blocks public access Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter