OWA Problem after Updating to SP1 (Full Version)

All Forums >> [Microsoft Exchange 2010] >> Outlook Web Access



Message


mblaser -> OWA Problem after Updating to SP1 (18.Sep.2010 9:42:19 AM)

Hello Forum

I just updated our Exchange 2010 to SP1 and everthing seems to work.

But the new features with the insert picture don't work. I get evertime the error:
The action you tried to perform couldn't be completed because there's a configuration problem on the server. If the problem continues, contact your helpdesk.

In the event logs there is the error (in german):
Outlook Web App konnte aufgrund eines Konfigurationsfehlers keine Verbindung zu den Exchange-Webdiensten herstellen. Antwortcode = 'null, webException.Status = ConnectFailure'.

Has anybody seen this error and have a hint how to fix it?

thx




alexjakovlev -> RE: OWA Problem after Updating to SP1 (22.Sep.2010 2:21:41 AM)

Hello Mblaser,
I have the same problems after Exchange SP1 installation:

Outlook Web App couldn't connect Exchange Web Services due to a configuration error. Response code = "null, webException.Status = ConnectFailure".

This only happens if anybody tries to delete or move any email item to other folder only from OWA.

Unfortunately I did not solve this problem yet, and looking forward for help.




rdol -> RE: OWA Problem after Updating to SP1 (22.Sep.2010 9:26:45 AM)

I have the same problem on one of my ex2010 installations. But not on others. Did you disable any IPv6 component on your server? I am just trying to identify differences between installations.




travis.sheldon -> RE: OWA Problem after Updating to SP1 (22.Sep.2010 11:17:53 AM)

Rdol,

Is the "Insert Picture" feature selected when you try to compose a new message through OWA (Just making sure you're not talking about GAL photos..)

If so, it works on my NLB CAS array which has IPv6 disabled.

It sounds like it could be IPv6, but I would also check your Internal and External URLs for the web services virtual directory

Get-WebServicesVirtualDirectory | fl identity,*rl




rdol -> RE: OWA Problem after Updating to SP1 (23.Sep.2010 2:51:28 AM)

I confirm both symptoms - cannot delete e-mail, cannot insert picture. I tried to turn IPv6 on, problems persist.

Travis, your hint was very good. One year ago, during installation I had used distinct external/internal URLs because I had used my own CA. However I migrated to StartSSL CA which does not allow private FQDNs in its certificates. So I changed (I thought) every internal URL to the same form as external and created "fake" external DNS zone for the internal usage.

Based on your PowerShell command I found that "Get-ClientAccessServer -AutodiscoverServiceInternalUri" and mainly "Get-WebServicesVirtualDirectory -InternalURL" contained old URLs. It was not problem a few weeks ago, probably because there was still the first SAN certificate with internal name - but it has just expired. Unfortunately I installed SP1 at the same time so I cannot confirm if these problems started after "unused" certificate expired or after SP1 installation :(

So I tried to find and replace every exchange-related InternalUrl/Uri with PowerShell (some of them cannot be found in GUI Console), tried to renew certificate from private CA, no success, problems persist. There must be something else.




rdol -> RE: OWA Problem after Updating to SP1 (23.Sep.2010 3:01:27 AM)

I have just tried to log in to Outlook Web App Light, no problem to delete an e-mail from this light version. The problem must be in something used only in full OWA. I am convinced it was caused by SP1.

Radek




wosscr -> RE: OWA Problem after Updating to SP1 (23.Sep.2010 9:19:40 AM)

Hello,

I have the exact same problem, I'm able to delete messages from the light version but not from the non-light version, have you found something else?




rdol -> RE: OWA Problem after Updating to SP1 (23.Sep.2010 9:40:02 AM)

Well, I have some partial progress. What type of SSL certificate do you use? From which CA? Does your SAN certificate include both external and internal FQDN names (my not because StartSSL does not allow it)? I think SP1 changed something in full OWA which requests EWS services via internal FQDN (or Netbios, not sure yet) name.

Can you test your EWS functionality with Test-WebServicesConnectivity cmdlet? I have got this Failure Result:

[System.Net.WebException]: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. Inner error [System.Security.Authentication.AuthenticationException]: The remote certificate is invalid according to the validation procedure.

Don't forget to run .\new-TestCasConnectivityUser.ps1 from your \Exchange Server\V14\Scripts\ installation.




rdol -> RE: OWA Problem after Updating to SP1 (23.Sep.2010 10:02:58 AM)

http://fabioscagliola.spaces.live.com/blog/cns!919F8FCDE3DC9AC4!154.entry?sa=415571128

"One way to secure XML web services is using SSL. If you install a certificate that has not been issued by a trusted certification authority on the web site hosting the web service and you consume the web service from a .NET application, then you would probably get an AuthenticationException warning you that "the remote certificate is invalid according to the validation procedure". This happens because the default certificate policy only allows valid certificates and valid certificates that have expired."




darth_max -> RE: OWA Problem after Updating to SP1 (23.Sep.2010 1:11:04 PM)

I also got the very same problem:

Right after upgrading any of two exchange 2010 to sp1 (on windows server 2008 r2, latest patches) the owa dont let you delete any items. Only coming this weird "configuration problem" message and in the event log there is an event id 108, source MSExchange OWA...

Has anybody meantime any idea? It is re produceable, when you install in this environment a clean exchange 2010, latest patches, everythink work fine. THen you upgrade to SP1 and the error is here...




rdol -> RE: OWA Problem after Updating to SP1 (23.Sep.2010 4:03:46 PM)

I give it up. I created new SAN certificate with all FQDN and Netbios names, issued on my internal CA, installed on Exchange server. After that all Powershell cmdlets Test-*Connectivity were successfully processed.
So it's not IPv6 problem, it is not SSL problem, problems persist. It must be something in OWA code and it can vary installation by installation (I have one installation without any problem). I have this error in my w3svc log file:
2010-09-23 18:57:12 192.168.169.10 POST /owa/ev.owa oeh=1&ns=EwsProxy&ev=Proxy&rqApplyConversationAction 443 tester@test.cz 192.168.333.10 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+WOW64;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+.NET4.0C;+.NET4.0E) 584 0 0 3171




wosscr -> RE: OWA Problem after Updating to SP1 (24.Sep.2010 10:33:20 AM)

This is what I got when running the Test-WebServicesConnectivity cmdlet:

RunspaceId                  : 2ca1f565-ec62-4077-ba55-ac191f8650f7
LocalSite                   : Default-First-Site-Name
SecureAccess                : True
VirtualDirectoryName        :
Url                         :
UrlType                     : Unknown
Port                        : 0
ConnectionType              : Plaintext
ClientAccessServerShortName : exchangesrv
LocalSiteShortName          : Default-First-Site-Name
ClientAccessServer          : hostname.domainname.xxx
Scenario                    : GetFolder
ScenarioDescription         : Issue an Exchange Web Services GetFolder call to retrieve a folder.
PerformanceCounterName      : CreateItem Latency
Result                      : Failure
Error                       : [System.Net.WebException]: The underlying connection was closed: An unexpected error occu
                             rred on a send. Inner error [System.IO.IOException]: Unable to read data from the transpo
                             rt connection: An existing connection was forcibly closed by the remote host.
UserName                    : extest_7bc0480d98884
StartTime                   : 9/24/2010 10:31:22 AM
Latency                     : -00:00:01
EventType                   : Error
LatencyInMillisecondsString :
Identity                    :
IsValid                     : True




z28power -> RE: OWA Problem after Updating to SP1 (7.Oct.2010 12:44:25 PM)

After trying a LOT of steps including rebuilding all virtual directories, reobtaining/reinstalling SSL certificates, and a myriad of setting changes to exchange and IIS, I ran into a post on technet

http://social.technet.microsoft.com/Forums/en-GB/exchange2010hosters/thread/e45d7277-b205-4791-a430-631b163a5072

which led me to another...

Bottom line was, deleting/renaming the web.config file from "...\inetpub\wwwroot\web.config" fixed the issue. I renamed this file to web.configBAD and ran iisreset. OWA lets me delete, move, etc without any issues now.




Demonseed -> RE: OWA Problem after Updating to SP1 (5.Nov.2010 2:02:21 PM)

As a followup to this.

I tried the following step and it didn't fix my problem. It wasn't until I noticed in IIS under the \exchange folder that the "Redirect requests to this destination" was checked. After unchecking the box, OWA starting working again without the error.

Thanks




jtechs -> RE: OWA Problem after Updating to SP1 (8.Nov.2010 5:49:45 PM)

Hey everyone,

I had the same problem, It ended up being related to setting the default site to an IP (10.1.0.108) and not (all unassigned). I set the default SSL to ALL Unassigned.

Worked perectly.

I use a apache reverse proxy, but I dont think it matters. Strange one..




dsain -> RE: OWA Problem after Updating to SP1 (11.Oct.2011 7:12:50 PM)

quote:

ORIGINAL: jtechs

...had the same problem, It ended up being related to setting the default site to an IP (10.1.0.108) and not (all unassigned). I set the default SSL to ALL Unassigned.

Worked perectly.


SBS 2011 same issue, solution worked great. HTTPS was bound to local IP only. Changed site bindings for HTTPS to * and loopback ip to resolve.

David




gurinder1987 -> RE: OWA Problem after Updating to SP1 (14.Nov.2011 4:03:35 AM)

Sorry, I never see this problem. You can search on Google for this help.




Page: [1]