Exchange 2010 HTTP Redirection Issue (Full Version)

All Forums >> [Microsoft Exchange 2010] >> Outlook Web Access


bloodfire1004 -> Exchange 2010 HTTP Redirection Issue (29.Sep.2010 1:28:03 AM)


I have Exchange 2010 CAS and mailbox servers installed. I have configured HTTP redirection on the Default Web Site to However, the issue is that if is used, instead of the supposed redirection, an Internal Server Error (500) appears. When accessing the directly, the link works. Nothing appears in the event or IIS logs.

The solutions posted here: have already been tried with no luck.

Can you help? Thanks!

de.blackman -> RE: Exchange 2010 HTTP Redirection Issue (29.Sep.2010 9:54:12 AM)

This is assuming you have reverted all changes made from any previous attempts:

1. To simplify the OWA URL, a redirection has been configured in the form of an HTML file containing the following data:

<TITLE>Exchange OWA Redirection</TITLE>

This has been saved as an HTML file (named OWARedirector.html) on the CAS server under the c:\inetpub\wwwroot directory.

2. The next step is to configure IIS to use this file as a redirector from the default web site. Open Internet Information Services (IIS) Manager from the Administrative tools on the CAS server. Expand the server name\
Sites\Default Web Site

3. Click the Default Web Site name and from the results pane, scroll down to Default Document.

4. On the Default Document screen, click the Add button from the Actions menu. You will be presented with the Add Default Document dialog box. Enter the name of the newly created HTML file (OWARedirector.html) then click OK. The file must be placed in the c:\inetpub\wwwroot folder

5. Use the Move Up and Move Down arrows from the Actions menu to arrange the documents so that the added document is at the top of the default documentfs list.

6. By default, the Default Web Site has been configured to accept only SSL connections however in order to allow a redirection from HTTP to HTTPS, SSL must not be required. Click on the Default Web Site. In the results pane, find and double click the SSL Settings

7. On the SSL Settings pane, remove the checkbox labelled Require SSL and click Apply

8. After making these changes, restart IIS services by running IISRESET from a command prompt. Make sure these changes are identically applied to all CAS servers, if applicable.

Page: [1]