• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

DAG Backup using WSB not truncating logs

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> High Availability >> DAG Backup using WSB not truncating logs Page: [1]
Login
Message << Older Topic   Newer Topic >>
DAG Backup using WSB not truncating logs - 20.Dec.2010 5:32:26 AM   
pjrouse2010

 

Posts: 11
Joined: 2.Dec.2010
Status: offline
Scenario

2 x HT and CA Servers in a client access array
2 x EXC 2010 Mailbox Servers with a single Mailbox Database in DAG (active/passive with no lagged copy)

Both running Server 2008 R2

EDB on D:\
Log Files on E:\

On the primary mailbox server Windows Server Backup tools are installed but the person who installed them originally also installed the command line tools, but these have been subsequently removed as I know you are not supposed to install these as they intefere with the Exchange VSS Backup Writer.

Windows Server Backup set to perform full VSS backup of D:\ and E:\

Backup completes with the following error logged in the event log - Event ID 9782
Exchange VSS Writer (instance 6e763d02-8919-46df-afec-673023e1272e:1) has completed the backup of database 'MailboxDatabase01' with errors. The backup did not complete successfully, and no log files were truncated for this database.

I have watched the WSB tool run and checked the WSBExchange service at the time and this was still showing a manual startup and wasnt running?

I then failed the active copy of the mailbox over to the secondary mailbox server where WSB had been installed correctly (ie without the command line tools). I then ran a full backup from there - same issue- backup runs but doesn't show "performing consistency check for application exchange" and doesnt truncate the logs. I tried the same this but manually started the the Microsoft Exchange Server for Windows Server Backup Extension service, but got the same issue.

VSS Admin List Writers and List Providers show the correct ouput

We have a non DAG test environment and backups run perfectly in that truncating all log files as expected.

Any other ideas as to how I can get the log files to truncate as I'm running out of disk space as I now have over 100K of log files!

Thanks
Paul

Paul
Post #: 1
RE: DAG Backup using WSB not truncating logs - 21.Dec.2010 9:18:08 AM   
workinghardinit

 

Posts: 5
Joined: 21.Dec.2010
Status: offline
Check the EnableVSSWriter settings in HKEY_LOCAL_MACHINE\Software\Microsoft\ExchangeServer\v14\Replay\Parameters see details at
http://technet.microsoft.com/en-us/library/dd876851.aspx

(in reply to pjrouse2010)
Post #: 2
RE: DAG Backup using WSB not truncating logs - 21.Dec.2010 10:07:56 AM   
pjrouse2010

 

Posts: 11
Joined: 2.Dec.2010
Status: offline
According to that article, you only have to disable the setting if the server hosts both active and passive copies.

quote:

If a server hosting the data being backed up is a member of a database availability group (DAG) and hosts both active and passive database copies, you must disable the Microsoft Exchange Replication service VSS writer. If the Microsoft Exchange Replication service VSS writer is enabled, the backup operation will fail.


I'm only backing up on the server that hosts the active copy of the DB?

Or have I read it wrong, and because the server I am using *can* host either an active or passive copy of the database I have to disable that setting?

Thanks

Paul

(in reply to workinghardinit)
Post #: 3
RE: DAG Backup using WSB not truncating logs - 21.Dec.2010 10:34:07 AM   
workinghardinit

 

Posts: 5
Joined: 21.Dec.2010
Status: offline
You can't backup the passive copy with Windows Backup. You need to use the active copy and you need to set te registry key. Further more I requiers a restart of the Microsoft Exchange Replication service.

(in reply to pjrouse2010)
Post #: 4
RE: DAG Backup using WSB not truncating logs - 21.Dec.2010 11:49:55 AM   
pjrouse2010

 

Posts: 11
Joined: 2.Dec.2010
Status: offline
I presume I need to set it on both DAG member servers and restart the replication service on each?

I assume the client will not notice any loss in connectivity?

Paul

(in reply to workinghardinit)
Post #: 5
RE: DAG Backup using WSB not truncating logs - 21.Dec.2010 3:18:34 PM   
workinghardinit

 

Posts: 5
Joined: 21.Dec.2010
Status: offline
Yes but remember you can only back up active copies on whatever nodes. No the clients are unaffected.

(in reply to pjrouse2010)
Post #: 6
RE: DAG Backup using WSB not truncating logs - 22.Dec.2010 4:21:08 AM   
pjrouse2010

 

Posts: 11
Joined: 2.Dec.2010
Status: offline
Just added that reg key and restarted the replication service and attempted backing up the active copy of the DB

It still doesnt recognise Exchange and the Microsoft Exchange Server Extension for Windows Server Backup service doesnt start when the backup is running.

Paul

(in reply to workinghardinit)
Post #: 7
RE: DAG Backup using WSB not truncating logs - 22.Dec.2010 5:05:10 AM   
workinghardinit

 

Posts: 5
Joined: 21.Dec.2010
Status: offline
Things to check:

Any other events?
Diskpace on volumes to backup, do you have enough space?
Are the edb's in good health?
Are you using Full VSS backups ...

(in reply to pjrouse2010)
Post #: 8

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> High Availability >> DAG Backup using WSB not truncating logs Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter