• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Active Sync Test

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Active Sync Test Page: [1]
Login
Message << Older Topic   Newer Topic >>
Active Sync Test - 17.Jan.2011 12:13:02 PM   
TCheck

 

Posts: 92
Joined: 16.Jan.2006
Status: offline
We have an Exchange Server 2003 and we have been trying to get active sync to work on our Anroid and IPhone's with no luck. I ran the Active Sync test using (https://testexchangeconnectivity.com). IT all seems to sync except the final step I get the following mesage. Any ideas would be appreciated.

ExRCA is testing Exchange ActiveSync.
The Exchange ActiveSync test failed.
Test Steps
Attempting to resolve the host name mail.companyname.com in DNS.
The host name resolved successfully.
Additional Details
IP addresses returned:

Testing TCP port 443 on host mail.companyname.com to ensure it's listening and open.
The port was opened successfully.
Testing the SSL certificate to make sure it's valid.
The certificate passed all validation requirements.
Test Steps
Validating the certificate name.
The certificate name was validated successfully.
Additional Details
Host name mail.companyname.com was found in the Certificate Subject Common name.

Testing the certificate date to confirm the certificate is valid.
Date validation passed. The certificate hasn't expired.
Additional Details
The certificate is valid. NotBefore = 8/3/2010 4:59:33 PM, NotAfter = 8/3/2013 4:59:33 PM



Checking the IIS configuration for client certificate authentication.
Client certificate authentication wasn't detected.
Additional Details
Accept/Require Client Certificates isn't configured.

Testing HTTP Authentication Methods for URL https://mail.companyname.com/Microsoft-Server-Activesync/.
The HTTP authentication methods are correct.
Additional Details
ExRCA found all expected authentication methods and no disallowed methods. Methods found: Basic

An ActiveSync session is being attempted with the server.
Errors were encountered while testing the Exchange ActiveSync session.
Test Steps
Attempting to send the OPTIONS command to the server.
Testing of the OPTIONS command failed. For more information, see Additional Details.
Additional Details
A Web exception occurred because an HTTP 401 - Unauthorized response was received from Unknown.
Post #: 1
RE: Active Sync Test - 17.Jan.2011 12:37:57 PM   
alanhardisty

 

Posts: 389
Joined: 28.Feb.2010
Status: offline
The 401 error is usually down to an incorrect Username / Password or IP Address restrictions on the Exchange / Microsoft-Server-Activesync virtual directories.

Please have a read through my Exchange 2003 / Activesync article, check your settings and test again. If you get stuck anywhere - please let me know where.

http://alanhardisty.wordpress.com/2010/02/28/exchange-2003-and-activesync-configuration-and-troubleshooting/

_____________________________

Alan Hardisty

http://www.it-eye.co.uk
http://alanhardisty.wordpress.com
http://www.exchange-certificates.com

(in reply to TCheck)
Post #: 2
RE: Active Sync Test - 20.Jun.2011 2:01:11 AM   
jensskov

 

Posts: 8
Joined: 11.Feb.2008
Status: offline
Could it be that someone has a similar guide for Exchange 2010 sp1/Server 2008R2 ?
I have what seems to be exactely the same issue.
Everything is working but Active Sync and I get the same 401 error while testing the options command.

(in reply to alanhardisty)
Post #: 3
RE: Active Sync Test - 20.Jun.2011 3:04:50 AM   
alanhardisty

 

Posts: 389
Joined: 28.Feb.2010
Status: offline
Try this one for size:

http://alanhardisty.wordpress.com/2010/03/05/activesync-not-working-on-exchange-2010-when-inherit-permissions-not-set/

_____________________________

Alan Hardisty

http://www.it-eye.co.uk
http://alanhardisty.wordpress.com
http://www.exchange-certificates.com

(in reply to jensskov)
Post #: 4
RE: Active Sync Test - 20.Jun.2011 8:22:14 AM   
jensskov

 

Posts: 8
Joined: 11.Feb.2008
Status: offline
Thank you for you reply.
Sadly it does not seem to be my problem.

(in reply to alanhardisty)
Post #: 5
RE: Active Sync Test - 20.Jun.2011 9:07:47 AM   
alanhardisty

 

Posts: 389
Joined: 28.Feb.2010
Status: offline
In that case - you might be better off opening up a question in the Exchange 2010 area as this is Exchange 2003.

Alan

_____________________________

Alan Hardisty

http://www.it-eye.co.uk
http://alanhardisty.wordpress.com
http://www.exchange-certificates.com

(in reply to jensskov)
Post #: 6

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Message Routing >> Active Sync Test Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter