• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

[SOLVED] Can't connect to shell or management console

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> Management >> [SOLVED] Can't connect to shell or management console Page: [1]
Login
Message << Older Topic   Newer Topic >>
[SOLVED] Can't connect to shell or management console - 8.Apr.2011 1:11:33 PM   
Tamerz

 

Posts: 1
Joined: 8.Apr.2011
Status: offline
Hello, we just installed Exchange 2010 and everything was working fine for the most part. The other day though, we were no longer able to open the management console or the shell. With either one we get the message:

[server.domain.local] Connecting to remote server failed with the following error message : The WinRM client cannot 
process the request. It cannot determine the content type of the HTTP response from the destination computer. The 
content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.

  + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException
  + FullyQualifiedErrorId : PSSessionOpenFailed


I followed the steps here but the kerberos module is configured correctly at the PowerShell level and the users trying to launch the console have the proper rights: http://blogs.technet.com/b/exchange/archive/2010/02/04/3409289.aspx

Any help would be appreciated.

EDIT:
I was able to get this fixed by recreating the PowerShell virtual directory.

I tried everything mentioned in that article but it still did not work. Another issue with it, is that in order to run the “Get-User” and “Set-User” commands to check the user permissions, you need to open the Exchange Management Shell which was my problem to begin with. A workaround is to open a regular PowerShell and then run the following command:


Add-PSSnapin Microsoft.Exchange.Management.PowerShell.E2010


This allowed the use of the Exchange Management cmdlets. This then showed us that the user accounts had proper permissions and that this was not the issue.


The way I ended up resolving it was by using that same PowerShell to remove the PowerShell Virtual Directory from IIS:


> Get-PowerShellVirtualDirectory
Name
----
PowerShell (Default Web Site)


> Remove-PowerShellVirtualDirectory "PowerShell (Default Web Site)"


> New-PowerShellVirtualDirectory
cmdlet New-PowerShellVirtualDirectory at command pipeline position 1
Supply values for the following parameters:
Name: PowerShell

 
Name
----
PowerShell (Default Web Site)


After it created the new PowerShell directory, I had to open up IIS Manager and navigate to the PowerShell virtual directory. Go to the SSL settings, and make sure that “Require SSL” is not checked and hit Apply.


This resolved the issue for us after nothing else did. Hopefully it can help someone else out. I do recommend following the steps in the linked article first since that seems to resolve it for most people.

< Message edited by Tamerz -- 11.Apr.2011 11:08:04 AM >
Post #: 1
RE: [SOLVED] Can't connect to shell or management console - 13.Oct.2016 9:25:50 AM   
LFC

 

Posts: 1
Joined: 13.Oct.2016
Status: offline
Hi there, apologies for reviving an old thread but had to say thank you for this post. Have a SBS2011 customer that was facing this issue after a .Net 4.5.2 install.

Tried a few other fixes mentioned without success but this did it

Thanks again!

(in reply to Tamerz)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> Management >> [SOLVED] Can't connect to shell or management console Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter