• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

iPod to Exchange 2010

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> Mobility >> iPod to Exchange 2010 Page: [1]
Login
Message << Older Topic   Newer Topic >>
iPod to Exchange 2010 - 1.Aug.2011 4:10:24 PM   
deang

 

Posts: 14
Joined: 3.Aug.2009
Status: offline
I am having trouble connecting to an account on an Exchange 2010 server using an iPod or iPhone. Iím going to setup, mail, select Exchange and fill in the needed info. When the devices checks for mail I see the following error, Cannot Get Mail The connection to the server failed. If I switch the username, email address & password, to a different account on the same server (Iím leaving all the server info unchanged) it works fine. I have check over properties on each mailbox looking for differences and have not seen any. I have looked at the event viewer and see the login for the account that works under security. When I change to the setting for the account Iím having trouble with I donít even see a rejection of the login and I havenít changed the server settings at all. At the time Iíve attempted to connect using the bad account I see and security event for an administrator login that says, This event is generated when a logon session is destroyed. It may be positively correlated with a logon event using the logon ID value. Logon IDs are only unique between reboots on the same computer. What does that mean??
Looking for suggestions on how to fix my problem.
Thanks, Dean
Post #: 1
RE: iPod to Exchange 2010 - 1.Aug.2011 5:00:39 PM   
John Weber

 

Posts: 1236
Joined: 20.Apr.2005
From: Portland, Oregon
Status: offline
Is the user account with the connection issues a domain admin, or has that account ever been a member of one of the groups protected by the adminsdholder process?

_____________________________

John Weber [Lync MVP] http://tsoorad.blogspot.com

(in reply to deang)
Post #: 2
RE: iPod to Exchange 2010 - 2.Aug.2011 8:14:48 AM   
deang

 

Posts: 14
Joined: 3.Aug.2009
Status: offline
John,
The user with the issue is a member of Administrators, Domain Admins & Domain Users plus a few others that we created.

Thanks for the help,
Dean

(in reply to John Weber)
Post #: 3
RE: iPod to Exchange 2010 - 2.Aug.2011 10:36:45 AM   
John Weber

 

Posts: 1236
Joined: 20.Apr.2005
From: Portland, Oregon
Status: offline
If that is the case, then I suggest checking the user account in Active Directory.

It ADUC, goto VIEW and select "Advanced Features"

Right-click the user object, then choose Properties | Security | Advanced.

At the bottom of that there will be an empty check box that says "include inheritable permissions from this ojbect's parent"
tick that box, close the user object by clicking on OK twice.

http://tsoorad.blogspot.com/2011/08/adminsdholder-with-exchange-and-lync.html

_____________________________

John Weber [Lync MVP] http://tsoorad.blogspot.com

(in reply to deang)
Post #: 4
RE: iPod to Exchange 2010 - 3.Aug.2011 11:03:31 AM   
deang

 

Posts: 14
Joined: 3.Aug.2009
Status: offline
John,
Thanks for the idea but that did not work. Any other suggestions?

Dean

(in reply to John Weber)
Post #: 5
RE: iPod to Exchange 2010 - 3.Aug.2011 11:11:57 AM   
John Weber

 

Posts: 1236
Joined: 20.Apr.2005
From: Portland, Oregon
Status: offline
I presume you have checked the obvious stuff like hidden from GAL, locked out account, expired account, etc.

Can the account be accessed via OWA from the outside? What does https://www.testexchangeconnectivity.com/ tell you?

Can another device access that account and just not the Iphone/ipod?

_____________________________

John Weber [Lync MVP] http://tsoorad.blogspot.com

(in reply to deang)
Post #: 6
RE: iPod to Exchange 2010 - 3.Aug.2011 1:39:43 PM   
deang

 

Posts: 14
Joined: 3.Aug.2009
Status: offline
John,
He isn't hidden from the address list, locked out or expired. This is a new install switching from Novell to Windows Servers.
I can access the problem account using OWA. I have tested on a Droid and can not connect to the problem account. With my droid I have successfully accessed a different email account on that server.
Tested using the link you provided and I see the an error at the following point: Attempting the FolderSync command on the Exchange ActiveSync session.
The test of the FolderSync command failed.
Exchange ActiveSync returned an HTTP 500 response.
I clicked on the link it provided about the issue. Basically said to check the box to include inheritable permissions from the object to parent. This was the suggestion you gave earlier, but walked through it anyway. I had the account already setup on the iPod, I hit refresh twice and it pulled in email. Kind of odd it was unchecked today when I checked it yesterday. Solve one problem and discover another.
Thanks a ton for the help. Do you by chance have an idea why that box became unchecked?
Dean

(in reply to John Weber)
Post #: 7
RE: iPod to Exchange 2010 - 3.Aug.2011 2:31:01 PM   
John Weber

 

Posts: 1236
Joined: 20.Apr.2005
From: Portland, Oregon
Status: offline
Yes, I do know why that box gets unchecked. Every 20 minutes (I think that is the time frame) the adminsdholder rats through all of your AD and takes a series of actions to protect AD DS from nefarious deeds/people. One of those actions is to clear the inherits from certain groups and group members.

Read through that link I sent you. A ton of great info in that Policelli blog article.

I am glad you got the issue resolved so easily.

< Message edited by John Weber -- 3.Aug.2011 2:32:56 PM >


_____________________________

John Weber [Lync MVP] http://tsoorad.blogspot.com

(in reply to deang)
Post #: 8
RE: iPod to Exchange 2010 - 17.Sep.2011 4:18:15 AM   
shanmarsh1

 

Posts: 139
Joined: 13.Sep.2011
Status: offline
I am experiencing a similar issue. OSX mail connects to exchange just fine but my iphone 3GS with iOS4 says it is unable to verify account information.

Any luck figuring out what the issue is?

(in reply to deang)
Post #: 9

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> Mobility >> iPod to Exchange 2010 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter