Cluster network name is not online (Full Version)

All Forums >> [Microsoft Exchange 2010] >> High Availability



Message


travis.sheldon -> Cluster network name is not online (24.Aug.2011 10:38:00 AM)

I have a 2010 network with a DAG that is experiencing the following issue

"The cluster network name is not online"

The DAG consists of two mailbox servers that are located in the same network with two NICs each (1 MAPI, 1 replication) and one file share witness

1st NIC: The MAPI network has a local subnet used by the other Exchange servers
2nd NIC: Replication network has a private subnet that only exists on the mailbox server secondary nic.

The DAG itself has an IP for the local subnet (mapi) and one for the replication network..I believe that the replication network IP shouldn't be present, but the DAG would not online initially without it.

In the cluster events is the following entry:

quote:

Cluster IP address resource 'Cluster IP Address' cannot be brought online because the cluster network 'Cluster Network 2' is not configured to allow client access. Please use the Failover Cluster Manager snap-in to check the configured properties of the cluster network.



The first entry in the Cluster events was 6 hours prior to the above entry

quote:

File share witness resource 'File Share Witness (\\hub1.xxx.yyy.com\RDDAL.xxx.yyy.com)' failed a periodic health check on file share '\\hub1.xxx.yyy.com\RDDAL.xxx.yyy.com'. Please ensure that file share '\\hub1.xxx.yyy.com\RDDAL.xxx.yyy.com' exists and is accessible by the cluster.


I've tried to enable the "Allow clients to connect through this network" through the Failover Cluster Manager, but anytime I change it, the change isn't saved and it unchecks the option. I've also tried setting the property through cmd (cluster.exe) and powershell to no avail.


As far as I can see the cluster is still operating and logs are copying and committing..I cannot test a fail over until after hours..however not being able to online the cluster network name concerns me.

quote:

[PS] C:\Windows\system32>Get-DatabaseAvailabilityGroup | Set-DatabaseAvailabilityGroup
WARNING: Network name 'RDDAL' is not online. Please check that the IP address configuration for the database
availability group is correct.
Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
+ CategoryInfo : NotSpecified: (0:Int32) [Set-DatabaseAvailabilityGroup], UnauthorizedAccessException
+ FullyQualifiedErrorId : EA26050A,Microsoft.Exchange.Management.SystemConfigurationTasks.SetDatabaseAvailabilityG
roup


This same issue happened last week and the only option I was left with was to destroy the DAG and recreate it with a new name, etc..




travis.sheldon -> RE: Cluster network name is not online (24.Aug.2011 5:21:53 PM)

I was able to resolve the issue without taking down any resources.

First, I noticed that the Failover Cluster Manager "Cluster Name" had the IP address of the replication network only..

After going back through the guide @ http://technet.microsoft.com/en-us/library/dd638104.aspx I changed the properties on the NICs for file sharing, etc..I then adjusted windows firewall rules to block traffic from my MAPI network destined for the replication network.

I then removed the IP from the replication network on the DAG leaving only the 1 MAPI network IP.

After an hour or so, I ran Get-DatabaseAvailabilityGroupNetwork and seen that the MAPIAccess property was finally set to true on my MAPI network. I went back to Failover Cluster Manager and my Cluster Core Resource Cluster Name dropped the IP address that was associated (IP from the replication network) I added a new IP from my Mapi network range, updated the DAG IP in Exchange and the DNS record for the DAG and my cluster resource came online.




shanmarsh1 -> RE: Cluster network name is not online (18.Sep.2011 6:35:04 AM)

im having the same errors as you. it was working fine until my cluster bluescreened. after it rebooted, then i started getting these errors. i found an older thread that stated the exact problem but it said it was foxed with rtm. ( i guess not?)

Body Armour
Safeguard Clothing




Page: [1]