• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

OWA 2010 - SSL Vulnerability

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> Outlook Web Access >> OWA 2010 - SSL Vulnerability Page: [1]
Login
Message << Older Topic   Newer Topic >>
OWA 2010 - SSL Vulnerability - 25.Aug.2011 9:44:56 AM   
atengelmann

 

Posts: 1
Joined: 25.Aug.2011
Status: offline
Hello,

I am working on our company's annual compliance audit and one of the findings is an SSL (v2) weakness with our OWA server. I have been following this forum:

http://forums.iis.net/t/1151822.aspx

One of the posts in that forum a user mentions his registry entry for disabling SSLv2 on Windows Server 2008 R2 64bit with IIS7 (which is what I am running):

REG ADD "HKLM\System\CurrentControlSet\Control\SecurityProviders\SChannel\Protocols\SSL 2.0\Server" /v DisabledByDefault /t REG_DWORD /d 1 /f

I added that registry entry on our server and it works, which is verified by serversniff.net SSL Checker. The problem is that when this registry entry is added, the Exchange Management Console starts throwing a bunch of WinRM errors every time you click through the different sections. It seemed like it was still usable but just too many errors. So I removed that registry entry to get everything back to normal.

Anyone have any experience with that or know how to make that registry entry play nice with the Exchange Management Console?

This is the last hit before auditors come back next month to test again. Thank you for any advice!

Austin
Post #: 1
RE: OWA 2010 - SSL Vulnerability - 25.Aug.2011 3:58:05 PM   
kopter

 

Posts: 1
Joined: 25.Aug.2011
Status: offline
Good question because I am having the same problem.
After editing the same registry entry into our system, the exchange management console kept crashing.
We ended up removing that registry key and everything is going good now but I would like to be a little more secure.
any advice would be appreciated
thanks

(in reply to atengelmann)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> Outlook Web Access >> OWA 2010 - SSL Vulnerability Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter