Cannot Access Public Folder (Full Version)

All Forums >> [Microsoft Exchange 2003] >> Public Folders


DaveRainsberger -> Cannot Access Public Folder (24.Oct.2011 9:43:36 AM)

We have a single Exchange 2003 running in Windows Server 2003. It is newly installed from scratch. The Exchange Server is not a DC. Everything works fine: AD, OWA, mailboxes, etc. ... but we cannot get public folders to work. We also cannot get the free / busy information from any user for meeting requests.

I have gone through all the documentation on your forums and Microsoft website on repairing these issues: delete public folder / recreate public folder using adsiedit, move folders, reset access rights, etc. ... is it possible I have corrupt installation?

We are at a total loss on what to do. The public folder / scheduling meetings was why we convinced the CEO (small non-profit organization) to get Exchange in the first place. Please help!

DaveRainsberger -> RE: Cannot Access Public Folder (24.Oct.2011 1:21:53 PM)

[image][/image] Thanks for the help!

[image][/image] Any messages popping up?
In Outlook:
Unable to expand the folder. The set of folders could not be opened. The attempt to log on to the Microsoft Exchange server computer has failed ( [server name] )
In ESM: Click on Folders -> Public Folders
The requested operation is forbidden
ID no: c1030af1
Exchange System Manager


The operation completed successfully.
Facility: Win32
ID no: c0070000
Exchange System Manager
Public Folders store in First Storage Group
has 5 folders, and it mounts correctly
Public Folder Instances
Public Folders
Replication Status
Full-Text Indexing

[image][/image] Any notifications in the eventlogs?
The only error I found in the event log seems to be unrelated because it was recorded at 5:06am when I wasn't here yet, nothing after that.

The MAPI call 'OpenMsgStore' failed with the following error:
The attempt to log on to the Microsoft Exchange Server computer has failed.
The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0512-00000000
[image][/image] Does it work as an administrator?
[image][/image] What are the current rights set on the public store?
Administrator: Full
Anonymous: None
Domain Admins: Full (except delete)
Enterprise Admins: Full
Everyone: Full (I changed this myself thinking it may help)
Exchange Domain Servers: Read/Execute/Create/Modify/Etc.
Exchange Services: Full
[image][/image] Does the folder where the files are stored have enough space?
HDD has 175GB free space
[image][/image] What specifically doesn't work (can you see the contents of the file)?
I noted this in detail above. In ASM I can see the folder tree and sub-folders but in Outlook I cannot open the folders.
[image][/image] Is there anything that does work (regarding public folders)?

Lastly: I double checked to see that the Public Folders Store is in the Public Folders Tree. Is it possible naming the Exchange Server 'Exchange' caused any problems? or calling the Public Folders 'Public Folders'? We apparently do not have very imaginative minds for naming things.

I attached an image of the tree structure from ESM


DaveRainsberger -> RE: Cannot Access Public Folder (24.Oct.2011 2:01:20 PM)

I had tried those, but I ran through them again, no luck.

I just seems to be an access rights issue ... so frustrating [image][/image]

Any other ideas?

DaveRainsberger -> RE: Cannot Access Public Folder (27.Oct.2011 10:27:55 AM)

First let me say thanks a million for all your help.

Okay, I ran through everything above. I ran the defrag on the database last night with no errors (it does seem to running better though). While that was going on, while I had the services stopped, I deleted the public folders through ADSIEDIT, and then deleted the public folder databases as well. Everything is running great with no public folders.

Do you have any instructions that I may not have read already about recreating the public folders correctly? Is there any other residual registry cleanup I should do first to completely remove instances of the former public folders?

I don't know if I explained this before but my goal is to publish everyone's free / busy schedules and apparently that doesn't work if the public folders are not accessible.

devang2718 -> RE: Cannot Access Public Folder (20.Nov.2011 4:19:16 AM)


I have also faced such kind of problem during my first exchange 2010 installation.

As you have mentioned you are not able to expand the public folder in Microsoft Outlook.

This Could be because of Microsoft Exchange RPC Access Service is not running on your server.

First pls verify that RPC Access Service is available in Exchange 2003 or not because i'm telling you the service name from my exchange 2010 experience.

Jesper Bernle -> RE: Cannot Access Public Folder (20.Nov.2011 9:26:36 AM)


ORIGINAL: devang2718

you are not able to expand the public folder in Microsoft Outlook.

This Could be because of Microsoft Exchange RPC Access Service is not running on your server.

This advice is only viable in Exchange 2010. Why? In Exchange 2003 ALL client connection go to the mailbox server whereas in Exchange 2010 ONLY Public Folder connections go to the mailbox server role. So, in Exchange 2010 it is possible to have everything working but having problems to reach Public Folders due to the RPC Access Service not being started.

It the RPC service isn't started in Exchange 2003 NOTHING would work.

DaveRainsberger -> RE: Cannot Access Public Folder (30.Jan.2012 11:28:50 AM)

Well, I finally hired an expert consultant to come in and fix my problem. I appreciate all the help and suggestions here but this one was a strange one.

The way I understood the solution was that in my registry there was a reference to a public folder container that did not exist and no matter how many times I recreated the folder container, or deleted and then recreated it, the reference remained in the registry. It took my hired expert quite a lot of digging through reference manuals and registry entries to find and remove it.

So problem solved, with no help from me [;)]

Page: [1]