• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Dual Login to OWA

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Outlook Web Access >> Dual Login to OWA Page: [1]
Login
Message << Older Topic   Newer Topic >>
Dual Login to OWA - 17.Nov.2011 7:33:09 AM   
TravisT

 

Posts: 11
Joined: 9.Jan.2009
Status: offline
I've been having this problem since I installed Exchange 2007, but since I rarely use OWA, I never bothered with fixing it. Now it's bugging me and I can't seem to figure it out.

When I try to login to my OWA, I get a dialog box that asks me for my login info. After I successfully enter it, it brings me to the OWA login webpage, which I then have to log in to again in order to access my email. I've tried changing many settings in the IIS Manager, but none seem to fix this problem. Am I missing something?

I have an Edge/Hub setup with exchange.
Post #: 1
RE: Dual Login to OWA - 28.Nov.2011 11:44:32 AM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
Sounds like you no longer have Anonymous Access enabled on the IIS directory containing the logon page. I don't have E2007 any more, but if it's the same as E2010 (and most things are), it'll be the owa/auth directory in IIS.

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to TravisT)
Post #: 2
RE: Dual Login to OWA - 28.Nov.2011 1:55:15 PM   
TravisT

 

Posts: 11
Joined: 9.Jan.2009
Status: offline
Thanks for the reply. I checked the recommended setting, and it seems that it is already set to allow anonymous logins. I checked the auth folder under the owa, it was set to allow anonymous logins. I attempted to set the entire owa folder to allow anonymous logins, and that didn't help.

Since I am connecting to https://server/exchange, I looked at that folder. Anonymous logins were not enabled there, so I enabled them. It seems to have made a difference, because now I get a HTTP/1.1 401 Unauthorized screen, but no authentication dialog box popup. Seems that the problem is related to the /exchange folder?

I am at a loss here. If anyone can point me in the right direction I would appreciate it.

(in reply to leederbyshire)
Post #: 3
RE: Dual Login to OWA - 29.Nov.2011 10:38:18 AM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
Ah, right. You are still going to the https://servername/exchange address to access OWA. In E2007, it is better to go to https://servername/owa . You _can_ still go to the /exchange address if you want to (it's there so that you don't have to tell everyone the new URL), but you just get redirected to the new address anyway. Also, you don't get to see the shiny new logon page. Plus, going to the old address just to get redirected adds some unneccesary complication.

Anyway, since you were going to /Exchange the setting on /owa/auth were not relevant, and you should have changed the setttings on /exchweb/auth, instead. But before we go any further, are you happy to go to the new /owa address, or are you happier going to the old /exchange address, then being redirected?

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to TravisT)
Post #: 4
RE: Dual Login to OWA - 29.Nov.2011 10:56:17 AM   
TravisT

 

Posts: 11
Joined: 9.Jan.2009
Status: offline
/owa doesn't seem to be working at all. I'll have to look into that in more detail.

I'm fine with going to owa, but would like to have both function the same. This is purely a testing environment (aside from the two users that actually receive mail on this box). I'd just like to understand the innerworkings of exchange.

Lets stick with /exchange now, and once I get the issue worked out with the /owa site I'll work on that part.

(in reply to leederbyshire)
Post #: 5
RE: Dual Login to OWA - 29.Nov.2011 12:07:14 PM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
Well, since /exchange is always going to attempt to redirect you to /owa, I think you will need to get /owa working first. But, in case getting the logon page at /exchange helps (because it means you won't see that logon page at /owa, and that might be broken, too), it will probably help to recreate the exchweb directory. I have to leave for home, now, so if you can't wait till tomorrow (it will take me a while to work out what you will need to type in) have a search for articles that explain how to use remove-owavirtualdirectory and new-owavirtualdirectory to recreate that exchweb vdir.

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to TravisT)
Post #: 6
RE: Dual Login to OWA - 30.Nov.2011 12:53:08 AM   
TravisT

 

Posts: 11
Joined: 9.Jan.2009
Status: offline
Thanks for your help. Don't mind doing the legwork myself, just didn't know where to look. Started searching on how to recreate the exchweb virtual directory and found this KB:

http://support.microsoft.com/kb/941201

I deleted all of the virtual directories (as it says to in the KB) and re-created them. My OWA is now working like it should. Only strange thing now is that when I go to the /exchange url, it redirects me to my internal URL as opposed to my external url (server.local vs. server.com). I'm going to dig through the exchange vd to see if I can figure out where the redirect is happening and update it to the right URL. May not mess with this yet, because I read somewhere that you should not modify the exchange vd's in IIS, instead they should be modified within the exchange management shell. Don't want to break this again.

(in reply to leederbyshire)
Post #: 7
RE: Dual Login to OWA - 30.Nov.2011 11:33:37 AM   
leederbyshire

 

Posts: 1356
Joined: 4.Jan.2006
Status: offline
Correct, there are some properties of the Exchange VDirs that should not be changed in IIS Manager (although there are a few cases where you have no other option). Have a look at the properties of the OWA VDir in Exchange Management Console. I think you'll find an input box there for the internal and external URLs. If not, then that's something else you will have to type into the command line, as a parameter of Set-OWAVirtualDirectory:
http://technet.microsoft.com/en-us/library/bb123515.aspx

_____________________________

Lee.
___________________________________

Outlook Web Access for PDA and WAP:
www.leederbyshire.com
___________________________________

(in reply to TravisT)
Post #: 8

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Outlook Web Access >> Dual Login to OWA Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter