• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

404 - File or directory not found Win2k8 CAS, Win2k3 BE

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2007] >> Outlook Web Access >> 404 - File or directory not found Win2k8 CAS, Win2k3 BE Page: [1]
Login
Message << Older Topic   Newer Topic >>
404 - File or directory not found Win2k8 CAS, Win2k3 BE - 7.Dec.2011 4:20:02 PM   
ilovebsod

 

Posts: 35
Joined: 20.Sep.2007
Status: offline
Just installed our 1st 2007 server (don't laugh, it's all we have licensing for) with just the Hub Transport and Client Access roles installed (no mailboxes) so we could replace our current Exch 2003 frontend.

First I was receiving the user does not exist when I'd tried to log it, I resolved by installing these roles

http://www.msexperts.org/blogs/cam/archive/2008/09/18/owa-redirection-for-exchange-2007-users-doesn-t-work-on-windows-2008.aspx

Then I was able to login, but received the 404 error

I recreated the /Exchange virtual directory and reinstalled the CAS role

http://forums.msexchange.org/m_1800506659/tm.htm

Still the problem remains.

This occurs if I attempt to access via the internal DNS/hostname or the external DNS (I've updated the hosts file on my workstation) at https://webmail.ourdomain.com/exchange (our SSL cert is issued to webmail.ourdomain.com)


mnot sure where else to go from here. thanks in advance
Post #: 1
RE: 404 - File or directory not found Win2k8 CAS, Win2k... - 7.Dec.2011 9:10:15 PM   
Ytsejamer1

 

Posts: 135
Joined: 3.Jun.2010
Status: offline
No worries on Exchange version...whatever works is whatever works! :)

There is a tiny little checkbox that has to be selected in the 2003 BE IIS virtual directories to make OWA work correctly when going to a backend.

Doing a quick search here of this forum I found one of my older posts:
http://forums.msexchange.org/m_1800550742/mpage_1/key_CAS/tm.htm#1800550874

This was the most helpful link: http://blogs.technet.com/b/exchange/archive/2007/09/04/3403852.aspx

Note: Integrated Windows authentication for /Exchange and /Microsoft-Server-ActiveSync virtual directories must be enabled via Exchange System Manager on Exchange 2003 back-end server

I think that will help you get your issue resolved.  There are several links in that Technet article which are very helpful too!

(in reply to ilovebsod)
Post #: 2
RE: 404 - File or directory not found Win2k8 CAS, Win2k... - 8.Dec.2011 12:15:04 PM   
ilovebsod

 

Posts: 35
Joined: 20.Sep.2007
Status: offline
Thanks for the reply!

Is the tick box that you're referencing the Integrated Authentication? That's ticked on both virtual directories on ISM on the 2003 BE, but through ESM I can only verify that it's ticked on /Exchange . The access tab on /Microsoft-Server-ActiveSync in ESM is greyed out. I found a hotfix for this issue that I'll apply after hours, but I just want to make sure that's the tick box in question.

http://blogs.technet.com/b/exchange/archive/2007/01/05/3397655.aspx

http://support.microsoft.com/kb/937031

Thanks again!

(in reply to Ytsejamer1)
Post #: 3
RE: 404 - File or directory not found Win2k8 CAS, Win2k... - 8.Dec.2011 9:27:57 PM   
Ytsejamer1

 

Posts: 135
Joined: 3.Jun.2010
Status: offline
I think you are spot on...however I think I remember doing in IIS rather then in ESM2003.  I don't remember installing any hotfix for it.  Good find.

(in reply to ilovebsod)
Post #: 4
RE: 404 - File or directory not found Win2k8 CAS, Win2k... - 9.Dec.2011 9:59:07 AM   
ilovebsod

 

Posts: 35
Joined: 20.Sep.2007
Status: offline
I installed the hotfix, the Integrated Authentication box was not ticked for /Microsoft-Server-ActiveSync, I ticked it and then restarted the HTTP protocol (through the cluster administrator, our BE is a cluster) then attempted to log in to OWA through our 2007 CAS and still received the 404 error.

Any other ideas? I've read through every article/post I can find and all my systems seem to check out with what the articles say. I'm at a complete loss here.

(in reply to Ytsejamer1)
Post #: 5
RE: 404 - File or directory not found Win2k8 CAS, Win2k... - 12.Dec.2011 9:55:34 AM   
Ytsejamer1

 

Posts: 135
Joined: 3.Jun.2010
Status: offline
What is your mail flow configuration like? (ie. Public SMTP/Antispam->MS Exchange Hub Transport->MS Exchange Mailbox)

(in reply to ilovebsod)
Post #: 6
RE: 404 - File or directory not found Win2k8 CAS, Win2k... - 13.Dec.2011 11:13:55 AM   
ilovebsod

 

Posts: 35
Joined: 20.Sep.2007
Status: offline
Currently it's our a 3rd party SMTP w/ Antispam (Xwall) > our 2003 FE (which has our antivirus) > 2003 backend

The plan is to have it be 3rd party SMTP w/ Antispam (Xwall) > Hub Transport/CAS (w/ our 3rd party antivirus, this is not installed yet) > 2003 backend

(in reply to Ytsejamer1)
Post #: 7
RE: 404 - File or directory not found Win2k8 CAS, Win2k... - 15.Dec.2011 10:25:53 PM   
Ytsejamer1

 

Posts: 135
Joined: 3.Jun.2010
Status: offline
Seems on the up and up...pretty straight forward. So you're pointing your SMTP from the antispam box, to a specific smart host IP or FQDN.

I'm kind of at a loss...everything seems in order. Where are your servers in relation to Active Directory sites and services? Is the FE and CAS box in their own site or is everything just in a single site? You installed the latest SP3 and Update Rollup for 2007 correct?

Hopefully someone else can jump in. If you don't make any headway after awhile...sometimes those support calls to Microsoft are quite valuable. They know their stuff and are good to answer any questions you have along the course of the support call. When I was working on this project, there were about two things that I had to call them on. It was worth it in the grand scheme of things.

*EDIT* Gulab had some good links...not sure if they are applicable to your situation or config, but might be worth exploring. http://forums.msexchange.org/404_-_File_or_directory_not_found%25/m_1800556771/tm.htm

< Message edited by Ytsejamer1 -- 15.Dec.2011 10:30:21 PM >

(in reply to ilovebsod)
Post #: 8
RE: 404 - File or directory not found Win2k8 CAS, Win2k... - 23.Dec.2011 12:57:42 PM   
ilovebsod

 

Posts: 35
Joined: 20.Sep.2007
Status: offline
I'm pointing the SMTP from our 2003 FE to our antispam server (Xwall, running on a Windows 2003 box) via FQDN.

The FE and CAS (as well as all other Exchange boxes) are in the same site. I've got SP3 and rollup 5 installed.

Unfortunately none of the links Gulab provided applied to my situation.

At this point I'm thinking it may be something w/ server 2008 R2. I'm going to spin up a 2003 R2 instance and try installing the CAS role on it to see if it works.

(in reply to Ytsejamer1)
Post #: 9
RE: 404 - File or directory not found Win2k8 CAS, Win2k... - 30.Dec.2011 10:01:26 AM   
ilovebsod

 

Posts: 35
Joined: 20.Sep.2007
Status: offline
Running a CAS/HT from a 2003 R2 instance results in the same 404 error.

I checked the local path for the /Exchange VD and on both CAS instances it pointed to

\\.\BackOfficeStorage\our-primarysmtp-domain.com\MBX

our SMTP domain is different than our AD domain, so I changed it on 1 CAS (the new 2003 CAS) to

\\.\BackOfficeStorage\our-ad-domain.com\MBX

and stopped/started the website, but still no joy.

(in reply to ilovebsod)
Post #: 10

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2007] >> Outlook Web Access >> 404 - File or directory not found Win2k8 CAS, Win2k3 BE Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter