Permission or security error for inbound email (Full Version)

All Forums >> [Microsoft Exchange 2003] >> Message Routing



Message


tsimpsonaz -> Permission or security error for inbound email (13.Dec.2011 7:15:22 PM)

I currently only use the Default SMTP Virtual Server for all inbound/outbound mail. I need to create a SMTP connector so I can relay to an external smart host. When it setup the new connector I can send email from the server ok. When I try to send an email to my account from an external email account like Hotmail it gets bounced back with the message "Your message wasn't delivered due to a permission or security issue. It may have been rejected by a moderator, the address may only accept e-mail from certain senders, or another restriction may be preventing delivery."

As soon as I delete the SMTP connector all works fine again.




alanhardisty -> RE: Permission or security error for inbound email (14.Dec.2011 4:17:26 AM)

The SMTP Connector only handles Outbound emails, not incoming emails, so please check your SMTP Virtual Server settings on the Delivery Tab and check that nothing is setup there.

Inbound mail settings are on the Access tab and for Authentication you need a minimum of Anonymous Auth enabled.

Once you have checked everything - restart the SMTP service to force the settings to be applied.




tsimpsonaz -> RE: Permission or security error for inbound email (14.Dec.2011 9:26:47 AM)

Yep I know the SMTP is only for outbound which really confuses me why as soon as I create it that emails start getting blocked. Almost like it somehow changes some of the permissions on the Virtual SMTP server. I will take a look at the settings you recommend. Thanks




tsimpsonaz -> RE: Permission or security error for inbound email (14.Dec.2011 9:44:56 AM)

I checked the Authentication settings. I had Anonymous, Basic Auth and Integrated Windows all turned on. I unchecked both basic and Integrated and restarted SMTP service (after creating the SMTP connector again) and I get the same permission error.




alanhardisty -> RE: Permission or security error for inbound email (14.Dec.2011 12:16:47 PM)

What TCP Port and IP Address is configured on the General Tab> Advanced Button?

Worst case - disable the current SMTP Virtual Server and create a new one and see how that behaves.




tsimpsonaz -> RE: Permission or security error for inbound email (14.Dec.2011 3:37:38 PM)

Alan, it's curently set to (All Unassigned) for IP and port 25 and Filter Enable is set to YES.




alanhardisty -> RE: Permission or security error for inbound email (14.Dec.2011 3:51:47 PM)

Okay - that's all normal!

Can you disable the SMTP Virtual Server and create a new one using the same IP and port settings, then restart the SMTP Service and see if that helps.

Thanks

Alan




tsimpsonaz -> RE: Permission or security error for inbound email (14.Dec.2011 5:23:01 PM)

I actually found part of the problem. The Exchange server I am working on is not my home domain. In a nutshell I have a contact setup for my home domain and my AD account forwards all email to that account, so when I want to test email on that server I send a message from my home account to that domain and it gets forwarded back to my home account. It normally works just fine; however I found out that once I create this SMTP connector I am the only one getting bounce backs due to it trying to forward the email back to me. If I unforward it, the email gets delivered fine. The SMTP connector worked fine all along so now I just have to figure out why it won't allow forwarding. Thanks for your help on this.




alanhardisty -> RE: Permission or security error for inbound email (14.Dec.2011 5:56:20 PM)

That makes sense - and explains a lot. It did sound like everything was configured properly.

Re the forwarding (or lack of) when the SMTP Connector is in use - what error do you get?




tsimpsonaz -> RE: Permission or security error for inbound email (16.Dec.2011 9:23:10 AM)

It's the message on my initial post about permissions.

I just looked at the SMTP log on the Exchange server and here is the error returned:
554+5.7.1+<myuser@myhomedomain.com>:+Sender+address+rejected:+Access+denied 0 0 75 0 110 SMTP

I also tried something different. I went into my AD account and turned off the forwarding. I then logged into my email on the remote domain and setup an Outlook rule to forward all mail to my home account. When I send an email to it, it never gets forwarded, but I never get an NDR either.




alanhardisty -> RE: Permission or security error for inbound email (16.Dec.2011 12:09:53 PM)

Sender+address+rejected - suggests they don't like you personally.




tsimpsonaz -> RE: Permission or security error for inbound email (20.Dec.2011 9:38:12 AM)

It does it with any email account I try to forward out.




Page: [1]