• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Cannot activate database copy

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> High Availability >> Cannot activate database copy Page: [1]
Login
Message << Older Topic   Newer Topic >>
Cannot activate database copy - 19.Jan.2012 4:49:27 AM   
MichaelCaditz

 

Posts: 14
Joined: 9.Dec.2011
Status: offline
The Microsoft Exchange Replication service is in fact running on both servers . . .what could be causing this?


--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Cannot activate database copy 'Activate Database Copy...'.

Activate Database Copy...
Failed
Error:
An Active Manager operation failed. Error: The database action failed. Error: An error occurred while trying to validate the specified database copy for possible activation. Error: Cannot determine the copy status for database 'Mailbox Database SFGAL0' on server 'MAILSFGAL1.gpgallery.com'. Error: A server-side administrative operation has failed. The Microsoft Exchange Replication service may not be running on server MAILSFGAL1.gpgallery.com. Specific RPC error message: Error 0x6bf (The remote procedure call failed and did not execute) from cli_GetCopyStatusEx2. [Database: Mailbox Database SFGAL0, Server: MAILCORP1.gpgallery.com]

An Active Manager operation failed. Error: An error occurred while trying to validate the specified database copy for possible activation. Error: Cannot determine the copy status for database 'Mailbox Database SFGAL0' on server 'MAILSFGAL1.gpgallery.com'. Error: A server-side administrative operation has failed. The Microsoft Exchange Replication service may not be running on server MAILSFGAL1.gpgallery.com. Specific RPC error message: Error 0x6bf (The remote procedure call failed and did not execute) from cli_GetCopyStatusEx2.




--------------------------------------------------------
OK
--------------------------------------------------------
Post #: 1
RE: Cannot activate database copy - 19.Jan.2012 7:33:35 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Are the servers in the same AD Site\same datacenter? How many members are in the DAG? What is the status of the databases on all members? Is this happening to one or all databases in the DAG?

This error you posted is very generic! Can you post events that are produced in the application log when you try to activate the copy?

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to MichaelCaditz)
Post #: 2
RE: Cannot activate database copy - 19.Jan.2012 8:19:32 AM   
MichaelCaditz

 

Posts: 14
Joined: 9.Dec.2011
Status: offline
I have six servers. Four are in the AD site where I am having the problem. Two are in another AD site.

In this AD site, only two servers are in the DAG. Thus, I have four servers in the DAG. Two in this AD site, and two in the other AD site.

The database active in other AD site is not having a problem.

The problem is with two databases in this AD site (one is a PF database). Both are not mounted and I cannot mount them(but they were mounted and working fine a few hours ago.)

With respect to the regular mailbox database "SFGAL0", it resides on server "MAILSFGAL0", it is active, its status is dismounted and content index state is failed. It has a copy on another DAG member "MAILSFGAL1" in the same AD site. The copy is not active, status is suspended and content index state is failed. Thee is a second copy of this database on a server "MAILCORP0" in the other AD site. That copy is not active, status is suspended and content index state is failed.

On server MAILSFGAL1, I am trying to repair the index as follows on the copy: Update-MailboxDatabaseCopy "Mailbox Database SFGAL0\MAILSFGAL1" -CatalogOnly

and the response is

A source-side operation failed. Error An error occurred while performing the seed operation. Error: An error occurred w
hile updating the search catalog files from server 'MAILSFGAL0' to 'MAILSFGAL1'. Error: Can't pause the search catalog.
Error: Microsoft.Exchange.Search.Common.FteCatalogNotFoundException: SearchCatalog.PauseIndexing failed, error 0x80043
629 ---> System.ComponentModel.Win32Exception: Unknown error (0x80043629)
--- End of inner exception stack trace ---
at Microsoft.Exchange.Cluster.Replay.SearchCatalogProxy.PauseIndexing()
at Microsoft.Exchange.Cluster.Replay.CiFilesSeederInstance.<SeedThreadProcInternal>b__3(Object , EventArgs )
at Microsoft.Exchange.Cluster.Replay.CiFilesSeederInstance.RetryCiOperation(EventHandler evt).. [Database: Mailbox D
atabase SFGAL0, Server: MAILSFGAL1.gpgallery.com]
+ CategoryInfo : InvalidOperation: (:) [Update-MailboxDatabaseCopy], CiSeederGenericException
+ FullyQualifiedErrorId : 604238D6,Microsoft.Exchange.Management.SystemConfigurationTasks.UpdateDatabaseCopy

Application Event log on MAILSFGAL1 shows:


[Seed Manager] The seed request for database 'Mailbox Database SFGAL0' encountered an error during seeding. Error: An error occurred while updating the search catalog files from server 'MAILSFGAL0' to 'MAILSFGAL1'. Error: Can't pause the search catalog. Error: Microsoft.Exchange.Search.Common.FteCatalogNotFoundException: SearchCatalog.PauseIndexing failed, error 0x80043629 ---> System.ComponentModel.Win32Exception: Unknown error (0x80043629)
--- End of inner exception stack trace ---
at Microsoft.Exchange.Cluster.Replay.SearchCatalogProxy.PauseIndexing()
at Microsoft.Exchange.Cluster.Replay.CiFilesSeederInstance.<SeedThreadProcInternal>b__3(Object , EventArgs )
at Microsoft.Exchange.Cluster.Replay.CiFilesSeederInstance.RetryCiOperation(EventHandler evt).

AND


Failed to save admin audit log for this cmdlet invocation.
Organization:
Log content:
Subject: gpgallery.com/San Fe Gallery/Michael R. Caditz : Update-MailboxDatabaseCopy
Body:
Cmdlet Name: Update-MailboxDatabaseCopy
Object Modified: Mailbox Database SFGAL0\MAILSFGAL1
Parameter: CatalogOnly = True
Parameter: Identity = Mailbox Database SFGAL0\MAILSFGAL1
Caller: gpgallery.com/San Fe Gallery/Michael R. Caditz
Succeeded: False
Error: Microsoft.Exchange.Cluster.Replay.CiSeederGenericException: A source-side operation failed. Error An error occurred while performing the seed operation. Error: An error occurred while updating the search catalog files from server \'MAILSFGAL0\' to \'MAILSFGAL1\'. Error: Can\'t pause the search catalog. Error: Microsoft.Exchange.Search.Common.FteCatalogNotFoundException: SearchCatalog.PauseIndexing failed, error 0x80043629 ---> System.ComponentModel.Win32Exception: Unknown error (0x80043629)\r\n --- End of inner exception stack trace ---\r\n at Microsoft.Exchange.Cluster.Replay.SearchCatalogProxy.PauseIndexing()\r\n at Microsoft.Exchange.Cluster.Replay.CiFilesSeederInstance.<SeedThreadProcInternal>b__3(Object , EventArgs )\r\n at Microsoft.Exchange.Cluster.Replay.CiFilesSeederInstance.RetryCiOperation(EventHandler evt).. ---> Microsoft.Exchange.Search.Common.FteCatalogNotFoundException: SearchCatalog.PauseIndexing failed, error 0x80043629 ---> System.ComponentModel.Win32Exception: Unknown error (0x80043629)\r\n --- End of inner exception stack trace ---\r\n at Microsoft.Exchange.Cluster.Replay.SearchCatalogProxy.PauseIndexing()\r\n at Microsoft.Exchange.Cluster.Replay.CiFilesSeederInstance.<SeedThreadProcInternal>b__3(Object , EventArgs )\r\n at Microsoft.Exchange.Cluster.Replay.CiFilesSeederInstance.RetryCiOperation(EventHandler evt)\r\n --- End of inner exception stack trace (Microsoft.Exchange.Search.Common.FteCatalogNotFoundException) ---\r\n at Microsoft.Exchange.Cluster.Replay.CiFilesSeederInstance.SeedThreadProcInternal()\r\n at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.RunRpcServerOperation(String databaseName, RpcServerOperation rpcOperation)\r\n --- End of stack trace on server (MAILSFGAL1.gpgallery.com) ---\r\n at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.ClientRethrowIfFailed(String databaseName, String serverName, RpcErrorExceptionInfo errorInfo)\r\n at Microsoft.Exchange.Cluster.Replay.SeedProgressReporter.GetException()
Run Date: 2012-01-19T13:16:50
OriginatingServer: MAILSFGAL1 (14.01.0355.001)

Error:
Microsoft.Exchange.Data.Storage.ConnectionFailedTransientException: Cannot open mailbox /o=GPGALLERY/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=MAILSFGAL0/cn=Microsoft System Attendant. ---> Microsoft.Mapi.MapiExceptionNetworkError: MapiExceptionNetworkError: Unable to make connection to the server. (hr=0x80040115, ec=-2147221227)
Diagnostic context:
......
Lid: 13720 dwParam: 0x6D9 Msg: EEInfo: Flags: 0
Lid: 11672 dwParam: 0x6D9 Msg: EEInfo: NumberOfParameters: 4
Lid: 8856 dwParam: 0x6D9 Msg: EEInfo: prm[0]: Unicode string: ncacn_ip_tcp
Lid: 8856 dwParam: 0x6D9 Msg: EEInfo: prm[1]: Unicode string: MAILSFGAL0.gpgallery.com
Lid: 12952 dwParam: 0x6D9 Msg: EEInfo: prm[2]: Long val: -545057711
Lid: 12952 dwParam: 0x6D9 Msg: EEInfo: prm[3]: Long val: 382312662
Lid: 45169 StoreEc: 0x824
Lid: 44273
Lid: 59431 EMSMDB.EcDoConnectEx called [length=184]
Lid: 34855 EMSMDB.EcDoConnectEx returned [ec=0x0][length=82][latency=0]
Lid: 25964 StoreEc: 0x824
Lid: 38951 EMSMDB.EcDoDisconnect called [length=8]
Lid: 55335 EMSMDB.EcDoDisconnect returned [ec=0x0][length=12][latency=0]
Lid: 36081
Lid: 52465 StoreEc: 0x80040115
Lid: 60065
Lid: 33777 StoreEc: 0x80040115
Lid: 59805
Lid: 52209 StoreEc: 0x80040115
Lid: 56583
Lid: 52487 StoreEc: 0x80040115
Lid: 19778
Lid: 27970 StoreEc: 0x80040115
Lid: 17730
Lid: 25922 StoreEc: 0x80040115
at Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, SafeExInterfaceHandle iUnknown, Exception innerException)
at Microsoft.Mapi.ExRpcConnection.Create(ConnectionCache connectionCache, ExRpcConnectionCreateFlag createFlags, ConnectFlag connectFlags, String serverDn, String userDn, String user, String domain, String password, String httpProxyServerName, Int32 ulConMod, Int32 lcidString, Int32 lcidSort, Int32 cpid, Int32 cReconnectIntervalInMins, Int32 cbRpcBufferSize, Int32 cbAuxBufferSize, Client xropClient, Byte[] clientSessionInfo, TimeSpan connectionTimeout)
at Microsoft.Mapi.MapiStore.OpenMapiStore(String serverDn, String userDn, String mailboxDn, Guid guidMailbox, Guid guidMdb, String userName, String domainName, String password, String httpProxyServerName, ConnectFlag connectFlags, OpenStoreFlag storeFlags, CultureInfo cultureInfo, Boolean wantRedirect, String& correctServerDN, ClientIdentityInfo clientIdentity, String applicationId, Client xropClient, Boolean wantWebServices, Byte[] clientSessionInfo, TimeSpan connectionTimeout)
at Microsoft.Mapi.MapiStore.OpenMailbox(String serverDn, String userDn, String mailboxDn, String userName, String domainName, String password, ConnectFlag connectFlags, OpenStoreFlag storeFlags, CultureInfo cultureInfo, WindowsIdentity windowsIdentity, String applicationId)
at Microsoft.Exchange.Data.Storage.MailboxSession.ForceOpen(MapiStore linkedStore)
--- End of inner exception stack trace ---
at Microsoft.Exchange.Data.Storage.MailboxSession.ForceOpen(MapiStore linkedStore)
at Microsoft.Exchange.Data.Storage.MailboxSession.Initialize(MapiStore linkedStore, LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags, GenericIdentity auxiliaryIdentity)
at Microsoft.Exchange.Data.Storage.MailboxSession.<>c__DisplayClass12.<CreateMailboxSession>b__10(MailboxSession mailboxSession)
at Microsoft.Exchange.Data.Storage.MailboxSession.InternalCreateMailboxSession(LogonType logonType, ExchangePrincipal owner, CultureInfo cultureInfo, String clientInfoString, IAccountingObject budget, Action`1 initializeMailboxSession, InitializeMailboxSessionFailure initializeMailboxSessionFailure)
at Microsoft.Exchange.Data.Storage.MailboxSession.CreateMailboxSession(LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags, CultureInfo cultureInfo, String clientInfoString, PropertyDefinition[] mailboxProperties, IList`1 foldersToInit, GenericIdentity auxiliaryIdentity, IAccountingObject budget)
at Microsoft.Exchange.Data.Storage.MailboxSession.ConfigurableOpen(ExchangePrincipal mailbox, MailboxAccessInfo accessInfo, CultureInfo cultureInfo, String clientInfoString, LogonType logonType, PropertyDefinition[] mailboxProperties, InitializationFlags initFlags, IList`1 foldersToInit, IAccountingObject budget)
at Microsoft.Exchange.Data.Storage.MailboxSession.OpenAsSystemService(ExchangePrincipal mailboxOwner, CultureInfo cultureInfo, String clientInfoString)
at Microsoft.Exchange.ProvisioningAgent.MailboxLoggerFactory.XsoMailer.Log(AdminLogMessageData data, LogMessageDelegate logMessage)
at Microsoft.Exchange.ProvisioningAgent.AdminLogProvisioningHandler.OnComplete(Boolean succeeded, Exception e)

(in reply to de.blackman)
Post #: 3
RE: Cannot activate database copy - 19.Jan.2012 2:07:13 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
OK thanks for the description and details! This is what we need to be able to help you !

First off, public folders CANNOT be included in a DAG! They already use PF replication to synchronize so they cannot be added into the DAG. Please remove them from the DAG (http://www.msexchange.org/articles_tutorials/exchange-server-2010/high-availability-recovery/uncovering-exchange-2010-database-availability-groups-dags-part1.html)!

Secondly, for your mailbox database, it seems it is having an issue with the content index. Before you can update the copy of the catalog, you will have to recreate it.

http://www.msexchangegeek.com/2009/09/09/how-to-manually-rebuild-the-full-text-index-catalog/


_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to MichaelCaditz)
Post #: 4
RE: Cannot activate database copy - 20.Jan.2012 11:11:09 AM   
MichaelCaditz

 

Posts: 14
Joined: 9.Dec.2011
Status: offline
I knew that a PF should not be in DAG. I didn't add it intentionally, I just put it on the server.

I guess I don't completely understand DAGs. If the database is on the server then it necessarily becomes part of the DAG? How can I remove the PF from the DAG while maintaining its accessibility?

(in reply to de.blackman)
Post #: 5
RE: Cannot activate database copy - 20.Jan.2012 12:42:39 PM   
MichaelCaditz

 

Posts: 14
Joined: 9.Dec.2011
Status: offline
This article states that I can have a PF database on a DAG member server:

quote:

A public folder database can be hosted on a Mailbox server in a database availability group (DAG), but you must use multiple public folder databases and public folder replication for data redundancy.


http://technet.microsoft.com/en-us/library/bb629523.aspx

(in reply to MichaelCaditz)
Post #: 6
RE: Cannot activate database copy - 21.Jan.2012 1:57:13 PM   
MichaelCaditz

 

Posts: 14
Joined: 9.Dec.2011
Status: offline
I found the problem.

Let this be a warning to others whose system have these characteristics, as does mine:

1. CAS and mailbox server roles on one box.

2. DAG spanning multiple AD sites

3. Hardware load balancers

MAKE SURE THAT NAT IS NOT ENABLED on the HLB.

I use Kemp Loadmaster Exchange. It shipped with a "Miscellaneous Option" called
"Enable SNAT" selected by default. When I unchecked this box, replication and MAPI connectivity between AD sites was restored.

I do have a question. I have two networks, MAPI and replication. Only the MAPI is routed throught the HLB. Thus, I am confused as to why the replication network broke (in addition to the MAPI) when NAT was enabled on the HLB.

Does anyone know if, by design, the replication network requires the MAPI network in order to function?

(in reply to MichaelCaditz)
Post #: 7
RE: Cannot activate database copy - 26.Nov.2012 6:16:03 PM   
jhocut

 

Posts: 1
Joined: 26.Nov.2012
Status: offline
Bless you for posting your solution!

I have been banging my head on this for three days. Two servers in my primary site in the US, each running CAS, HT, and MB roles. DAG with both servers and CAS array sitting behind a Kemp LB. Built a new server in China. Installed all three roles, one at a time and it was mostly fine until I started configuring the MB role and tried to add it to the DAG.

Kept running into RPC issues and couldn't figure them out for the life of me.

Disabled SNAT and everything is working great so far. But I have a quick question.

Did disabling SNAT cause you to have to make any other changes? I am concerned that some other aspect of client access may be currently configured to work with SNAT in place and would like to get ahead of this if there are any known issues.

(in reply to MichaelCaditz)
Post #: 8
RE: Cannot activate database copy - 19.Nov.2013 7:29:26 AM   
mattclarified

 

Posts: 1
Joined: 19.Nov.2013
Status: offline
Created an account just to say thanks for this information. Sitting in exactly the same with a Kemp and DAG situation and have been pulling my hair out for days!

(in reply to jhocut)
Post #: 9

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> High Availability >> Cannot activate database copy Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter