Exchange Server 2007 SP3 OWA - Need "OWA" Specific Handler Mappings for Virtual Directory in IIS 7 (Full Version)

All Forums >> [Microsoft Exchange 2010] >> Outlook Web Access



Message


ckoeber -> Exchange Server 2007 SP3 OWA - Need "OWA" Specific Handler Mappings for Virtual Directory in IIS 7 (14.Feb.2012 9:53:47 PM)

Hello,


I have a Microsoft Windows Server 2008 SP2 system running Microsoft Exchange 2007 SP3. Recently we have updated our systems using the latest updates from Microsoft (testing on the development platform went without a hitch) and all of a suddent several issues cropped up. This post will be about one of them as I will post the other issues on the appropriate forums.


A major issue we are having after the updates is that our OWA clients cannot send messages via the enhanced interface (for Internet Explorer, etc.). People get messages like the following whenever basic functions like sending a message, looking up contacts, etc.:


Outlook Web Access encountered an unexpected error and was unable to handle your request.


I have tried the Remove-OwaVirtualDirectory commandlet followed by the New-OwaVirtualDirectory commandlet to no avail, the issue persists.
Upon inspection of IIS I have found that I no longer have certain Exchange related "Handler Mappings" within the "owa" virtual directory of the Default Site. Inspecting the web.config file shows me that I should have handlers and/or listed that relate to the following:




<!-- OWA HTTP Modules -->
<httpModules>			
<add type="Microsoft.Exchange.Clients.Owa.Core.OwaModule, Microsoft.Exchange.Clients.Owa" name="OwaModule"/>
</httpModules>		
<!-- OWA HTTP Handlers -->		
<httpHandlers>			
<add verb="POST,GET"	path="ev.owa"	type="Microsoft.Exchange.Clients.Owa.Core.OwaEventHandlerFactory, Microsoft.Exchange.Clients.Owa"/>
<add verb="GET,HEAD"	path="attachment.ashx"	type="Microsoft.Exchange.Clients.Owa.Core.AttachmentHandler, Microsoft.Exchange.Clients.Owa" />	
</httpHandlers>



I tried various ways of adding these back to the listing under the listing of "Handler Mappings" for the "OWA" virtual directory to no avail. Only the standard handler mappings for a NET Framework enabled IIS web server show up under the "OWA" virtual directory.


How can I get the "OWA" handler mappings back? Using the Powershell commandlets as mentioned before has not done this for me so I am wondering how this can be done.


Thanks.




Page: [1]