• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

iPhone 4s Exchange

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> Mobility >> iPhone 4s Exchange Page: [1]
Login
Message << Older Topic   Newer Topic >>
iPhone 4s Exchange - 15.Mar.2012 3:06:11 PM   
abelamorales

 

Posts: 4
Joined: 15.Mar.2012
Status: offline
[IMG]http://i42.tinypic.com/34e7r4p.jpg[/IMG]

^ -> Here is a screenshot from the ActivSync test.

I have tried inheriting permissions on AD and tried setting the password to NEVER expire, but never worked. Any help would be greatly appreciated - BTW the password is right, I believe it is something to do with the user's profile settings on AD or something b/c I created a new username and synched his email to the the new username which worked on the iPhone but then he had other issues as far as permissions to certain things so trying to figure out how to get his iPhone 4s to synch with our exchange server 2010 w/o having to change the username,

< Message edited by abelamorales -- 15.Mar.2012 3:07:32 PM >
Post #: 1
RE: iPhone 4s Exchange - 16.Mar.2012 7:18:26 AM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Hi,

Has this user been a member of a protected group? Use AdsiEdit to check if the AdminCount is set to 1. If this is the case set it to 0 and try again after replication has occured.

Regards,
Johan

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to abelamorales)
Post #: 2
RE: iPhone 4s Exchange - 16.Mar.2012 9:09:48 AM   
abelamorales

 

Posts: 4
Joined: 15.Mar.2012
Status: offline
So I changed the Administrators user group's AdminCount to 0 however when I get on PowerShell it still tells me the value is 1 using this command:

Get-ADgroup -LDAPFilter (admincount=1) | select name

< Message edited by abelamorales -- 16.Mar.2012 9:29:27 AM >

(in reply to jveldh)
Post #: 3
RE: iPhone 4s Exchange - 16.Mar.2012 10:42:49 AM   
abelamorales

 

Posts: 4
Joined: 15.Mar.2012
Status: offline
So I figured out how to edit the adminCount using ADSI Edit. The iPhone 4S now synchs to our Exchange server, so thank you for your help!

I do have a question though, can you explain WHY doing this works?

(in reply to abelamorales)
Post #: 4
RE: iPhone 4s Exchange - 17.Mar.2012 3:45:48 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Well becaause it's an security risk if accounts which are a member of, for example the administrator group, can activesync. From security perspective this is not what you want. So resetting the admincount is a temporary solution. This because the admincount will be set to 1 agsin after a while.

My advice would be to create a new account without admin privileges and attsch the mailbox to this account.

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to abelamorales)
Post #: 5
RE: iPhone 4s Exchange - 17.Mar.2012 4:23:22 PM   
abelamorales

 

Posts: 4
Joined: 15.Mar.2012
Status: offline
Here's the issue though, I and many other of my colleagues are administrators and have not had any issues with ActiveSync, however he's the only one that has had an issue. Because he is our SharePoint guy, he needs an Administrator status.

I did notice that Server 2008R2 reset the adminCount value back to 1 and his phone would still work; is it eventually going to stop working or will it continue working?

(in reply to jveldh)
Post #: 6
RE: iPhone 4s Exchange - 17.Mar.2012 5:20:46 PM   
jveldh

 

Posts: 2335
Joined: 12.Apr.2008
From: The Netherlands
Status: offline
Most times it keeps working. But it may cause some other serious issues for example: oof does not work, etc.

_____________________________

Best regards,

Johan Veldhuis

Visit my Exchange blog

(in reply to abelamorales)
Post #: 7
RE: iPhone 4s Exchange - 3.Apr.2012 5:40:40 AM   
matt.john

 

Posts: 11
Joined: 23.Mar.2012
Status: offline
FYI sometimes the domain name needs to be in all caps. Not sure why but I discovered this with some of my users who got new iPhones. I realize the OP already found a solution but this is for anyone else who finds this thread in their search.

transport companies | auto shipment
car transportation services | auto transporters

(in reply to jveldh)
Post #: 8
RE: iPhone 4s Exchange - 9.Apr.2012 12:01:39 PM   
Printing Company

 

Posts: 11
Joined: 29.Mar.2012
Status: offline
it's an security risk if accounts.So resetting the admincount is a temporary solution

(in reply to matt.john)
Post #: 9
RE: iPhone 4s Exchange - 18.Jul.2012 4:43:41 AM   
veronika13

 

Posts: 3
Joined: 18.Jul.2012
Status: offline
Yes i also agree with this ans (it's an security risk if accounts.So resetting the admincount is a temporary solution) by printing company

_____________________________

SEO Company Chandigarh | Enterprise Mobility Solutions

(in reply to abelamorales)
Post #: 10

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> Mobility >> iPhone 4s Exchange Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter