• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Creating Send connectors

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Installation >> Creating Send connectors Page: [1]
Login
Message << Older Topic   Newer Topic >>
Creating Send connectors - 24.Aug.2012 3:44:18 PM   
amit_m04

 

Posts: 8
Joined: 13.Aug.2012
Status: offline
Hello,

I have only 1 Exchange server in my Test environment.
all the emails that i send are going out on the internet.

Now what i want to do it before the email goes out on internet i want to send that email to another server to check if the email has any sensitive data and then that other server will send that email back to the exchange server to sent it out or to block it.

what are the connectors that i will have to create?

[image][/image]
Post #: 1
RE: Creating Send connectors - 24.Aug.2012 4:52:35 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Create a send connector and configure it to use the other server as a smarthost. All traffic will be sent to the other server for verification and then you must configure this "other server" to send the mail out.

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to amit_m04)
Post #: 2
RE: Creating Send connectors - 27.Aug.2012 9:36:01 AM   
amit_m04

 

Posts: 8
Joined: 13.Aug.2012
Status: offline
Thanks blackman, but i want to know if the other server is sending the message back to same exchange but on different port then how should i configure the exchange to receive the message on some other port from a particular server.

Eg:- Exchange Server and Other Server
1) Exchange server is sending the message to other server on port 25
2) other server will check the message and content and then send the message back to Exchange server on port 10026
3) Now exchange server will send the message out.


Now in this case i have created a SMTP connector to send the message to Other Server(SmartHost)
I have done the settings on the Other server to send message back to Exchange server on port 10026

but i don't know how can i configure Exchange server to receive it on 10026 from other server and send it out/where ever accordingly.

Sorry some how i don't know how to upload the image and have to explain in this way.

(in reply to de.blackman)
Post #: 3
RE: Creating Send connectors - 27.Aug.2012 10:09:13 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
On exchange, create a receive connector and configure it to listen on port 10026. Set the connector to accept connections from the IP address of the "other" server. The problem I see is that you may create a loop if you send the message back from the other server to Exchange. I recommend that you configure the other server to send the mail out to the internet.

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to amit_m04)
Post #: 4
RE: Creating Send connectors - 28.Aug.2012 9:06:45 AM   
amit_m04

 

Posts: 8
Joined: 13.Aug.2012
Status: offline
Thanks blackman, That is what i am not able to do.

Could you please guide me or give me the steps in creating a Receive connector on the same exchange server to listen on port 10026.

(in reply to de.blackman)
Post #: 5
RE: Creating Send connectors - 28.Aug.2012 12:49:07 PM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
You can use the steps outlined in the article below:

http://technet.microsoft.com/en-us/library/bb125159.aspx

Step 4 under Port simply specify the port as 10026

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to amit_m04)
Post #: 6
RE: Creating Send connectors - 28.Aug.2012 2:58:59 PM   
amit_m04

 

Posts: 8
Joined: 13.Aug.2012
Status: offline
Thank you blackman, but this link is for Exchange 2010 and i would like to do this on Exchange 2003.

(in reply to de.blackman)
Post #: 7
RE: Creating Send connectors - 30.Aug.2012 7:42:50 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Ahhhhh!! When you wrote "send connector", my mind went into Exchange 2010/2007 mode and nowhere did you mention that you were using Exchange 2003! In your case you have to create a new SMTP Virtual server on your server and configure it to accept connections on port 10026

Follow the section in the link below to create a new smtp virtual server
http://support.microsoft.com/kb/823019

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to amit_m04)
Post #: 8
RE: Creating Send connectors - 30.Aug.2012 2:23:12 PM   
amit_m04

 

Posts: 8
Joined: 13.Aug.2012
Status: offline
Thank you blackman, i will implement this and will update accordingly.

(in reply to de.blackman)
Post #: 9
RE: Creating Send connectors - 4.Sep.2012 1:06:40 PM   
amit_m04

 

Posts: 8
Joined: 13.Aug.2012
Status: offline
Hello Blackman,

I already had a Default SMTP Virtual Server
-- IP Address = All unassigned -- Port = 25
-- Access > Relay > check box Allow All computers
-- Delivery > Outbound Connection > TCP port = 25

Created New connector "To 3rd party"
-- Expand the Administrative Groups container from Exchange System Manager
-- Expanded the administrative group
-- Expand the Routing Groups container
-- Right-click the Connectors container, and then click “New”.
-- Click “SMTP Connector”
-- On the “General” tab, provide an appropriate identifying name for the connector "To 3rd party"
-- Choose “Forward all mail through”
-- Enter the IP address of 3rd party server, such as [10.208.17.206]
-- Add the "local bridgehead" server
-- On the tab "Address Space", add a wildcard address space for SMTP
-- Check “Allow messages to be”
-- Save the changes


Created New SMTP Virtual Server "from 3rd Party"
-- IP Address = All unassigned -- Advanced > Port = 10026
-- Access > Relay > check box Allow All computers
-- Delivery > Outbound Connection > TCP port = 25


In the Queues
Message Queued for deffered delivery - SMTP - from 3rd Party - Ready - 1(Number of messages)

Queue also shows
to 3rd Party [10.208.17.206] (SMTP Connector) - SMTP - from 3rd Party
to 3rd Party [10.208.17.206] (SMTP Connector) - SMTP - Default SMTP Virtual Server

The 3rd party server has received the message and has sent the message back to the same exchange server on port 10026
Now the message is not going to the external addresses and is just sitting in the queue

< Message edited by amit_m04 -- 5.Sep.2012 8:27:39 AM >

(in reply to amit_m04)
Post #: 10

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Installation >> Creating Send connectors Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter