DAG mailbox database copy fails (Full Version)

All Forums >> [Microsoft Exchange 2010] >> High Availability



Message


rynwilliams -> DAG mailbox database copy fails (19.Sep.2012 10:05:34 AM)

We have two exchange 2010 SP2 RU4 Mailbox servers. EXC03 and EXC04
We have 6 mailbox databases going from EXC03 to EXC04.
All was replicating fine when setup but about 3 weeks ago they all stopped for some reason, i have tried deleting the copies and recreating them but the copy always either fails or fails and suspended.
I have somehow managed to get a few of them working but the others just wont. The error log says that a log file is missing and to do an Update-MailboxDatabaseCopy, which i have tried but doesn't work.

My problem seems similar to the post below.

http://www.misdivision.com/blog/performing-a-manual-copy-of-a-mailbox-database-in-a-dag

A manual update cant be the only answer, there is surely something wrong here.

Any ideas?




clementrosario -> RE: DAG mailbox database copy fails (20.Sep.2012 11:35:55 AM)

Hi Williams,


Get-MailboxDatabaseCopyStatus and find the database with failed or supended status

Test-ReplicationHealth –Identity “DB_name”

suspend the copy
Suspend-MailboxDatabaseCopy –Identity “db_name\server”

Now update it from a good copy of the replication server
Update-MailboxDatabaseCopy –Identity “DB_name\Server” –DeleteExistingFiles




rynwilliams -> RE: DAG mailbox database copy fails (21.Sep.2012 7:31:11 AM)

Tried that.

The database ends up with a failed state after the synchronization.

I do get a DBCopyFailed - *Failed* after the replication health test. All others pass.

Any other ideas?




rynwilliams -> RE: DAG mailbox database copy fails (23.Sep.2012 3:31:41 PM)

Ok a bit of progress.

I have taked each database offline then completed the manual database copy, ten created the database copy in exchange.

It worked fine and started replicating.

I thin rebooted the primary server to test the failover and the replication stopped working again.

Back to stage one where none of the databases are working.

Anyone come across this before?




rynwilliams -> RE: DAG mailbox database copy fails (24.Sep.2012 10:45:15 AM)

Ok looks like the log file drive on the replicated server was full so the databases went offline after the reboot. A quick drive space increase allowed me to start the replication again and all is working fine.

So it looks as though the manual copy is the only way of getting it working, unless anyone else know of another way.




clementrosario -> RE: DAG mailbox database copy fails (25.Sep.2012 8:58:21 AM)

Excellent.


The cmdlet DeleteExistingFiles will fail if other files are present.

If the database-related files are present, you must manually remove them.




Page: [1]