• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

OMA not working - settings messed up

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2003] >> Exchange 2003 SBS >> OMA not working - settings messed up Page: [1]
Login
Message << Older Topic   Newer Topic >>
OMA not working - settings messed up - 4.Nov.2012 6:33:41 AM   
lonyl

 

Posts: 2
Joined: 4.Nov.2012
Status: offline
Hi, i have been trying for the last 3 months to fix problems with OMA. All this started after someone claiming to be an expert messed things up.

I am not an expert, so i need help solving this riddle.

I have followed numerous posts/fixes/MS support without getting any closer to the solution.

I diont know if anyone here has the skills to detect what problems i am dealing with?

This is the error i get when accessing the server https://mailserver.domainname.*/OMA on the server :

Server Error in '/OMA' Application.
Collection was modified; enumeration operation may not execute.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.InvalidOperationException: Collection was modified; enumeration operation may not execute.

Source Error:

The source code that generated this unhandled exception can only be shown when compiled in debug mode. To enable this, please follow one of the below steps, then request the URL:

1. Add a "Debug=true" directive at the top of the file that generated the error. Example:

<%@ Page Language="C#" Debug="true" %>

or:

2) Add the following section to the configuration file of your application:

<configuration>
<system.web>
<compilation debug="true"/>
</system.web>
</configuration>

Note that this second technique will cause all files within a given application to be compiled in debug mode. The first technique will cause only that particular file to be compiled in debug mode.

Important: Running applications in debug mode does incur a memory/performance overhead. You should make sure that an application has debugging disabled before deploying into production scenario.

Stack Trace:


[InvalidOperationException: Collection was modified; enumeration operation may not execute.]
System.Collections.ArrayListEnumeratorSimple.MoveNext() +7488601
Microsoft.Exchange.OMA.Tracing.OmaTrace.set_DebugOutputTracing(Boolean value) +175
Microsoft.Exchange.OMA.UserInterface.Global..ctor() +262
ASP.global_asax..ctor() +5

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) +0
System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) +86
System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) +230
System.Activator.CreateInstance(Type type, Boolean nonPublic) +67
System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +1051
System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +111
System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +221
System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +107
System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +289


Version Information: Microsoft .NET Framework Version:2.0.50727.3603; ASP.NET Version:2.0.50727.3082

If i access the server from the outside, i get this error:

Server Error in '/OMA' Application.

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>


Any help appreciated, i will, if someone is able to fix this, pay for the job.



Best regards
Lonyl
Post #: 1
RE: OMA not working - settings messed up - 5.Nov.2012 2:12:38 PM   
raphaelk

 

Posts: 2
Joined: 5.Nov.2012
Status: offline
Hum, I'm facing the same issue, since today. My CPU load is quite high due to w3wp.exe, OWA is working, but it is quite slow. I m planning a reboot tomoroow morning.

Lonyl, do you have CPU load too ?

(in reply to lonyl)
Post #: 2
RE: OMA not working - settings messed up - 6.Nov.2012 5:22:40 AM   
lonyl

 

Posts: 2
Joined: 4.Nov.2012
Status: offline
No, i don't have a high CPU-load.

I changed all the vdir's to asp. net v 1.x and now i get a different error. It's not as bad as this one, at least i get a message saying mailbox cannot be accessed.

I tried this solution:

1. Open IIS Manager
2. Navigate to Websites -> right click on "Default web site" and click on properties.
3. On the web site tab click on advanced
4. Under "Multiple identities for this website" click on the default entry and click on edit
5. I made the following changes - IP address: (All Unssigned), TCP port:80, Host Header Value: "Blank"
6. click ok and restart IIS Admin Service (warning will disconnect clients) to be sure!

When i apply this my outlook web access dissapears, also the 2 webpages hosted on the server.



Best regards
Lonyl

quote:

ORIGINAL: raphaelk

Hum, I'm facing the same issue, since today. My CPU load is quite high due to w3wp.exe, OWA is working, but it is quite slow. I m planning a reboot tomoroow morning.

Lonyl, do you have CPU load too ?

(in reply to raphaelk)
Post #: 3
RE: OMA not working - settings messed up - 7.Nov.2012 2:14:10 AM   
raphaelk

 

Posts: 2
Joined: 5.Nov.2012
Status: offline
Hi Lonyl,

I solved my OMA issue by removing all the IIS related folder.

Follow these link :

- http://searchexchange.techtarget.com/tutorial/Step-by-Step-Guide-How-to-repair-Exchange-related-IIS-virtual-directories (scroll down to have links)

After this, my OMA error was gone, but I had a message telling me that my client is older blablabla

It is an SSL issue with the virtual folder ; follow this next link http://support.microsoft.com/kb/817379/en-us
(method 2, from "Create a secondary virtual directory for Exchange server"

I hope it will solve your issu as it solved mine \o/

(in reply to lonyl)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2003] >> Exchange 2003 SBS >> OMA not working - settings messed up Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter