• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Outlook Anywhere - An error occurred while testing the NSPI RPC endpoint

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2010] >> Installation >> Outlook Anywhere - An error occurred while testing the NSPI RPC endpoint Page: [1]
Login
Message << Older Topic   Newer Topic >>
Outlook Anywhere - An error occurred while testing ... - 29.Nov.2012 7:56:07 PM   
hungrymind1200

 

Posts: 1
Joined: 29.Nov.2012
Status: offline
Greetings Exchange community. Please bear with me as this is my first exchange migration. I'm hoping that someone can assist me with a problem that is driving me absolutely insane. I have searched forums for hours and I am still unable to come up with a resolution to this problem...

For the purpose of confidentially, I will be using the contoso.com domain within this thread...

I am in the midst of a migration from Exchange 2007 SP3 to Exchange 2010 SP2 rollup4v2. Our Exchange 2010 environment consists of a single hub transport / client access server, and a single mailbox server. We are not using an edge transport server.

I am having a problem getting outlook anywhere to function properly with our non-domain outlook 2010 clients...

When setting up an email account for outlook anywhere, I am either endlessly prompted for authentication, or receive the following errors:

"The action cannot be completed. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action".
"Your server or mailbox names cannot be resolved".

Within the e-mail account setup I have proxy settings in place "msstd:mail.contoso.com" and I am using Basic authentication from the outlook client, NTLM (for outlook anywhere) on the exchange hub/cas server.

I ran the ExRCA for outlook anywhere using autodiscover. All tests pass, with the exception of the last:

Testing the Name Service Provider Interface (NSPI) on the Exchange Mailbox server.
An error occurred while testing the NSPI RPC endpoint
Attempting to ping RPC endpoint 6004 (NSPI Proxy Interface) on server HUBCAS01.internal.contoso.com.

Additional Details
The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process.



It would appear that my hubcas server is not listening on the required ports:
TCP 0.0.0.0:6001 HUBCAS01:0 LISTENING
TCP 0.0.0.0:6005 HUBCAS01:0 LISTENING
TCP 0.0.0.0:6006 HUBCAS01:0 LISTENING
TCP 0.0.0.0:6007 HUBCAS01:0 LISTENING
TCP 0.0.0.0:6008 HUBCAS01:0 LISTENING
TCP [::]:6001 HUBCAS01:0 LISTENING
TCP [::]:6005 HUBCAS01:0 LISTENING
TCP [::]:6006 HUBCAS01:0 LISTENING
TCP [::]:6007 HUBCAS01:0 LISTENING
TCP [::]:6008 HUBCAS01:0 LISTENING



RPC over HTTP Proxy feature is installed on the hub/cas server. There is no redirection set within RPC IIS vdir and SSL is required, client certificates are ignored.


I am using a trusted commercial SAN cert with the following hostnames:
mail.contoso.com
legacy.contoso.com
autodiscover.contoso.com


Here is some information that I've seen to be helpful in other forums:
[PS] C:\Windows\system32>Get-OutlookAnywhere |fl
RunspaceId : b2dc62ab-efa2-45c8-9d2f-694b5f08f343
ServerName : HUBCAS01
SSLOffloading : False
ExternalHostname : mail.contoso.com
ClientAuthenticationMethod : Ntlm
IISAuthenticationMethods : {Ntlm}
XropUrl :
MetabasePath : IIS://HUBCAS01.internal.contoso.com/W3SVC/1/ROOT/Rpc
Path : C:\Windows\System32\RpcProxy
ExtendedProtectionTokenChecking : None
ExtendedProtectionFlags : {}
ExtendedProtectionSPNList : {}
Server : HUBCAS01
AdminDisplayName :
ExchangeVersion : 0.10 (14.0.100.0)
Name : Rpc (Default Web Site)
DistinguishedName : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocols,CN=HUBCAS01,CN=Servers,CN=Excha
Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=contoso,CN=Mi
soft Exchange,CN=Services,CN=Configuration,DC=internal,DC=contoso,DC=com
Identity : HUBCAS01\Rpc (Default Web Site)
Guid : c095aba4-429d-4726-be7c-80bd1d4f765c
ObjectCategory : internal.contoso.com/Configuration/Schema/ms-Exch-Rpc-Http-Virtual-Directory
ObjectClass : {top, msExchVirtualDirectory, msExchRpcHttpVirtualDirectory}
WhenChanged : 11/21/2012 3:43:36 PM
WhenCreated : 11/21/2012 3:43:21 PM
WhenChangedUTC : 11/21/2012 8:43:36 PM
WhenCreatedUTC : 11/21/2012 8:43:21 PM
OrganizationId :
OriginatingServer : DC01.internal.contoso.com
IsValid : True
[PS] C:\Windows\system32>
[PS] C:\Windows\system32>
[PS] C:\Windows\system32> Get-outlookprovider expr |fl
RunspaceId : b2dc62ab-efa2-45c8-9d2f-694b5f08f343
CertPrincipalName :
Server :
TTL : 1
OutlookProviderFlags : None
AdminDisplayName :
ExchangeVersion : 0.1 (8.0.535.0)
Name : EXPR
DistinguishedName : CN=EXPR,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=contoso,CN=Microsoft Exchange,CN=Serv
s,CN=Configuration,DC=internal,DC=contoso,DC=com
Identity : EXPR
Guid : 83244ed9-77ec-4653-ade1-90577f6cf0c4
ObjectCategory : internal.contoso.com/Configuration/Schema/ms-Exch-Auto-Discover-Config
ObjectClass : {top, msExchAutoDiscoverConfig}
WhenChanged : 11/6/2008 1:59:25 PM
WhenCreated : 11/6/2008 1:59:25 PM
WhenChangedUTC : 11/6/2008 6:59:25 PM
WhenCreatedUTC : 11/6/2008 6:59:25 PM
OrganizationId :
OriginatingServer : DC01.internal.contoso.com
IsValid : True




Does anyone have any advice or troubleshooting tips? I'm not quite sure where to go from here. All help and feedback is greatly appreciated.

Thank you,


HungryMind1200
Post #: 1
RE: Outlook Anywhere - An error occurred while test... - 30.Nov.2012 7:44:10 AM   
de.blackman

 

Posts: 3542
Joined: 4.Apr.2005
From: Toronto, Canada
Status: offline
Change the authentication method on Outlook AnyWhere to BASIC. As a non-domain joined client, you are not authenticated to the domain so NTLM will not work.

_____________________________

Ibrahim Benna - Microsoft Exchange MVP
Forum Moderator
Navantis
@IbrahimBenna

(in reply to hungrymind1200)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2010] >> Installation >> Outlook Anywhere - An error occurred while testing the NSPI RPC endpoint Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter