Problem with Exchange 2013 Managment Shell (Full Version)

All Forums >> [Microsoft Exchange 2013] >> Installation



Message


Godaze -> Problem with Exchange 2013 Managment Shell (30.Nov.2012 5:25:32 AM)

Hi,
Recently I installed MS Exchange 2013 in WinServer2008R2 SP1. It looks everything is OK except Exchange Management Shell. when I click on EMS I got this Problem:



Welcome to the Exchange Management Shell!
Full list of cmdlets: Get-Command
Only Exchange cmdlets: Get-ExCommand
Cmdlets that match a specific string: Help *<string>*
Get general help: Help
Get help for a cmdlet: Help <cmdlet name> or <cmdlet name> -?
Show quick reference guide: QuickRef
Exchange team blog: Get-ExBlog
Show full output for a command: <command> | Format-List

Tip of the day #23:

Who isn't tired of spam? You can configure real-time block list (RBL) providers with the Exchange Management Shell by ru
nning the following two commands:

Set-IPBlockListProvidersConfig -Enabled $True -ExternalMailEnabled $True

and then

Add-IPBlockListProvider -Name <Name of RBL Provider> -LookupDomain <FQDN of RBL Provider> -AnyMatch $True

VERBOSE: Connecting to mail.bmi.local.
New-PSSession : [mail.bmi.local] Connecting to remote server mail.bmi.local failed with the following error message :
The WinRM client cannot process the request. The WinRM client tried to use Kerberos authentication mechanism, but the
destination computer (mail.bmi.local:80) returned an 'access denied' error. Change the configuration to allow Kerberos
authentication mechanism to be used or specify one of the authentication mechanisms supported by the server. To use
Kerberos, specify the local computer name as the remote destination. Also verify that the client computer and the
destination computer are joined to a domain. To use Basic, specify the local computer name as the remote destination,
specify Basic authentication and provide user name and password. Possible authentication mechanisms reported by
server: For more information, see the about_Remote_Troubleshooting Help topic.
At line:1 char:1
+ New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
gTransportException
+ FullyQualifiedErrorId : AccessDenied,PSSessionOpenFailed

Failed to connect to an Exchange server in the current site.
Enter the server FQDN where you want to connect.


I search almost same problem in any helpful website but can't solve the problem.




pjhutch -> RE: Problem with Exchange 2013 Managment Shell (24.Dec.2012 4:48:21 PM)

Exchange 2013 uses .NET Framework 4 for the Management Shell and this is not enabled during the install of Exchange 2013. You have to do the following:

Run "aspnet_regiis -ir" from C:\Windows\Microsoft.NET\Framework(64)\v4.0.30319 to register ASP.NET 4.0.

See also Exchange Blog at http://blogs.technet.com/b/theexchangeguy/archive/2012/08/13/installing-exchange-2013-preview-on-windows-server-2008-r2.aspx




Gulab -> RE: Problem with Exchange 2013 Managment Shell (28.Dec.2012 12:31:25 AM)

Any update on the issue?




troy12n -> RE: Problem with Exchange 2013 Managment Shell (7.Jan.2013 8:17:28 AM)

You have to install a server with the mailbox role before powershell will work.

Kind of dumh, eh?

This is not documented anywhere, but I figured it out the first time I installed it.




96Primera -> RE: Problem with Exchange 2013 Managment Shell (7.Nov.2013 2:01:51 PM)

yes that is correct, as the mgt shell needs/wants to connect to a mailbox server & not a CAS




Page: [1]