• RSS
  • Twitter
  • FaceBook

Exchange Server Forums

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Exchange 2013 - content index failed, service search host controller doesn't start

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Microsoft Exchange 2013] >> Management >> Exchange 2013 - content index failed, service search host controller doesn't start Page: [1]
Login
Message << Older Topic   Newer Topic >>
Exchange 2013 - content index failed, service search ho... - 3.Sep.2013 2:00:11 AM   
bart27

 

Posts: 1
Joined: 3.Sep.2013
Status: offline
Hello,

I have a problem with Exchange 2013 CU2, after update KB2874216 completely stopped searching. This problem is known: http://support.microsoft.com/kb/2879739, but it didn't resolve my issue.


Service Microsoft Exchange Search Host Controller doesn't start (Error 1067: The process terminated unexpectedly), in event log:



Log Name: Application
Source: Application Error
Event ID: 1000
Task Category: (100)
Level: Error
Description:
Faulting application name: hostcontrollerservice.exe, version: 15.0.712.0, time stamp: 0x5199c4fd
Faulting module name: KERNELBASE.dll, version: 6.2.9200.16451, time stamp: 0x50988aa6
Exception code: 0xe0434352
Fault offset: 0x000000000003811c
Faulting process id: 0x9dc
Faulting application start time: 0x01cea81afc9a0b77
Faulting application path: C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\hostcontrollerservice.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 3aacf188-140e-11e3-9410-005056bc7c05
Faulting package full name:
Faulting package-relative application ID:




And it's all. Database status:






[PS] C:\Windows\system32>Get-MailboxDatabaseCopyStatus | fl 'Content*'
ContentIndexState : Failed
ContentIndexErrorMessage : The database has been dismounted.

...


In register (HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Search Foundation for Exchange the DataDirectory field has "C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data" value.

Server and database seems to work. Everything works, except this searching. What next should I check/do/repair?

Regards,

Bart
Post #: 1
RE: Exchange 2013 - content index failed, service searc... - 8.Oct.2013 12:36:56 PM   
troy12n

 

Posts: 192
Joined: 1.Oct.2007
Status: offline
This has been a chronic issue with Exchange 2013 since it was released. On every server where the content index has failed, stop the "microsoft exchange search host controller" and the "microsoft exchange search" services. Then go to the directories where the mailbox DB is located, delete the "guid" directory, then start the "search host controller" service, then wait a few seconds and then star tthe "search" service, and that will fix it. For now anyway.I would check this every few days.

(in reply to bart27)
Post #: 2
[Deleted] - 9.Aug.2017 5:07:37 AM   
Deleted User
[Deleted by Admins]

(in reply to troy12n)
  Post #: 3

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Microsoft Exchange 2013] >> Management >> Exchange 2013 - content index failed, service search host controller doesn't start Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts


Follow TechGenix on Twitter