Issues with CAS array and outlook anywhere (Full Version)

All Forums >> [Microsoft Exchange 2010] >> Mobility



Message


SalehRam -> Issues with CAS array and outlook anywhere (29.Dec.2013 12:59:11 AM)

Hi

I have an issue getting outlook anywhere to work with 2 CAS servers configured as array and with NLB...

My setup is like this:

Server 1: EXCHHTCA1
Server 2: EXCHHTCA2
Array name: casarray.localdomain.com

Outlook anywhere is not working, and after some checking I did around I managed to get it to work on server 1, I had to change the registry on server 1 to be like that:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy\ValidPorts="EXCHHTCA1:6001-6002;EXCHHTCA1:6004

After I fixed that registry, I checked the remote connectivity analyzer and I was able to connect to the server after I manually specified the internal server 1 name instead of the whole CAS array name...

When I went to server 2 and wanted to check registry, I found some extra keys in the registry that are not existed on server 1 registry...

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy\ValidPorts="EXCHHTCA2:6001-6002;EXCHHTCA2:6004
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy\ValidPorts_AutoConfig_Exchange="casarray:6001-6004;casarray.localdomain.com:6001-6004;EXCHHTCA1:6001-6004;EXCHHTCA1.localdomain.com:6001-6004;EXCHHTCA2:6001-6004;EXCHHTCA2.localdomain.com:6001-6004;EXCHMBX1:6001-6004;EXCHMBX1.localdomain.com:6001-6004;EXCHMBX2:6001-6004;EXCHMBX2.localdomain.com:6001-6004"
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy\RedirectorDLL_EXRDRLBS="C:\\Program Files\\Microsoft\\Exchange Server\\V14\\bin\\exrdrlbs.dll"
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy\RedirectorDLL_EXRDRLBSCallOrder=dword:00000000
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy\AllowAnonymous=dword:00000001

When I do a test with remote connectivity analyzer and I specify the CAS array name, I get this error in the results:

Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server The attempt to ping the endpoint failed

I know that there is something wrong here, but I'm a bit confused at this stage, and I would appreciate any tips or help on this matter.
Also before I reach the registry, I already checked the other exchange settings and all seemed OK to me...




pjhutch -> RE: Issues with CAS array and outlook anywhere (7.Jan.2014 10:59:15 AM)

Do not use the cas array name for load balanced OWA or Outlook Anywhere, setup a different FQDN for outlook anywhere and make sure tht you have a valid SSL Certificate on both servers for HTTPS over RPC to work. Do not use self-signed or internal certificates as it needs a trusted certificat to work. You can test connectivity using this web site:

https://testconnectivity.microsoft.com/




Page: [1]